summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-04-12 17:30:35 +0000
committerTilman Klar <phoenix@gentoo.org>2003-04-12 17:30:35 +0000
commitb6ed958bd6341876831993274abf79f6dd4e26da (patch)
treecf259720379edd80ea0c1bb5f007f5dcdfa2b4a7 /app-emulation
parentsmall fix (diff)
downloadhistorical-b6ed958bd6341876831993274abf79f6dd4e26da.tar.gz
historical-b6ed958bd6341876831993274abf79f6dd4e26da.tar.bz2
historical-b6ed958bd6341876831993274abf79f6dd4e26da.zip
Added support for USE="nptl"
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog4
-rw-r--r--app-emulation/wine/wine-20030411.ebuild8
2 files changed, 7 insertions, 5 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 3369a3e47593..81a3c5b57449 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.36 2003/04/12 16:02:23 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.37 2003/04/12 17:30:35 phoenix Exp $
*wine-20020411 (11 Apr 2003)
12 Apr 2002; Tilman Klar <phoenix@gentoo.org> wine-20020411.ebuild :
- Tagged this version stable ("x86").
+ Tagged this version stable ("x86"). Added support for USE="nptl".
11 Apr 2002; Tilman Klar <phoenix@gentoo.org> wine-20020411.ebuild,
files/digest-wine-20020411, files/wine-20020411-* :
diff --git a/app-emulation/wine/wine-20030411.ebuild b/app-emulation/wine/wine-20030411.ebuild
index 268597477bee..0d20711166a4 100644
--- a/app-emulation/wine/wine-20030411.ebuild
+++ b/app-emulation/wine/wine-20030411.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030411.ebuild,v 1.2 2003/04/12 16:02:23 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20030411.ebuild,v 1.3 2003/04/12 17:30:35 phoenix Exp $
inherit eutils base
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.winehq.com/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc"
-IUSE="nas arts cups opengl alsa tcltk"
+IUSE="nas arts cups opengl alsa tcltk nptl"
DEPEND="sys-devel/gcc
sys-devel/flex
@@ -36,7 +36,9 @@ src_compile() {
cd ${S}
local myconf
- use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ use opengl && myconf="$myconf --enable-opengl" || myconf="$myconf --disable-opengl"
+ use nptl && myconf="$myconf --with-nptl" || myconf="$myconf --without-nptl"
+
[ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
# there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected