summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-15 01:27:50 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-15 01:27:50 +0000
commitb8f4599ef51b424876002328a3479110548d17d4 (patch)
treea3d61a146b186e6e2bb7c3baeb5c8e050ecdc081 /app-emulation
parentinitial commit (diff)
downloadhistorical-b8f4599ef51b424876002328a3479110548d17d4.tar.gz
historical-b8f4599ef51b424876002328a3479110548d17d4.tar.bz2
historical-b8f4599ef51b424876002328a3479110548d17d4.zip
bumped up release numbers of packages that were updated with the tcl/tk
update
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/files/digest-wine-20011004-r11
-rw-r--r--app-emulation/wine/wine-20011004-r1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/wine/files/digest-wine-20011004-r1 b/app-emulation/wine/files/digest-wine-20011004-r1
new file mode 100644
index 000000000000..fd5646ad00e2
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20011004-r1
@@ -0,0 +1 @@
+MD5 3a23a634b7eff17a1631571f7be25421 Wine-20011004.tar.gz 6467584
diff --git a/app-emulation/wine/wine-20011004-r1.ebuild b/app-emulation/wine/wine-20011004-r1.ebuild
new file mode 100644
index 000000000000..43a846ea2e8c
--- /dev/null
+++ b/app-emulation/wine/wine-20011004-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20011004-r1.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+ #http://twine.codeweavers.com/~mpilka/winesetuptk/winesetuptk-${WSV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+ #http://wine.codeweavers.com/winesetuptk.shtml"
+
+# need to add: db2html, db2ps, db2pdf for building the docs
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ net-print/cups
+ >=media-libs/freetype-2.0.0"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ if [ "`use opengl`" ]
+ then
+ myconf="--enable-opengl"
+ else
+ myconf="--disable-opengl"
+ fi
+
+ if [ -z $DEBUG ]
+ then
+ myconf="$myconf --disable-trace --disable-debug"
+ else
+ myconf="$myconf --enable-trace --enable-debug"
+ fi
+
+ ./configure --prefix=/opt/wine --sysconfdir=/etc/opt/wine \
+ --infodir=/opt/info --mandir=/opt/man \
+ --host=${CHOST} --enable-curses ${myconf} || die
+
+ make depend || die
+ make || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/opt/wine install || die
+ insinto /etc/opt/wine
+ newins ${FILESDIR}/wine.conf config
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README WARRANTY
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/wine.env 90wine
+
+}
+