summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Veber <coronalvr@gentoo.org>2003-09-08 03:50:34 +0000
committerAlex Veber <coronalvr@gentoo.org>2003-09-08 03:50:34 +0000
commitbb34423bb97513a36194e6f28180a310e86e3949 (patch)
tree6bb66a1b91ad658dca30e7fe354d9ef1b2bd16b3 /app-emulation
parentbump (diff)
downloadhistorical-bb34423bb97513a36194e6f28180a310e86e3949.tar.gz
historical-bb34423bb97513a36194e6f28180a310e86e3949.tar.bz2
historical-bb34423bb97513a36194e6f28180a310e86e3949.zip
bump
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/nwwine/Manifest5
-rw-r--r--app-emulation/nwwine/files/digest-nwwine-200307093
-rw-r--r--app-emulation/nwwine/metadata.xml8
-rw-r--r--app-emulation/nwwine/nwwine-20030709.ebuild122
4 files changed, 136 insertions, 2 deletions
diff --git a/app-emulation/nwwine/Manifest b/app-emulation/nwwine/Manifest
index a680e3329822..77bc90dd6ef1 100644
--- a/app-emulation/nwwine/Manifest
+++ b/app-emulation/nwwine/Manifest
@@ -1,7 +1,8 @@
MD5 bfefd9c14cc5af781f3549413924723c nwwine-20020703.ebuild 3168
MD5 c2cbd847df48a2b45d0dba165d8dfaac nwwine-20030618.ebuild 3327
-MD5 723896ccd515176d899816ff63d6bd6f nwwine-20030709.ebuild 3288
-MD5 0966d88267a8898bf41f05ce9aacf894 ChangeLog 833
+MD5 0e0eb5dd147d43f5338b47228568fec4 nwwine-20030709.ebuild 3397
+MD5 9eb3e86c1ea013e9854e1d42256bd453 ChangeLog 954
+MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 cec34c252d6533f2810215a52b8da2ff files/digest-nwwine-20020703 68
MD5 da29c2497d9360990085f8b6d248f9a5 files/digest-nwwine-20030618 293
MD5 f1568a96d35c3362af94ca9370e9a24d files/digest-nwwine-20030709 226
diff --git a/app-emulation/nwwine/files/digest-nwwine-20030709 b/app-emulation/nwwine/files/digest-nwwine-20030709
new file mode 100644
index 000000000000..814e5deb3a95
--- /dev/null
+++ b/app-emulation/nwwine/files/digest-nwwine-20030709
@@ -0,0 +1,3 @@
+MD5 9f71d94bdd166bf6ad5d29fd1f3c067f nwwine-20030618-misc.tar.bz2 4603
+MD5 6e282b59a9b861b493a430e6064da7f6 nwwine-based-on-20030709.tar.gz 9138320
+MD5 af8da46a0e51578ff1e18e399141d628 nwwine-20030618-fake_windows.tar.bz2 500
diff --git a/app-emulation/nwwine/metadata.xml b/app-emulation/nwwine/metadata.xml
new file mode 100644
index 000000000000..6e1b347e6c04
--- /dev/null
+++ b/app-emulation/nwwine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>wine</herd>
+<longdescription>
+This package allows you to run many winodws applications in your *nix environment. It can be used either with your existing Windows instalation or without it.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/nwwine/nwwine-20030709.ebuild b/app-emulation/nwwine/nwwine-20030709.ebuild
new file mode 100644
index 000000000000..e97de5d49f85
--- /dev/null
+++ b/app-emulation/nwwine/nwwine-20030709.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/nwwine/nwwine-20030709.ebuild,v 1.1 2003/09/08 03:50:29 coronalvr Exp $
+
+DESCRIPTION="A special version of wine for the Never Winter Nights toolkit"
+SRC_URI="mirror://gentoo/nwwine-20030618-misc.tar.bz2
+ ftp://128.173.184.249/Linux/nwwine/nwwine-based-on-${PV}.tar.gz
+ mirror://gentoo/nwwine-20030618-fake_windows.tar.bz2"
+
+HOMEPAGE="http://www.winehq.com/ http://republika.pl/nwnlinux/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk"
+S=${WORKDIR}/nwwine-based-on-${PV}
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=sys-apps/sed-4
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+RDEPEND=""
+
+src_compile() {
+ cd ${S}/dlls/opengl32
+
+ cd ${S}
+ #fix the nwwine wrapper
+ mv nwwine.sh nwwine.old
+ sed -e "s:wine:/usr/lib/nwwine/bin/wine:" nwwine.old > nwwine.sh
+
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ # use the default setting in ./configure over the /etc/make.conf setting
+ unset CFLAGS CXXFLAGS
+
+ ./configure --prefix=/usr/lib/${PN} \
+ --sysconfdir=/etc/${PN} \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die "configure failed"
+
+ # No parallel make
+ make depend all || die "make depend all failed"
+ cd programs && emake || die
+}
+
+src_install () {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/${PN}"
+
+ ### Install wine to ${D}
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/${PN}/.data
+ # set up fake_windows
+ dodir /usr/lib/${PN}/.data
+ cd ${D}/usr/lib/nwwine/.data
+ cp -r ${WORKDIR}/fake_windows .
+
+ # copy config
+ cp ${WORKDIR}/config .
+
+ # put winedefault.reg into .data
+ cp ${S}/winedefault.reg .
+
+ # move wrappers to bin/
+ cd ${WORKDIR}
+ insinto /usr/bin
+ dobin regedit-nwwine nwwine
+ rm regedit-nwwine nwwine
+
+ # set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/${PN}/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # manpage setup
+ mv ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # remove the executable flag from those libraries.
+ cd ${D}/usr/lib/${PN}/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/nwwine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-nwwine to import registry files into the"
+ einfo "wine registry."
+ einfo ""
+ einfo "If you have bugs, enhancements or patches"
+ einfo "report a bug and assign it to wine@gentoo.org"
+}