summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2005-09-19 16:45:42 +0000
committerChris Bainbridge <chrb@gentoo.org>2005-09-19 16:45:42 +0000
commitc32d7a192eb3b63b5f4407dd95e0027be9e8511a (patch)
tree78c4089be1bcd678a8598d72e487b6bdc0b90aec /app-emulation
parentFixed deps for glade-sharp and gtk-sharp. bug #106508 (diff)
downloadhistorical-c32d7a192eb3b63b5f4407dd95e0027be9e8511a.tar.gz
historical-c32d7a192eb3b63b5f4407dd95e0027be9e8511a.tar.bz2
historical-c32d7a192eb3b63b5f4407dd95e0027be9e8511a.zip
Version bump
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/ChangeLog8
-rw-r--r--app-emulation/xen/Manifest4
-rw-r--r--app-emulation/xen/files/digest-xen-3.0.0_pre200509191
-rw-r--r--app-emulation/xen/xen-3.0.0_pre20050919.ebuild94
4 files changed, 105 insertions, 2 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index cef734c5400b..66a51c4b29d4 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.1 2005/09/07 18:18:59 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.2 2005/09/19 16:45:42 chrb Exp $
+
+*xen-3.0.0_pre20050919 (19 Sep 2005)
+
+ 19 Sep 2005; Chris Bainbridge <chrb@gentoo.org>
+ +xen-3.0.0_pre20050919.ebuild:
+ Version bump
*xen-3.0.0_pre20050906 (07 Sep 2005)
*xen-2.0.7 (07 Sep 2005)
diff --git a/app-emulation/xen/Manifest b/app-emulation/xen/Manifest
index 2e51fa7f6aa2..30f04d1c107c 100644
--- a/app-emulation/xen/Manifest
+++ b/app-emulation/xen/Manifest
@@ -1,10 +1,12 @@
-MD5 625c815b939fd0fdcd0d12f651f1a414 ChangeLog 537
+MD5 ba5fa3317509eeb469019da0a74c06e6 ChangeLog 674
MD5 23ec60d5040f966fda250a47d8903428 metadata.xml 252
MD5 127f02804f9b2029eff0f18830d17661 xen-2.0.7.ebuild 2696
MD5 6bdec80c76754e7f3a07642ac527bcd0 xen-3.0.0_pre20050906.ebuild 2608
+MD5 837501dd56f3c0ffb462217c550f74e2 xen-3.0.0_pre20050919.ebuild 2618
MD5 16d372298e94a8eef72c1943b1ed5561 files/xend-conf 347
MD5 8fdc16ee0ddc5db42c85e4a3b7484135 files/xend-init 746
MD5 9f441f0eaec0c4a04af82df233dadbe0 files/xendomains-conf 22
MD5 5caa93c9ec5394b7ae89a3bb0c038d6b files/xendomains-init 1221
MD5 1d06bd45f1c44612f4ab57e8d7c303ac files/digest-xen-3.0.0_pre20050906 75
+MD5 7dc7b60a7e88657c9141d4154e41458c files/digest-xen-3.0.0_pre20050919 75
MD5 6eaea330ed78459069eb5ba608e654dd files/digest-xen-2.0.7 63
diff --git a/app-emulation/xen/files/digest-xen-3.0.0_pre20050919 b/app-emulation/xen/files/digest-xen-3.0.0_pre20050919
new file mode 100644
index 000000000000..b07b65120596
--- /dev/null
+++ b/app-emulation/xen/files/digest-xen-3.0.0_pre20050919
@@ -0,0 +1 @@
+MD5 e6cba3e0b82c6ca4677a9d101b48bfbb xen-unstable-20050919.tar.bz2 3406996
diff --git a/app-emulation/xen/xen-3.0.0_pre20050919.ebuild b/app-emulation/xen/xen-3.0.0_pre20050919.ebuild
new file mode 100644
index 000000000000..9266f75e2872
--- /dev/null
+++ b/app-emulation/xen/xen-3.0.0_pre20050919.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.0_pre20050919.ebuild,v 1.1 2005/09/19 16:45:42 chrb Exp $
+
+inherit mount-boot
+
+DESCRIPTION="The Xen virtual machine monitor and Xend daemon"
+HOMEPAGE="http://xen.sourceforge.net"
+DATE="20050919"
+SRC_URI="mirror://gentoo/xen-unstable-${DATE}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc debug"
+
+DEPEND="sys-apps/iproute2
+ net-misc/bridge-utils
+ dev-lang/python
+ net-misc/curl
+ sys-libs/zlib
+ doc? (
+ dev-tex/latex2html
+ media-gfx/transfig
+ )"
+
+S="${WORKDIR}/xen-unstable-${DATE}"
+
+src_compile() {
+ local myopt
+ if use debug; then
+ myopt="${myopt} debug=y"
+ fi
+
+ unset CFLAGS
+ make ${myopt} -C xen || die "compiling xen failed"
+ make ${myopt} -C tools || die "compiling tools failed"
+
+ if use doc; then
+ sh ./docs/check_pkgs || die "package check failed"
+ make ${myopt} -C docs || die "compiling docs failed"
+ fi
+
+}
+
+src_install() {
+ make DESTDIR=${D} -C xen install || die "installing xen failed"
+
+ make DESTDIR=${D} XEN_PYTHON_NATIVE_INSTALL=1 -C tools install \
+ || die "installing tools failed"
+
+ if use doc; then
+ make DESTDIR=${D} -C docs install \
+ || die "installing docs failed"
+ # Rename doc/xen to the Gentoo-style doc/xen-x.y
+ mv ${D}/usr/share/doc/{${PN},${PF}}
+ fi
+
+ # bind xend to localhost per default
+ sed -i -e "s/\((xend-address *\)'')/\1\'localhost\')/" \
+ ${D}/etc/xen/xend-config.sxp
+
+ newinitd ${FILESDIR}/xend-init xend
+ newconfd ${FILESDIR}/xend-conf xend
+ newconfd ${FILESDIR}/xendomains-conf xendomains
+ newinitd ${FILESDIR}/xendomains-init xendomains
+
+ # install kernel source patches
+ dodir /usr/share/xen/patches
+ rm patches/linux-2.6.12/patch-2.6.12.5
+ cd patches
+ for x in *; do tar -jcvf ${D}/usr/share/xen/patches/${x}.tar.bz2 ${x}/; done
+ cd ..
+
+ # we need to do whatever mkbuildtree would've done for each platform
+ # linux-2.6: copy public include files, and xenstored.h
+ mkdir linux-2.6-xen-sparse/include/asm-xen/xen-public
+ rm xen/include/public/COPYING
+ cp -dpPR xen/include/public/* linux-2.6-xen-sparse/include/asm-xen/xen-public
+ cp -dpP tools/xenstore/xenstored.h linux-2.6-xen-sparse/include/asm-xen/linux-public
+ # fixme: insert code for other sparse trees here
+
+ # install xen kernel sparse trees
+ for x in *-xen-sparse; do
+ if [ -e ${x}/mkbuildtree ]; then rm ${x}/mkbuildtree; fi
+ tar -jcvf ${D}/usr/share/xen/${x}.tar.bz2 -C ${x} .
+ done
+
+}
+
+pkg_postinst() {
+ einfo "Please visit the Xen and Gentoo wiki:"
+ einfo "http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+}