summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-10 23:07:01 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-10 23:07:01 +0000
commitffd4723c78aed432ccefb752e3eb389f1ec4b481 (patch)
tree5cfb5305e5d28257ff95c38e1ac27c6c16057403 /app-emulation
parentVersion bump #129240 by Duncan. (diff)
downloadhistorical-ffd4723c78aed432ccefb752e3eb389f1ec4b481.tar.gz
historical-ffd4723c78aed432ccefb752e3eb389f1ec4b481.tar.bz2
historical-ffd4723c78aed432ccefb752e3eb389f1ec4b481.zip
fix building on amd64
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/Manifest12
-rw-r--r--app-emulation/wine/wine-0.9.11.ebuild17
2 files changed, 18 insertions, 11 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 246b89b8d2fe..b719768d1ca0 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -133,9 +133,9 @@ SHA256 1e938dc1fa681a24126e5aa334dc73e3a02a5410781bbea641d5fbf0ca61401e wine-0.9
MD5 1ecfc5fed64aebe42b95c70761331a6d wine-0.9.10.ebuild 3489
RMD160 dc1a22106793861ad2036385fa021ca9dd684366 wine-0.9.10.ebuild 3489
SHA256 b9cd6ccaaed8d78f57894cf675a43a33e3eb9c64c31a4c38622bbda05137b5b9 wine-0.9.10.ebuild 3489
-MD5 fe663841f26d98e14f4a000afd28a680 wine-0.9.11.ebuild 3522
-RMD160 e88310a2b54cda2af8b595dc15660744679c30cf wine-0.9.11.ebuild 3522
-SHA256 aa3a6190423f9f0f97ee8d83be48bd3483e826bdb7386f1ed92edb19390172e9 wine-0.9.11.ebuild 3522
+MD5 39decb2dea313a0adf4721a57405bd25 wine-0.9.11.ebuild 3788
+RMD160 0ae964c25aa86ad42fe48894621ee1a0b89e270a wine-0.9.11.ebuild 3788
+SHA256 211b5b277fd93d70e059d4f1d0cb0d40f22528a5a0eb656f7715db2f6d2d6171 wine-0.9.11.ebuild 3788
MD5 0e8a939a0799b82181ee17f084caf7eb wine-0.9.2.ebuild 4161
RMD160 32af02785815020bd693318786246cd46ea8107b wine-0.9.2.ebuild 4161
SHA256 aa516a61dd7eaa622a5b0e8cd74646371371f13a2118cf6989f88eb7a75e2268 wine-0.9.2.ebuild 4161
@@ -199,7 +199,7 @@ SHA256 e08dfbc889806d6eb63eda6d255f29afb2921123703cd04682533e817f60e182 wine-999
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
-iD8DBQFEOUlg2+ySkm8kpY0RAiToAJ9GGjcZPbpuNy+HRbjHwzWHCFx1YwCdGmA4
-XE3ljiX2A4q8/PnMp38GNQ4=
-=WQJq
+iD8DBQFEOuUk2+ySkm8kpY0RAryPAKCGYVo/3j/g9hDGTOJeFpkx0UXwxgCff27t
+NGyd8UuAWlY+zl6WMLqJtz8=
+=wYXr
-----END PGP SIGNATURE-----
diff --git a/app-emulation/wine/wine-0.9.11.ebuild b/app-emulation/wine/wine-0.9.11.ebuild
index a682bc8fcabb..24be12070bfe 100644
--- a/app-emulation/wine/wine-0.9.11.ebuild
+++ b/app-emulation/wine/wine-0.9.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.11.ebuild,v 1.3 2006/04/09 17:49:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.11.ebuild,v 1.4 2006/04/10 23:07:01 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* -amd64 ~x86"
+KEYWORDS="-* ~amd64 ~x86"
IUSE="alsa arts cups debug esd gif glut jack jpeg lcms ldap nas ncurses opengl oss scanner truetype xml X"
RESTRICT="test" #72375
@@ -59,9 +59,8 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex"
-pkg_setup() {
- use amd64 && has_multilib_profile && export ABI=x86
-}
+# this will not build as 64bit code
+export ABI=x86
src_unpack() {
unpack wine-${PV}.tar.bz2
@@ -71,6 +70,14 @@ src_unpack() {
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+
+ # disable X include / lib searching as we setup our toolchain
+ # to properly locate the files ... otherwise, it'll use the host
+ # `xmkmf` binary which reports 'lib64' on amd64. boo!
+ sed -i \
+ -e '/^x_includes=/s:=NONE:=:' \
+ -e '/^x_libraries=/s:=NONE:=:' \
+ configure || die
}
config_cache() {