summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-07 02:46:48 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-07 02:46:48 +0000
commit3a1252cd0ddacc9c76354ff831f2df15f7e0b54a (patch)
tree7a9cb18a0df39debcff997baa657a7146d61078e /app-forensics/rkhunter/rkhunter-1.1.7.ebuild
parentLICENSE fix (diff)
downloadhistorical-3a1252cd0ddacc9c76354ff831f2df15f7e0b54a.tar.gz
historical-3a1252cd0ddacc9c76354ff831f2df15f7e0b54a.tar.bz2
historical-3a1252cd0ddacc9c76354ff831f2df15f7e0b54a.zip
Updated to use bash-completion.eclass
Diffstat (limited to 'app-forensics/rkhunter/rkhunter-1.1.7.ebuild')
-rw-r--r--app-forensics/rkhunter/rkhunter-1.1.7.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/app-forensics/rkhunter/rkhunter-1.1.7.ebuild b/app-forensics/rkhunter/rkhunter-1.1.7.ebuild
index 728447ee0663..cd910b7e2901 100644
--- a/app-forensics/rkhunter/rkhunter-1.1.7.ebuild
+++ b/app-forensics/rkhunter/rkhunter-1.1.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.1.7.ebuild,v 1.5 2004/10/02 22:20:10 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.1.7.ebuild,v 1.6 2004/11/07 02:46:48 ka0ttic Exp $
+
+inherit bash-completion
DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
HOMEPAGE="http://www.rootkit.org/"
@@ -35,8 +37,7 @@ src_install() {
exeinto /etc/cron.daily
newexe ${FILESDIR}/rkhunter.cron rkhunter
- insinto /usr/share/bash-completion
- newins ${FILESDIR}/${PN}.bash-completion ${PN}
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion ${PN}
}
pkg_postinst() {
@@ -44,11 +45,7 @@ pkg_postinst() {
einfo "A cron script has been installed to /etc/cron.daily/rkhunter."
einfo "To enable it, edit /etc/cron.daily/rkhunter and follow the"
einfo "directions."
- echo
- einfo "To enable bash command-line completion for rkhunter, execute"
- einfo "the following command as root:"
- einfo " ln -s /usr/share/bash-completion/rkhunter /etc/bash_completion.d/"
- echo
+ bash-completion_pkg_postinst
}
pkg_prerm() {