summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-07-04 09:25:40 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-07-04 09:25:40 +0000
commit7ba0dfe780b4faf5ed4c8d5d0e35435125d58da1 (patch)
tree2ec15dfa9371e61fdb41a4ac1b2eb420682c2096 /app-i18n/anthy
parentAdded ~amd64 ~sparc. (diff)
downloadhistorical-7ba0dfe780b4faf5ed4c8d5d0e35435125d58da1.tar.gz
historical-7ba0dfe780b4faf5ed4c8d5d0e35435125d58da1.tar.bz2
historical-7ba0dfe780b4faf5ed4c8d5d0e35435125d58da1.zip
new upstream release
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/ChangeLog7
-rw-r--r--app-i18n/anthy/Manifest16
-rw-r--r--app-i18n/anthy/anthy-5500.ebuild71
-rw-r--r--app-i18n/anthy/files/digest-anthy-55001
4 files changed, 82 insertions, 13 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 671a87f2deda..de90422e0113 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.20 2004/06/24 21:43:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.21 2004/07/04 09:25:40 hattya Exp $
+
+*anthy-5500 (04 Jul 2004)
+
+ 04 Jul 2004; Akinori Hattori <hattya@gentoo.org> +anthy-5500.ebuild:
+ new upstream release.
23 Jun 2004; <matsuu@gentoo.org> anthy-5100b.ebuild:
Marked amd64 as stable.
diff --git a/app-i18n/anthy/Manifest b/app-i18n/anthy/Manifest
index 176c9b45eccd..2aab4a48224a 100644
--- a/app-i18n/anthy/Manifest
+++ b/app-i18n/anthy/Manifest
@@ -1,21 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 9bd1778b19a45d016aa0fcaa8cd3fd8e ChangeLog 3363
+MD5 7accab0b9458fbe32e60cbdd0a4603a4 ChangeLog 3484
MD5 ea40c81232601cb38dba3a21b71c4f3d anthy-4300b.ebuild 946
MD5 7b55893f9e54a2bb3884cc7838404d19 anthy-4700.ebuild 945
-MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 a392e3bca82eeb9717c1f14cba2ddcd5 anthy-5100.ebuild 1433
MD5 d55a20ea7c2ce3cc93b757b1ad447632 anthy-5100b.ebuild 1457
+MD5 332193569c0da975ddd961c023215d42 anthy-5500.ebuild 1584
+MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 83e271d277525e627be3756f01c7010e files/digest-anthy-4300b 64
MD5 18278f8fc1cafd5d0c0047982c68142f files/digest-anthy-4700 63
MD5 686b7ab577ef2ec94a328dade8055bb6 files/digest-anthy-5100 63
MD5 0929884906bad3f7f4b85908b5425ba8 files/digest-anthy-5100b 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFA33cpHTu7gpaalycRArKPAJ9+g2S8a+SPNtXqUYjEsMYrtKPiIQCdEeBQ
-3CFvwN2N+p1kuoTCsdYWsr4=
-=6jfL
------END PGP SIGNATURE-----
+MD5 a43bee494b9bf2ac632a52d8dd686722 files/digest-anthy-5500 63
diff --git a/app-i18n/anthy/anthy-5500.ebuild b/app-i18n/anthy/anthy-5500.ebuild
new file mode 100644
index 000000000000..cfb59ab81072
--- /dev/null
+++ b/app-i18n/anthy/anthy-5500.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-5500.ebuild,v 1.1 2004/07/04 09:25:40 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/10139/${P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc"
+SLOT="0"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy-ss"
+
+# Anthy can not compile with sandbox since version 5209.
+# It always causes SEGV at making mkanthydic.
+SANDBOX_DISABLED="1"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy/files/digest-anthy-5500 b/app-i18n/anthy/files/digest-anthy-5500
new file mode 100644
index 000000000000..7897ebd2113b
--- /dev/null
+++ b/app-i18n/anthy/files/digest-anthy-5500
@@ -0,0 +1 @@
+MD5 ce1f4fb93effe9b772b67300826cc82b anthy-5500.tar.gz 1547024