summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-07-25 07:20:47 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-07-25 07:20:47 +0000
commit14057d227ebfafa539d58c365efc2dfc5d10b57a (patch)
tree3272f4fb6a907017cd77e34bdcab06a43e588e5e /app-i18n
parentInitial submit for shoutcast-server-bin. Assigning as maintainer. Closes bu... (diff)
downloadhistorical-14057d227ebfafa539d58c365efc2dfc5d10b57a.tar.gz
historical-14057d227ebfafa539d58c365efc2dfc5d10b57a.tar.bz2
historical-14057d227ebfafa539d58c365efc2dfc5d10b57a.zip
version bump.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5523.ebuild69
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-55231
4 files changed, 79 insertions, 2 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index ac40b0df36fe..46b252d7b7c9 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.36 2004/07/18 13:04:51 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.37 2004/07/25 07:20:47 hattya Exp $
+
+*anthy-ss-5523 (25 Jul 2004)
+
+ 25 Jul 2004; Akinori Hattori <hattya@gentoo.org> +anthy-ss-5523.ebuild:
+ version bump.
18 Jul 2004; Akinori Hattori <hattya@gentoo.org> -anthy-ss-5326.ebuild,
-anthy-ss-5330.ebuild:
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 5f6c52ebc849..34e502b2a8aa 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,9 +1,11 @@
-MD5 ec5d8fb3ca16770377b4212c89f251cf ChangeLog 5026
+MD5 5c9092789eac676accd394b634076647 ChangeLog 5147
MD5 440a66b95feb83768aec410bfd833a4e anthy-ss-5406.ebuild 1651
MD5 908f95bcee0ac6ee56a960457dfb2828 anthy-ss-5414.ebuild 1651
MD5 e9eb56a3ae3308b1657b05d6cc6e329d anthy-ss-5516.ebuild 1650
+MD5 134e67bcaecac79d949afa5eb9672eac anthy-ss-5523.ebuild 1516
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 5cf47066ec69dd7bf5cb5608655b26ed files/digest-anthy-ss-5406 63
MD5 7b897d744e2bdb8daebdcbe4ff258cff files/digest-anthy-ss-5414 63
MD5 ae0b002102ce35af49630eaab916579b files/digest-anthy-ss-5516 63
+MD5 c9253a102c9b0a8603aa76db6739bc44 files/digest-anthy-ss-5523 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5523.ebuild b/app-i18n/anthy-ss/anthy-ss-5523.ebuild
new file mode 100644
index 000000000000..dd5802ad5a58
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5523.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5523.ebuild,v 1.1 2004/07/25 07:20:47 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/10478/${MY_P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5523 b/app-i18n/anthy-ss/files/digest-anthy-ss-5523
new file mode 100644
index 000000000000..00916c08e865
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5523
@@ -0,0 +1 @@
+MD5 d0c0bcdbc99f455d2ae13a43ff972097 anthy-5523.tar.gz 1546698