summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-04-23 17:51:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-04-23 17:51:27 +0000
commit30522d7d9421368db79a6c826e04716595cbd123 (patch)
treeee5d895f848f19dce1954878b81e1663cce99104 /app-i18n
parentVersion bumped. (diff)
downloadhistorical-30522d7d9421368db79a6c826e04716595cbd123.tar.gz
historical-30522d7d9421368db79a6c826e04716595cbd123.tar.bz2
historical-30522d7d9421368db79a6c826e04716595cbd123.zip
Version bumped.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog7
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.2.1.ebuild54
-rw-r--r--app-i18n/ibus-pinyin/ChangeLog7
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.3.3.ebuild51
4 files changed, 117 insertions, 2 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index bd9feb614e06..2a3e58730f2f 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.19 2010/03/13 07:11:38 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.20 2010/04/23 17:51:08 matsuu Exp $
+
+*ibus-anthy-1.2.1 (23 Apr 2010)
+
+ 23 Apr 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-anthy-1.2.1.ebuild:
+ Version bumped.
*ibus-anthy-1.2.0.20100313 (13 Mar 2010)
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.2.1.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.2.1.ebuild
new file mode 100644
index 000000000000..7c46c7c02c16
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.2.1.ebuild,v 1.1 2010/04/23 17:51:08 matsuu Exp $
+
+EAPI=2
+PYTHON_DEPEND="2:2.5"
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2.0.20090904
+ app-i18n/anthy
+ >=dev-python/pygtk-2.15.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ elog
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ elog
+ elog "# emerge app-dicts/kasumi"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-pinyin/ChangeLog b/app-i18n/ibus-pinyin/ChangeLog
index 15dc73ec8ad6..4325fcc7ff33 100644
--- a/app-i18n/ibus-pinyin/ChangeLog
+++ b/app-i18n/ibus-pinyin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-pinyin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.20 2010/04/13 16:04:54 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.21 2010/04/23 17:51:27 matsuu Exp $
+
+*ibus-pinyin-1.3.3 (23 Apr 2010)
+
+ 23 Apr 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-pinyin-1.3.3.ebuild:
+ Version bumped.
*ibus-pinyin-1.3.2 (13 Apr 2010)
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.3.3.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.3.3.ebuild
new file mode 100644
index 000000000000..d7763db543d3
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ibus-pinyin-1.3.3.ebuild,v 1.1 2010/04/23 17:51:27 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="sqlite"
+inherit eutils python
+
+PYDB_TAR="pinyin-database-1.2.99.tar.bz2"
+DESCRIPTION="Chinese PinYin IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz
+ http://ibus.googlecode.com/files/${PYDB_TAR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ sys-apps/util-linux
+ dev-libs/libsigc++:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_prepare() {
+ cp "${DISTDIR}/${PYDB_TAR}" "${S}"/data/db/open-phrase/ || die
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) --enable-db-open-phrase || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}