summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-07-12 04:22:22 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-07-12 04:22:22 +0000
commitc4f487a69689e73230b86c85eed6fb3f4a113687 (patch)
tree5759083624da87d6ef19e985e904ca123b179b20 /app-laptop/pbbuttonsd
parentstable on mips (diff)
downloadhistorical-c4f487a69689e73230b86c85eed6fb3f4a113687.tar.gz
historical-c4f487a69689e73230b86c85eed6fb3f4a113687.tar.bz2
historical-c4f487a69689e73230b86c85eed6fb3f4a113687.zip
Added check for INPUT_EVDEV for bug #98050.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog5
-rw-r--r--app-laptop/pbbuttonsd/Manifest4
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild16
3 files changed, 20 insertions, 5 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index d3c343035b54..b7761fe9afe4 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.26 2005/07/11 22:41:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.27 2005/07/12 04:22:22 josejx Exp $
+
+ 12 Jul 2005; Joseph Jezak <josejx@gentoo.org> pbbuttonsd-0.7.0.ebuild:
+ Added check for INPUT_EVDEV for bug #98050.
*pbbuttonsd-0.7.0 (11 Jul 2005)
diff --git a/app-laptop/pbbuttonsd/Manifest b/app-laptop/pbbuttonsd/Manifest
index cca9171aab59..9ca03d40def5 100644
--- a/app-laptop/pbbuttonsd/Manifest
+++ b/app-laptop/pbbuttonsd/Manifest
@@ -1,10 +1,10 @@
-MD5 f675c3756f07cb8e984c4ce275764e59 ChangeLog 8262
+MD5 1991279df53b8e818340b360884ecc8a ChangeLog 8382
MD5 f0cdcf7c27493d60d25d76f479b82e63 pbbuttonsd-0.6.10.ebuild 1117
MD5 86caedd5742982169284b585959a54be pbbuttonsd-0.6.6.ebuild 1146
MD5 048caf6217e504f2c22e334f8eb9b65d pbbuttonsd-0.7_pre1.ebuild 1164
MD5 52f9d8e98c8931645c57a3de1c36727d metadata.xml 156
MD5 869f5eb8b01cb099feaba0713a1fb8d5 pbbuttonsd-0.7_pre2.ebuild 1163
-MD5 176c707b526e7dbbabc473a56d601273 pbbuttonsd-0.7.0.ebuild 1116
+MD5 51ee7ac8050581e2e52d47aba02e285a pbbuttonsd-0.7.0.ebuild 1505
MD5 e87049121a8371a7173cb9aa7c5b167d files/pbbuttonsd.rc6 444
MD5 af23b978a8a629ecc99e95f3505e8a74 files/digest-pbbuttonsd-0.6.10 69
MD5 921e017fad1253b70863f48dc9dbf670 files/digest-pbbuttonsd-0.7_pre1 73
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild
index d23f4ee9f5d4..eaa5f546b9f2 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild,v 1.1 2005/07/11 22:41:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.0.ebuild,v 1.2 2005/07/12 04:22:22 josejx Exp $
-inherit eutils
+inherit eutils linux-info
DESCRIPTION="program to map special Powerbook/iBook keys"
HOMEPAGE="http://pbbuttons.sf.net"
@@ -18,6 +18,12 @@ DEPEND="virtual/libc
RDEPEND=""
src_compile() {
+ if ! linux_chkconfig_present INPUT_EVDEV ; then
+ eerror "Please enable CONFIG_INPUT_EVDEV in your kernel"
+ eerror "pbbuttonsd will not work without it."
+ die "Kernel not compiled with CONFIG_INPUT_EVDEV support"
+ fi
+
econf || die "Sorry, failed to configure pbbuttonsd"
emake || die "Sorry, failed to compile pbbuttonsd"
}
@@ -31,6 +37,12 @@ src_install() {
}
pkg_postinst() {
+ if linux_chkconfig_module INPUT_EVDEV ; then
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ fi
+
+ einfo
einfo "This version of pbbuttonsd can replace PMUD functionality."
einfo "If you want PMUD installed and running, you should set"
einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"