summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-01-17 04:47:08 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-01-17 04:47:08 +0000
commitfe36f31c9e8b208ba333348468f3c272a7b79430 (patch)
tree77a7b2261b1b48b0741d99705ffab6a03d4e0e8c /app-laptop
parentsh love (diff)
downloadhistorical-fe36f31c9e8b208ba333348468f3c272a7b79430.tar.gz
historical-fe36f31c9e8b208ba333348468f3c272a7b79430.tar.bz2
historical-fe36f31c9e8b208ba333348468f3c272a7b79430.zip
Fixed building with latest evas.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/macosd/ChangeLog8
-rw-r--r--app-laptop/macosd/Manifest15
-rw-r--r--app-laptop/macosd/files/0.1.9-evas.patch50
-rw-r--r--app-laptop/macosd/files/digest-macosd-0.1.9-r11
-rw-r--r--app-laptop/macosd/macosd-0.1.9-r1.ebuild53
5 files changed, 125 insertions, 2 deletions
diff --git a/app-laptop/macosd/ChangeLog b/app-laptop/macosd/ChangeLog
index 61d5fbbde722..f7d70df04188 100644
--- a/app-laptop/macosd/ChangeLog
+++ b/app-laptop/macosd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/macosd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/ChangeLog,v 1.6 2006/01/08 12:24:48 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/ChangeLog,v 1.7 2006/01/17 04:47:08 josejx Exp $
+
+*macosd-0.1.9-r1 (17 Jan 2006)
+
+ 17 Jan 2006; Joseph Jezak <josejx@gentoo.org> +files/0.1.9-evas.patch,
+ +macosd-0.1.9-r1.ebuild:
+ Fixed building with latest evas.
08 Jan 2006; Michael Hanselmann <hansmi@gentoo.org> metadata.xml:
Remove retiring dev from metadata.
diff --git a/app-laptop/macosd/Manifest b/app-laptop/macosd/Manifest
index 512e67e45de9..d9243b8159fa 100644
--- a/app-laptop/macosd/Manifest
+++ b/app-laptop/macosd/Manifest
@@ -1,5 +1,18 @@
-MD5 ecbefe387e934e2aff6bcc04b66fbc54 ChangeLog 918
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 ce1c4a0a5d122fc9c21bc5b5ab7d5b11 ChangeLog 1086
MD5 e11c404b0ef630f5a364a0d4db4603d0 files/0.1.9-evas-pbbuttonsd.patch 3310
+MD5 4962805ae4fcd76e12880c53afda10ef files/0.1.9-evas.patch 1745
MD5 1dcb5edab66af7f0a128b77c7d2b09b8 files/digest-macosd-0.1.9 65
+MD5 1dcb5edab66af7f0a128b77c7d2b09b8 files/digest-macosd-0.1.9-r1 65
+MD5 b388391314b9f853c13fb814d6251abf macosd-0.1.9-r1.ebuild 1381
MD5 3acd133b5a1dc947584d001570dea373 macosd-0.1.9.ebuild 1341
MD5 20b1bed5008cb245ef24781eb798f1d0 metadata.xml 983
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDzHbWcsIHjyDViGQRAksHAKCBv6toYUoLm+l0omzyVirZ+sFnVgCglq1r
+7P0gmHIt4Vk9QOu0n4dGSo4=
+=WOtA
+-----END PGP SIGNATURE-----
diff --git a/app-laptop/macosd/files/0.1.9-evas.patch b/app-laptop/macosd/files/0.1.9-evas.patch
new file mode 100644
index 000000000000..e6c2e7a56a3c
--- /dev/null
+++ b/app-laptop/macosd/files/0.1.9-evas.patch
@@ -0,0 +1,50 @@
+--- gfx/include/EvasHelper.hh.bak 2006-01-16 22:50:55.000000000 -0500
++++ gfx/include/EvasHelper.hh 2006-01-16 22:50:30.000000000 -0500
+@@ -28,6 +28,7 @@
+
+ #include <Evas.h>
+ #include <inttypes.h>
++#include <time.h>
+
+ #include <string>
+
+@@ -129,16 +130,16 @@
+ */
+
+ void EventFeedMouseDown (int b, Evas_Button_Flags flags) {
+- evas_event_feed_mouse_down (ob, b, flags, NULL);
++ evas_event_feed_mouse_down (ob, b, flags, time(NULL), NULL);
+ };
+ void EventFeedMouseUp (int b, Evas_Button_Flags flags) {
+- evas_event_feed_mouse_up (ob, b, flags, NULL);
++ evas_event_feed_mouse_up (ob, b, flags, time(NULL), NULL);
+ };
+ void EventFeedMouseMove (int x, int y) {
+- evas_event_feed_mouse_move (ob, x, y, NULL);
++ evas_event_feed_mouse_move (ob, x, y, time(NULL), NULL);
+ };
+ void EventFeedmouseIn () {
+- evas_event_feed_mouse_in (ob, NULL);
++ evas_event_feed_mouse_in (ob, time(NULL), NULL);
+ };
+
+ /*
+@@ -147,13 +148,15 @@
+ void EventFeedKeyUpData (const char *keyname, const void *data) {
+ };
+ */
++ /* This isn't used for macosd and it's breaking compiles */
++ /*
+ void EventFeedKeyDown (const char *keyname, const char *keysymbol, const char *key_compose) {
+- evas_event_feed_key_down (ob, keyname, keysymbol, key_compose, NULL, NULL);
++ evas_event_feed_key_down (ob, keyname, keysymbol, key_compose, time(NULL), NULL);
+ };
+ void EventFeedKeyUp (const char *keyname, const char *keysymbol, const char *key_compose) {
+- evas_event_feed_key_up (ob, keyname, keysymbol, key_compose, NULL, NULL);
++ evas_event_feed_key_up (ob, keyname, keysymbol, key_compose, time(NULL), NULL);
+ };
+-
++*/
+
+ Evas* c_obj () {
+ return ob;
diff --git a/app-laptop/macosd/files/digest-macosd-0.1.9-r1 b/app-laptop/macosd/files/digest-macosd-0.1.9-r1
new file mode 100644
index 000000000000..617fe2d364b9
--- /dev/null
+++ b/app-laptop/macosd/files/digest-macosd-0.1.9-r1
@@ -0,0 +1 @@
+MD5 fde5ab8145fea6d348644176758e2341 macosd-0.1.9.tar.bz2 166308
diff --git a/app-laptop/macosd/macosd-0.1.9-r1.ebuild b/app-laptop/macosd/macosd-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..33fa9adf1cb1
--- /dev/null
+++ b/app-laptop/macosd/macosd-0.1.9-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/macosd-0.1.9-r1.ebuild,v 1.1 2006/01/17 04:47:08 josejx Exp $
+
+inherit eutils
+
+DESCRIPTION="On-Screen-Display frontend for pbbuttonsd (only for PPC Laptops)."
+HOMEPAGE="http://www.exactcode.de/oss/macosd/"
+SRC_URI="http://dl.rocklinux-consulting.de/oss/macosd/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+DEPEND="virtual/x11
+ >=app-laptop/pbbuttonsd-0.6.8
+ >=x11-libs/evas-0.9.9
+ >=x11-libs/xosd-2.2.5"
+RDEPEND="$DEPEND"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-evas-pbbuttonsd.patch
+ epatch ${FILESDIR}/${PV}-evas.patch
+}
+
+src_compile() {
+ # can't use econf -- this packages uses ROCK Linux style configure
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-xosd \
+ --with-evas || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/macosd
+ dodir /usr/bin
+ einstall || die
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Make sure that pbbuttons is running (add it to your default runlevel)"
+ einfo "and then add the following to your ~/.xinitrc to have macosd"
+ einfo "start whenever you launch X:"
+ einfo "macosd -t CleanOSX &"
+ einfo "To see a listing of available themes, run: macosd -l"
+}
+