summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-04-19 13:38:14 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-04-19 13:38:14 +0000
commitbbb681bf6ad5bf346d50f6c2834c6ac57065526c (patch)
tree242c8fc3fbaacdf3a71c63a4e96feb011b4839f7 /app-misc/digitemp
parentbug 74394 (diff)
downloadhistorical-bbb681bf6ad5bf346d50f6c2834c6ac57065526c.tar.gz
historical-bbb681bf6ad5bf346d50f6c2834c6ac57065526c.tar.bz2
historical-bbb681bf6ad5bf346d50f6c2834c6ac57065526c.zip
version bump, thanks to: ceho@elit.net.p in bug #86715
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/ChangeLog7
-rw-r--r--app-misc/digitemp/Manifest4
-rw-r--r--app-misc/digitemp/digitemp-3.3.2.ebuild64
-rw-r--r--app-misc/digitemp/files/digest-digitemp-3.3.21
4 files changed, 74 insertions, 2 deletions
diff --git a/app-misc/digitemp/ChangeLog b/app-misc/digitemp/ChangeLog
index 84b58dd10007..815bc348246a 100644
--- a/app-misc/digitemp/ChangeLog
+++ b/app-misc/digitemp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/digitemp
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/ChangeLog,v 1.6 2005/01/01 14:58:51 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/ChangeLog,v 1.7 2005/04/19 13:38:14 seemant Exp $
+
+*digitemp-3.3.2 (19 Apr 2005)
+
+ 19 Apr 2005; Seemant Kulleen <seemant@gentoo.org> +digitemp-3.3.2.ebuild:
+ version bump, thanks to: ceho@elit.net.p in bug #86715
30 Jun 2004; Aron Griffis <agriffis@gentoo.org> digitemp-3.2.0.ebuild,
digitemp-3.3.1.ebuild:
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index 0be434dad122..443892e98c45 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1,6 +1,8 @@
-MD5 88f9cdf7bc38512d380cd4896e265999 ChangeLog 1128
+MD5 e5917f82cff48a1f8ff9e55609438595 ChangeLog 1290
MD5 69f75462bb2ae933342e85dc6ece80f9 digitemp-3.2.0.ebuild 1837
MD5 1dd90360c823ab7a0d95bb1120305a84 digitemp-3.3.1.ebuild 1838
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
+MD5 2f48b5d1c3ee7408c6a2c4d50b258e20 digitemp-3.3.2.ebuild 1905
MD5 be3c44f8d662d55090d70813c9b3adc9 files/digest-digitemp-3.2.0 66
MD5 97b7451b04d6c11f4379f845b552b682 files/digest-digitemp-3.3.1 66
+MD5 2826c62cff400db6831e24914830062e files/digest-digitemp-3.3.2 66
diff --git a/app-misc/digitemp/digitemp-3.3.2.ebuild b/app-misc/digitemp/digitemp-3.3.2.ebuild
new file mode 100644
index 000000000000..06cbcc6e738b
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.3.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.3.2.ebuild,v 1.1 2005/04/19 13:38:14 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
+HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
+SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/libc"
+
+exampledir="/usr/share/doc/${PF}"
+target="ds9097u"
+
+src_compile() {
+ # default is to compile to the ds9097u. local use flag takes care of
+ # passive ds9097. the ds9097u setting is what i have, so probably a safe
+ # default - nothing special here.
+ [ "${SERIAL_DRIVER}" = ds9097 ] && target="ds9097"
+ make clean
+
+ ewarn ""
+ ewarn "making for ${target} serial controller. if you would like support"
+ ewarn "for another controller, please set SERIAL_DRIVER=\"ds9097u\" or"
+ ewarn "SERIAL_DRIVER=\"ds9097\" as appropriate"
+ ewarn ""
+
+ make LOCK="no" ${target} || die
+}
+
+src_install() {
+ target=${target/u/U}
+ mv digitemp_${target} digitemp
+ dobin digitemp || die
+ dodoc README FAQ TODO
+
+ # method one: don't treat the examples as docs; place them somewhere else.
+ # then tell the user where to find this stuff. suitable alternative:
+ # specify exampledir="/usr/share/doc/${PF}"
+
+ local perldir="${exampledir}/perl_examples"
+ insinto ${perldir}
+ doins perl/*
+ local pythondir="${exampledir}/python_examples"
+ insinto ${pythondir}
+ doins python/*
+ local rrdbdir="${exampledir}/rrdb_examples"
+ insinto ${rrdbdir}
+ doins rrdb/*
+}
+
+pkg_postinst() {
+ ewarn "set the SERIAL_DRIVER environment variable to ds9097 to build"
+ ewarn "for that controller instead"
+ einfo ""
+ einfo "examples of using digitemp with python, perl, and rrdtool are"
+ einfo "located in ${exampledir}"
+ einfo ""
+}
diff --git a/app-misc/digitemp/files/digest-digitemp-3.3.2 b/app-misc/digitemp/files/digest-digitemp-3.3.2
new file mode 100644
index 000000000000..1b6ecb1934e8
--- /dev/null
+++ b/app-misc/digitemp/files/digest-digitemp-3.3.2
@@ -0,0 +1 @@
+MD5 0b6cfb36d198767836de54d9fb11bbdb digitemp-3.3.2.tar.gz 134223