summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-15 03:34:35 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-15 03:34:35 +0000
commit773302781daa8ed2126de5bac1eab07093d969b6 (patch)
tree80fa903a749f30e0ea59b0770cd3a59ef73ef9d5 /app-misc/gallery
parentnew ispell dictionary (diff)
downloadhistorical-773302781daa8ed2126de5bac1eab07093d969b6.tar.gz
historical-773302781daa8ed2126de5bac1eab07093d969b6.tar.bz2
historical-773302781daa8ed2126de5bac1eab07093d969b6.zip
#7551
Diffstat (limited to 'app-misc/gallery')
-rw-r--r--app-misc/gallery/ChangeLog8
-rw-r--r--app-misc/gallery/files/digest-gallery-1.3.11
-rw-r--r--app-misc/gallery/gallery-1.3.1.ebuild87
3 files changed, 96 insertions, 0 deletions
diff --git a/app-misc/gallery/ChangeLog b/app-misc/gallery/ChangeLog
new file mode 100644
index 000000000000..858433ed1bb9
--- /dev/null
+++ b/app-misc/gallery/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-misc/gallery
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/ChangeLog,v 1.1 2002/11/15 03:34:35 woodchip Exp $
+
+*gallery-1.3.1 (14 Nov 2002)
+
+ 14 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import, from victor.pont@uab.es (Victor Pont) #7551.
diff --git a/app-misc/gallery/files/digest-gallery-1.3.1 b/app-misc/gallery/files/digest-gallery-1.3.1
new file mode 100644
index 000000000000..e09eab105d8d
--- /dev/null
+++ b/app-misc/gallery/files/digest-gallery-1.3.1
@@ -0,0 +1 @@
+MD5 0c0ef90962414cac95f28a881c80117d gallery-1.3.1.tar.gz 166794
diff --git a/app-misc/gallery/gallery-1.3.1.ebuild b/app-misc/gallery/gallery-1.3.1.ebuild
new file mode 100644
index 000000000000..c0618aba5da8
--- /dev/null
+++ b/app-misc/gallery/gallery-1.3.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gallery/gallery-1.3.1.ebuild,v 1.1 2002/11/15 03:34:35 woodchip Exp $
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator."
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND=">=net-www/apache-1.3.24-r1
+ >=dev-php/mod_php-4.1.2-r5
+ >=media-gfx/jhead-1.6
+ >=media-libs/netpbm-9.12"
+
+S="${WORKDIR}/${PN}"
+DST_PATH="/home/httpd/htdocs/gallery"
+
+src_compile() { :; }
+
+src_install() {
+ insinto ${DST_PATH}
+ doins *.{php,sh}
+
+ insinto ${DST_PATH}/classes
+ doins classes/*.php
+
+ insinto ${DST_PATH}/classes/database/mysql
+ doins classes/database/mysql/*.php
+
+ insinto ${DST_PATH}/classes/gallery
+ doins classes/gallery/*.php
+
+ insinto ${DST_PATH}/classes/nuke5
+ doins classes/nuke5/*.php
+
+ insinto ${DST_PATH}/classes/postnuke
+ doins classes/postnuke/*.php
+
+ insinto ${DST_PATH}/classes/postnuke0.7.1
+ doins classes/postnuke0.7.1/*.php
+
+ insinto ${DST_PATH}/css
+ doins css/*.default
+
+ insinto ${DST_PATH}/errors
+ doins errors/*.php
+
+ insinto ${DST_PATH}/html
+ doins html/*.inc
+
+ insinto ${DST_PATH}/html_wrap
+ doins html_wrap/*.default
+
+ insinto ${DST_PATH}/images
+ doins images/*.{gif,png}
+
+ insinto ${DST_PATH}/java
+ doins java/*.jar
+
+ insinto ${DST_PATH}/js
+ doins js/*.js
+
+ insinto ${DST_PATH}/layout
+ doins layout/*.inc
+
+ insinto ${DST_PATH}/platform
+ doins platform/*.php
+
+ insinto ${DST_PATH}/setup
+ doins setup/*.{php,inc,template,txt} setup/.htaccess
+
+ dodoc AUTHORS ChangeLog README LICENSE.txt todo UPGRADING
+}
+
+
+pkg_postinst() {
+ chown -R apache.apache ${DST_PATH}
+ chown root.root ${DST_PATH}/secure.sh ${DST_PATH}/configure.sh
+ chmod 700 ${DST_PATH}/secure.sh ${DST_PATH}/configure.sh
+
+ einfo
+ einfo "Now point your browser to http://www.yourhost.com/gallery/setup/"
+ einfo "and follow the instructions."
+ einfo
+}