summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-27 06:35:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-27 06:35:04 +0000
commitd67965aa7ad1048efd21820545625805b559eb5a (patch)
tree14d97c7abcc68aadcd0118b3bec566b7213e2a85 /app-misc/glimpse
parenterrno patch for #16396 (#16267) (diff)
downloadhistorical-d67965aa7ad1048efd21820545625805b559eb5a.tar.gz
historical-d67965aa7ad1048efd21820545625805b559eb5a.tar.bz2
historical-d67965aa7ad1048efd21820545625805b559eb5a.zip
errno patch #16267
Diffstat (limited to 'app-misc/glimpse')
-rw-r--r--app-misc/glimpse/ChangeLog7
-rw-r--r--app-misc/glimpse/files/4.15-errno.patch133
-rw-r--r--app-misc/glimpse/files/digest-glimpse-4.15-r1 (renamed from app-misc/glimpse/files/digest-glimpse-4.15)0
-rw-r--r--app-misc/glimpse/glimpse-4.15-r1.ebuild (renamed from app-misc/glimpse/glimpse-4.15.ebuild)12
4 files changed, 146 insertions, 6 deletions
diff --git a/app-misc/glimpse/ChangeLog b/app-misc/glimpse/ChangeLog
index eb0073d6ab02..7d0ca490a872 100644
--- a/app-misc/glimpse/ChangeLog
+++ b/app-misc/glimpse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/glimpse
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/ChangeLog,v 1.4 2003/02/22 22:42:45 dragon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/ChangeLog,v 1.5 2003/02/27 06:35:04 vapier Exp $
+
+*glimpse-4.15-r1 (26 Feb 2003)
+
+ 26 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ small patch to fix glibc errno issues (#16267).
*glimpse-4.15 (9 Feb 2002)
diff --git a/app-misc/glimpse/files/4.15-errno.patch b/app-misc/glimpse/files/4.15-errno.patch
new file mode 100644
index 000000000000..0ca41fd989bb
--- /dev/null
+++ b/app-misc/glimpse/files/4.15-errno.patch
@@ -0,0 +1,133 @@
+diff -uwr glimpse-4.15.orig/agrep/agrep.c glimpse-4.15/agrep/agrep.c
+--- glimpse-4.15.orig/agrep/agrep.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/agrep/agrep.c 2003-02-25 22:27:54.000000000 +0200
+@@ -11,7 +11,6 @@
+ #define PRINT(s)
+
+ extern char **environ;
+-extern int errno;
+ int pattern_index; /* index in argv where the pattern is */
+
+ int glimpse_isserver=0; /* so that there is no user interaction */
+diff -uwr glimpse-4.15.orig/agrep/checksg.c glimpse-4.15/agrep/checksg.c
+--- glimpse-4.15.orig/agrep/checksg.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/agrep/checksg.c 2003-02-25 22:27:54.000000000 +0200
+@@ -1,8 +1,8 @@
+ /* Copyright (c) 1994 Sun Wu, Udi Manber, Burra Gopal. All Rights Reserved. */
++#include <errno.h>
+ #include "agrep.h"
+ #include "checkfile.h"
+
+-extern int errno;
+ extern CHAR Progname[MAXNAME];
+ extern int SGREP, PAT_FILE, PAT_BUFFER, EXITONERROR, SIMPLEPATTERN,
+ CONSTANT, D, NOUPPER, JUMP, I, LINENUM, INVERSE, WORDBOUND, WHOLELINE,
+diff -uwr glimpse-4.15.orig/agrep/compat.c glimpse-4.15/agrep/compat.c
+--- glimpse-4.15.orig/agrep/compat.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/agrep/compat.c 2003-02-25 22:27:54.000000000 +0200
+@@ -1,5 +1,6 @@
+ /* Copyright (c) 1994 Sun Wu, Udi Manber, Burra Gopal. All Rights Reserved. */
+ /* test the conflicts between options */
++#include <errno.h>
+ #include <stdio.h>
+ #include "agrep.h"
+
+@@ -15,7 +16,6 @@
+ extern char Progname[MAXNAME];
+ extern int agrep_initialfd;
+ extern int EXITONERROR;
+-extern int errno;
+
+ int
+ compat()
+diff -uwr glimpse-4.15.orig/agrep/maskgen.c glimpse-4.15/agrep/maskgen.c
+--- glimpse-4.15.orig/agrep/maskgen.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/agrep/maskgen.c 2003-02-25 22:27:54.000000000 +0200
+@@ -1,4 +1,5 @@
+ /* Copyright (c) 1994 Sun Wu, Udi Manber, Burra Gopal. All Rights Reserved. */
++#include <errno.h>
+ #include "agrep.h"
+
+ extern unsigned D_endpos, endposition, Init1, wildmask;
+@@ -7,7 +8,6 @@
+ extern unsigned char Progname[];
+ extern int agrep_initialfd;
+ extern int EXITONERROR;
+-extern int errno;
+
+ int
+ maskgen(Pattern, D)
+diff -uwr glimpse-4.15.orig/agrep/preprocess.c glimpse-4.15/agrep/preprocess.c
+--- glimpse-4.15.orig/agrep/preprocess.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/agrep/preprocess.c 2003-02-25 22:27:54.000000000 +0200
+@@ -13,6 +13,7 @@
+ /* upon return, Pattern contains the pattern to be processed by maskgen */
+ /* D_pattern contains transformed D_pattern */
+
++#include <errno.h>
+ #include "agrep.h"
+
+ extern int PAT_FILE, PAT_BUFFER;
+@@ -25,7 +26,6 @@
+ extern int table[WORD][WORD];
+ extern int agrep_initialfd;
+ extern int EXITONERROR;
+-extern int errno;
+
+ extern int multifd;
+ extern char *multibuf;
+diff -uwr glimpse-4.15.orig/get_index.c glimpse-4.15/get_index.c
+--- glimpse-4.15.orig/get_index.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/get_index.c 2003-02-25 22:27:54.000000000 +0200
+@@ -1,4 +1,5 @@
+ /* Copyright (c) 1994 Burra Gopal, Udi Manber. All Rights Reserved. */
++#include <errno.h>
+ #include "glimpse.h"
+ #include "defs.h"
+
+@@ -14,7 +15,6 @@
+ extern unsigned int *dest_index_set;
+ extern unsigned char *dest_index_buf;
+ extern int mask_int[32];
+-extern int errno;
+ extern int ByteLevelIndex;
+ extern int RecordLevelIndex;
+ extern int rdelim_len;
+diff -uwr glimpse-4.15.orig/index/build_in.c glimpse-4.15/index/build_in.c
+--- glimpse-4.15.orig/index/build_in.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/index/build_in.c 2003-02-25 22:27:54.000000000 +0200
+@@ -23,6 +23,7 @@
+ this 12 19 \n is 9 17 12 18 19 \n an 7 12 \n example 16 \n
+ -----------------------------------------------------------------------*/
+
++#include <errno.h>
+ #include "glimpse.h"
+
+ #define debugt
+@@ -604,7 +605,6 @@
+ int ret;
+ char s[MAX_LINE_LEN], es1[MAX_LINE_LEN], es2[MAX_LINE_LEN], es3[MAX_LINE_LEN];
+ char s1[MAX_LINE_LEN];
+- extern int errno;
+ static int maxsortlinelen = 0;
+ int i;
+
+diff -uwr glimpse-4.15.orig/index/partition.c glimpse-4.15/index/partition.c
+--- glimpse-4.15.orig/index/partition.c 2003-02-25 22:29:06.000000000 +0200
++++ glimpse-4.15/index/partition.c 2003-02-25 22:27:54.000000000 +0200
+@@ -1,6 +1,7 @@
+ /* Copyright (c) 1994 Sun Wu, Udi Manber, Burra Gopal. All Rights Reserved. */
+ /* ./glimpse/index/partition.c */
+ #include "glimpse.h"
++#include <errno.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+
+@@ -27,7 +28,6 @@
+ int files_per_partition;
+ int files_in_partition;
+ int ATLEASTONEFILE = 0;
+-extern int errno;
+
+ char patbuf[MAX_PAT];
+ extern unsigned char *src_index_buf;
diff --git a/app-misc/glimpse/files/digest-glimpse-4.15 b/app-misc/glimpse/files/digest-glimpse-4.15-r1
index 0f14f6cfb013..0f14f6cfb013 100644
--- a/app-misc/glimpse/files/digest-glimpse-4.15
+++ b/app-misc/glimpse/files/digest-glimpse-4.15-r1
diff --git a/app-misc/glimpse/glimpse-4.15.ebuild b/app-misc/glimpse/glimpse-4.15-r1.ebuild
index 44f77850bc76..cfedb15ae500 100644
--- a/app-misc/glimpse/glimpse-4.15.ebuild
+++ b/app-misc/glimpse/glimpse-4.15-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.15.ebuild,v 1.10 2003/02/22 22:42:45 dragon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.15-r1.ebuild,v 1.1 2003/02/27 06:35:04 vapier Exp $
+
+inherit eutils
DESCRIPTION="A index/query system to search a large set of files quickly"
SRC_URI="http://webglimpse.net/trial/${P}.tar.gz"
@@ -11,14 +13,14 @@ LICENSE="BSD"
KEYWORDS="x86 ~ppc ~mips"
src_compile() {
- make distclean
- econf
+ epatch ${FILESDIR}/${PV}-errno.patch
+ make distclean || die
+ econf || die
make || die
}
src_install() {
- einstall
-
+ einstall || die
dodir /usr/share/man/man1
mv ${D}/usr/share/man/*.1 ${D}/usr/share/man/man1/
}