summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-22 13:31:58 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-22 13:31:58 +0000
commit0a7ea22842533746fd1635384c0881f2878c9672 (patch)
tree4c25de22834906167746418e915912a7f3ce6bc8 /app-misc/livetools/livetools-1.2.3.ebuild
parentNewer icon set, desktop file installation simplified (diff)
downloadhistorical-0a7ea22842533746fd1635384c0881f2878c9672.tar.gz
historical-0a7ea22842533746fd1635384c0881f2878c9672.tar.bz2
historical-0a7ea22842533746fd1635384c0881f2878c9672.zip
Closing #42464
Diffstat (limited to 'app-misc/livetools/livetools-1.2.3.ebuild')
-rw-r--r--app-misc/livetools/livetools-1.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/livetools/livetools-1.2.3.ebuild b/app-misc/livetools/livetools-1.2.3.ebuild
new file mode 100644
index 000000000000..2c279652fb2a
--- /dev/null
+++ b/app-misc/livetools/livetools-1.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/livetools/livetools-1.2.3.ebuild,v 1.1 2004/02/22 13:31:58 aliz Exp $
+
+DESCRIPTION="A small set of utilities to allow easy access to Creative's SoundBlaster Live!Drive IR's remote control."
+HOMEPAGE="http://www.clarkson.edu/~evanchsa/software/livetools/"
+SRC_URI="http://www.clarkson.edu/~evanchsa/software/livetools/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Currently, this is only functional as a XMMS plugin
+# so it makes no sense to run it without XMMS. When it
+# becomes more generalized we can remove the XMMS dep.
+DEPEND="media-sound/xmms"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}