summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-15 14:45:33 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-15 14:45:33 +0000
commitc4baf1407dfd165287b097e59d9be089479e5996 (patch)
tree9dde2cd6ec1522ad5ab1c552a35f2239d4238558 /app-misc/mtoolsfm
parentinitial release (diff)
downloadhistorical-c4baf1407dfd165287b097e59d9be089479e5996.tar.gz
historical-c4baf1407dfd165287b097e59d9be089479e5996.tar.bz2
historical-c4baf1407dfd165287b097e59d9be089479e5996.zip
initial release
Diffstat (limited to 'app-misc/mtoolsfm')
-rw-r--r--app-misc/mtoolsfm/Manifest4
-rw-r--r--app-misc/mtoolsfm/files/digest-mtoolsfm-1.9.31
-rw-r--r--app-misc/mtoolsfm/files/mtoolsfm.c.diff62
-rw-r--r--app-misc/mtoolsfm/mtoolsfm-1.9.3.ebuild28
4 files changed, 93 insertions, 2 deletions
diff --git a/app-misc/mtoolsfm/Manifest b/app-misc/mtoolsfm/Manifest
index efe6575a87ee..b1fd9227a60a 100644
--- a/app-misc/mtoolsfm/Manifest
+++ b/app-misc/mtoolsfm/Manifest
@@ -1,4 +1,4 @@
-MD5 bfa3c87631ff087cc8422d34773c7de2 mtoolsfm-1.9.3.ebuild 645
-MD5 c55e8449485b95f4222d5291c7c31e1f ChangeLog 275
+MD5 5d9989969d5e094d73c0731cfe93d54b mtoolsfm-1.9.3.ebuild 747
+MD5 1f35319cdfafbf8381cfa8aac1b7ec0b ChangeLog 365
MD5 87ef961e5ed3682a37f8b66f2e0f9aaf files/mtoolsfm.c.diff 1767
MD5 d1d9def37127f9c318c473026de352be files/digest-mtoolsfm-1.9.3 66
diff --git a/app-misc/mtoolsfm/files/digest-mtoolsfm-1.9.3 b/app-misc/mtoolsfm/files/digest-mtoolsfm-1.9.3
new file mode 100644
index 000000000000..1aac6212c19a
--- /dev/null
+++ b/app-misc/mtoolsfm/files/digest-mtoolsfm-1.9.3
@@ -0,0 +1 @@
+MD5 5ce76261ad969209c86b28e49924fc43 MToolsFM-1.9-3.tar.gz 177388
diff --git a/app-misc/mtoolsfm/files/mtoolsfm.c.diff b/app-misc/mtoolsfm/files/mtoolsfm.c.diff
new file mode 100644
index 000000000000..cc7b12e95fc4
--- /dev/null
+++ b/app-misc/mtoolsfm/files/mtoolsfm.c.diff
@@ -0,0 +1,62 @@
+--- src/mtoolsfm.c 2001-08-27 08:45:25.000000000 +0200
++++ src/mtoolsfm.c.1 2003-07-04 20:24:03.000000000 +0200
+@@ -85,6 +85,10 @@
+ char *homedir;
+ int debug=0;
+
++char *leftpath = "";
++char *rightpath = "";
++int sidecount=0;
++
+ /* should a configuration file ~/.mtoolsfm be written in user's homedir ? */
+ #ifdef DEFAULT_NOSAVE
+ int nosave=1;
+@@ -652,6 +656,7 @@
+ char *nextposition;
+ unsigned int path_length=50;
+ unsigned int path_add=50;
++ sidecount++;
+
+ if (debug) {
+ printf ("In gethdpath()\n");
+@@ -660,11 +665,19 @@
+ clearpath (whichside);
+ errno = 0;
+ path = malloc (path_length * sizeof (char));
++ if (sidecount == 1 && strlen(leftpath) != 0) {
++ strcpy(path, leftpath);
++ }
++ else if (sidecount == 2 && strlen(rightpath) != 0) {
++ strcpy(path, rightpath);
++ }
++ else {
+ while ((!getcwd (path, path_length - 2)) && (errno == ERANGE))
+ {
+ if (debug) printf(" getcwd buffer resize: errno=%d, path_length=%d, path=%s\n",errno,path_length,path);
+ path = g_realloc (path, (path_length+=path_add) * sizeof (char));
+ }
++ }
+ strcat (path, "/");
+ if (debug)
+ printf (" path: %s\n", path);
+@@ -2920,6 +2933,20 @@
+ debug = 1;
+ else if (!strcmp (argv[i], "--debug"))
+ debug = 1;
++ else if (!strncmp (argv[i], "--leftpath", 10)) {
++ leftpath = strchr(argv[i], '=');
++ if(leftpath) {
++ *leftpath = 0;
++ leftpath++;
++ }
++ }
++ else if (!strncmp (argv[i], "--rightpath", 11)) {
++ rightpath = strchr(argv[i], '=');
++ if(rightpath) {
++ *rightpath = 0;
++ rightpath++;
++ }
++ }
+ else if (!strcmp (argv[i], "--help")) {
+ g_print ("\n%s%s\n%s%s%s\n",ABOUTMTOOLSFM_1,ABOUTMTOOLSFM_2,
+ MTOOLSFMOPTIONS_1,CONFFILE,MTOOLSFMOPTIONS_2);
diff --git a/app-misc/mtoolsfm/mtoolsfm-1.9.3.ebuild b/app-misc/mtoolsfm/mtoolsfm-1.9.3.ebuild
new file mode 100644
index 000000000000..39c02864d024
--- /dev/null
+++ b/app-misc/mtoolsfm/mtoolsfm-1.9.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mtoolsfm/mtoolsfm-1.9.3.ebuild,v 1.1 2003/07/15 14:45:24 lanius Exp $
+
+DESCRIPTION="MToolsFM - easy floppy-access under linux / UNIX "
+HOMEPAGE="http://www.core-coutainville.org/MToolsFM/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+MY_P="MToolsFM-1.9-3"
+SRC_URI="http://www.core-coutainville.org/MToolsFM/archive/SOURCES/${MY_P}.tar.gz"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="=gtk+-1.2*
+ mtools"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/mtoolsfm.c.diff
+}
+
+src_install() {
+ einstall install_prefix=${D}
+ dodoc AUTHORS COPYING ChangeLog NEWS README THANKS
+}