summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-01-08 23:35:01 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-01-08 23:35:01 +0000
commit325d40230016253e5e43e71eb236036b4c680bf8 (patch)
tree515cbc090ef614464000037733aae9112474770f /app-misc/tablix/tablix-0.3.5.ebuild
parentNew package. Bug #204845 (diff)
downloadhistorical-325d40230016253e5e43e71eb236036b4c680bf8.tar.gz
historical-325d40230016253e5e43e71eb236036b4c680bf8.tar.bz2
historical-325d40230016253e5e43e71eb236036b4c680bf8.zip
Version bump.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'app-misc/tablix/tablix-0.3.5.ebuild')
-rw-r--r--app-misc/tablix/tablix-0.3.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/tablix/tablix-0.3.5.ebuild b/app-misc/tablix/tablix-0.3.5.ebuild
new file mode 100644
index 000000000000..5faf9999b462
--- /dev/null
+++ b/app-misc/tablix/tablix-0.3.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tablix/tablix-0.3.5.ebuild,v 1.1 2008/01/08 23:35:00 carlo Exp $
+
+inherit eutils
+
+MY_PV="${PN}2-${PV}"
+
+DESCRIPTION="Tablix is a powerful free software kernel for solving general timetabling problems."
+HOMEPAGE="http://www.tablix.org/"
+SRC_URI="http://www.tablix.org/releases/stable/${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="pvm"
+
+DEPEND=">=dev-libs/libxml2-2.4.3
+ pvm? ( sys-cluster/pvm )"
+
+S="${WORKDIR}/${MY_PV}"
+
+pkg_setup() {
+ if ! use pvm; then
+ ewarn
+ ewarn "Without parallel virtual machine support, tablix will not be able"
+ ewarn "to solve even moderately complex problems. Even if you are using"
+ ewarn "a single machine, USE=pvm is highly recommended."
+ ewarn
+ epause 5
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_with pvm pvm3) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+ cd doc
+ dodoc manual.pdf modules.pdf modules2.pdf morphix.pdf
+}