summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-08-20 03:07:11 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-08-20 03:07:11 +0000
commitf7413572756e9f9ceb0ff36e1e4cdcdf5783ce17 (patch)
treee85f3159d0bc70ebf2bd8ccf67d84ce1c312967b /app-misc
parentblah, second to last commit had too many local changes, make sure gcc-3.3.x l... (diff)
downloadhistorical-f7413572756e9f9ceb0ff36e1e4cdcdf5783ce17.tar.gz
historical-f7413572756e9f9ceb0ff36e1e4cdcdf5783ce17.tar.bz2
historical-f7413572756e9f9ceb0ff36e1e4cdcdf5783ce17.zip
bug 61887
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/rio/ChangeLog12
-rw-r--r--app-misc/rio/Manifest8
-rw-r--r--app-misc/rio/files/digest-rio-1.0.7-r11
-rw-r--r--app-misc/rio/files/rio-1.0.7-gentoo.patch39
-rw-r--r--app-misc/rio/files/rio-1.0.7-makefile.patch15
-rw-r--r--app-misc/rio/rio-1.0.7-r1.ebuild34
-rw-r--r--app-misc/rio/rio-1.0.7.ebuild15
7 files changed, 115 insertions, 9 deletions
diff --git a/app-misc/rio/ChangeLog b/app-misc/rio/ChangeLog
index d3a5c4cd6187..1d8457e0fad8 100644
--- a/app-misc/rio/ChangeLog
+++ b/app-misc/rio/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-misc/rio
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/ChangeLog,v 1.4 2005/01/01 15:21:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/ChangeLog,v 1.5 2005/08/20 03:07:11 vanquirius Exp $
+
+*rio-1.0.7-r1 (20 Aug 2005)
+
+ 20 Aug 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/rio-1.0.7-gentoo.patch, +files/rio-1.0.7-makefile.patch,
+ rio-1.0.7.ebuild, +rio-1.0.7-r1.ebuild:
+ Fix ebuild to make it work. rio is no longer installed suid, please use sudo
+ or su to use it properly. -r1 gets patched to avoid warning messages. Fixes
+ bug 61887. Thanks to Chase Hargraves <io@absolutek.ca>, Joshua Kinard
+ <kumba@gentoo.org> and others.
07 Oct 2003; Joel Hill <hillster@gentoo.org> rio-1.0.7.ebuild:
cleanup, marking stable.
diff --git a/app-misc/rio/Manifest b/app-misc/rio/Manifest
index 2b0bb0711680..7a5b698232b2 100644
--- a/app-misc/rio/Manifest
+++ b/app-misc/rio/Manifest
@@ -1,3 +1,7 @@
-MD5 fc3aae7adb204a56923da57ed4607c26 ChangeLog 447
-MD5 b32e5c763387bf3c4838c9c6d4e6d99a rio-1.0.7.ebuild 718
+MD5 127dc8a3461089e5a48c06ba1d0bd59c rio-1.0.7.ebuild 728
+MD5 91d466ac1ff13bbed98353a399e8db81 rio-1.0.7-r1.ebuild 769
+MD5 83853eb1ad0de2aa46402043afea5065 ChangeLog 899
+MD5 59701140e71ef37361df07ddb321a8ad files/rio-1.0.7-gentoo.patch 1213
MD5 57d3999d889f638c313d32013ed95bdc files/digest-rio-1.0.7 54
+MD5 0d748d4731e5bfdf220753f435a83935 files/rio-1.0.7-makefile.patch 328
+MD5 57d3999d889f638c313d32013ed95bdc files/digest-rio-1.0.7-r1 54
diff --git a/app-misc/rio/files/digest-rio-1.0.7-r1 b/app-misc/rio/files/digest-rio-1.0.7-r1
new file mode 100644
index 000000000000..f9ed3265caef
--- /dev/null
+++ b/app-misc/rio/files/digest-rio-1.0.7-r1
@@ -0,0 +1 @@
+MD5 81be1f37f98a23a013d02495b8b23ca9 rio007.tgz 28953
diff --git a/app-misc/rio/files/rio-1.0.7-gentoo.patch b/app-misc/rio/files/rio-1.0.7-gentoo.patch
new file mode 100644
index 000000000000..852dbeec6baa
--- /dev/null
+++ b/app-misc/rio/files/rio-1.0.7-gentoo.patch
@@ -0,0 +1,39 @@
+--- rio107.orig/std.h 2005-08-19 23:29:18.000000000 -0300
++++ rio107/std.h 2005-08-19 23:54:16.000000000 -0300
+@@ -31,7 +31,8 @@
+ #endif
+
+ #ifndef SZERROR
+-#define SZERROR sys_errlist[errno]
++/* Vanquirius: sys_errlist is deprecated */
++#define SZERROR strerror(errno)
+ #endif
+
+ typedef unsigned char UCHAR;
+--- rio107.orig/app.cpp 2005-08-19 23:29:18.000000000 -0300
++++ rio107/app.cpp 2005-08-19 23:55:38.000000000 -0300
+@@ -512,6 +512,8 @@
+ int iPortBase = PORT_BASE_DEFAULT;
+ int iPosDumpDirectory = 0;
+ int iSizeDumpDirectory = 0;
++ /* Vanquirius: LarryTheCow to the rescue! */
++ int pszFilePlaylistTempLarryTheCow = 0;
+
+ // process command line args
+ if ( iCountArg < 2 )
+@@ -571,7 +573,14 @@
+
+ // append all command line upload requests to temp playlist
+ if ( !pszFilePlaylistTemp )
+- pszFilePlaylistTemp = tmpnam( NULL );
++ /* Vanquirius: use mkstemp instead of tmpnam */
++ pszFilePlaylistTemp = strdup("/tmp/rio_XXXXXX");
++ if ( (pszFilePlaylistTempLarryTheCow = mkstemp(pszFilePlaylistTemp)) < 0 )
++ {
++ perror ("mkstemp");
++ exit (EXIT_FAILURE);
++ }
++ close(pszFilePlaylistTempLarryTheCow);
+
+ if ( pszFilePlaylistTemp )
+ {
diff --git a/app-misc/rio/files/rio-1.0.7-makefile.patch b/app-misc/rio/files/rio-1.0.7-makefile.patch
new file mode 100644
index 000000000000..8a646f658dd3
--- /dev/null
+++ b/app-misc/rio/files/rio-1.0.7-makefile.patch
@@ -0,0 +1,15 @@
+--- makefile.orig 2004-08-27 02:21:58.117715144 -0400
++++ makefile 2004-08-27 02:30:11.720676088 -0400
+@@ -9,8 +9,10 @@
+ all: rio
+
+ rio: app.cpp rio.cpp
+- g++ -O1 -o rio app.cpp rio.cpp
+- chmod +s rio
++ $(CXX) $(CXXFLAGS) -o rio app.cpp rio.cpp
++
++# suid binaries BAD! use sudo!
++# chmod +s rio
+
+ clean:
+ rm -f rio
diff --git a/app-misc/rio/rio-1.0.7-r1.ebuild b/app-misc/rio/rio-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..63662ccd70f3
--- /dev/null
+++ b/app-misc/rio/rio-1.0.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7-r1.ebuild,v 1.1 2005/08/20 03:07:11 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="Utility for the Diamond Rio 300 portable MP3 player"
+HOMEPAGE="http://www.world.co.uk/sba/rio.html"
+SRC_URI="http://www.world.co.uk/sba/${PN}007.tgz"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}${PV//./}"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-makefile.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake || die "compile failed"
+}
+
+src_install() {
+ dobin rio || die
+ dodoc CREDITS README gpl.txt playlist.txt rio.txt
+}
diff --git a/app-misc/rio/rio-1.0.7.ebuild b/app-misc/rio/rio-1.0.7.ebuild
index c4e15e322d38..c94fd5a2cf06 100644
--- a/app-misc/rio/rio-1.0.7.ebuild
+++ b/app-misc/rio/rio-1.0.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7.ebuild,v 1.9 2005/01/01 15:21:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7.ebuild,v 1.10 2005/08/20 03:07:11 vanquirius Exp $
+
+inherit eutils
DESCRIPTION="Utility for the Diamond Rio 300 portable MP3 player"
HOMEPAGE="http://www.world.co.uk/sba/rio.html"
@@ -14,7 +16,12 @@ IUSE=""
DEPEND="virtual/libc"
RDEPEND=""
-S=${WORKDIR}/${UNPACKDIR}
+S="${WORKDIR}/${PN}${PV//./}"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-makefile.patch
+}
src_compile() {
emake || die "compile failed"
@@ -24,7 +31,3 @@ src_install() {
dobin rio || die
dodoc CREDITS README gpl.txt playlist.txt rio.txt
}
-
-pkg_postinst() {
- einfo "Warning! The /usr/bin/rio binary is installed SUID/GUID root."
-}