summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-06-08 00:41:01 +0000
committerMarinus Schraal <foser@gentoo.org>2003-06-08 00:41:01 +0000
commit5d590833082572234e6f24585c4f1142af00cae7 (patch)
treea97d9a5f105e16dafc2eb5f6d4ed6d274884fdbf /app-office/abiword/abiword-1.0.6-r1.ebuild
parentreenabled gnome support (diff)
downloadhistorical-5d590833082572234e6f24585c4f1142af00cae7.tar.gz
historical-5d590833082572234e6f24585c4f1142af00cae7.tar.bz2
historical-5d590833082572234e6f24585c4f1142af00cae7.zip
reenabled gnome support
Diffstat (limited to 'app-office/abiword/abiword-1.0.6-r1.ebuild')
-rw-r--r--app-office/abiword/abiword-1.0.6-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-1.0.6-r1.ebuild b/app-office/abiword/abiword-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..5a46419fcec3
--- /dev/null
+++ b/app-office/abiword/abiword-1.0.6-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.0.6-r1.ebuild,v 1.1 2003/06/08 00:40:52 foser Exp $
+
+inherit flag-o-matic
+
+replace-flags "-O?" "-O1"
+IUSE="nls spell jpeg xml2 gnome"
+
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Word processor"
+SRC_URI="mirror://sourceforge/abiword/${P}.tar.gz"
+HOMEPAGE="http://www.abisource.com"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="GPL-2"
+SLOT="1"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=dev-libs/libunicode-0.4-r1
+ =x11-libs/gtk+-1.2*
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ spell? ( >=app-text/aspell-0.50.2-r1 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+ <gnome-extra/gal-1.99
+ >=gnome-base/bonobo-1.0.9-r1 )"
+
+src_compile() {
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --with-gnome --enable-gnome"; \
+ export ABI_OPT_BONOBO=1
+
+ use spell \
+ && myconf="${myconf} --with-pspell --disable-static"
+
+ use xml2 \
+ && myconf="${myconf} --with-libxml2" \
+ || myconf="${myconf} --without-libxml2"
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use nls \
+ && myconf="${myconf} --enable-bidi"
+
+ ./autogen.sh
+ einfo "Ignore above errors if it does not cause the build to fail"
+
+ CFLAGS="${CFLAGS} `gdk-pixbuf-config --cflags`"
+
+ # we got enough of the perl problems for now
+ econf ${myconf} --disable-scripting
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ einstall
+
+ dosed "s:${D}::g" /usr/bin/AbiWord
+
+ rm -f ${D}/usr/bin/abiword
+ dosym /usr/bin/AbiWord /usr/bin/abiword
+
+ dodoc BUILD COPYING *.txt, *.TXT
+
+ # Install icon and .desktop for menu entry
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ )
+}