summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2002-08-01 03:14:35 +0000
committerChad Huneycutt <chadh@gentoo.org>2002-08-01 03:14:35 +0000
commit10e8e0d0f0c8b4da9db23c6df001e95b4d653a63 (patch)
tree76e7631282635ff66164ee06b9d7cb5fe38fd7e4 /app-office/ical
parentAdded ppc to KEYWORDS. (diff)
downloadhistorical-10e8e0d0f0c8b4da9db23c6df001e95b4d653a63.tar.gz
historical-10e8e0d0f0c8b4da9db23c6df001e95b4d653a63.tar.bz2
historical-10e8e0d0f0c8b4da9db23c6df001e95b4d653a63.zip
new package.
Diffstat (limited to 'app-office/ical')
-rw-r--r--app-office/ical/ChangeLog9
-rw-r--r--app-office/ical/files/digest-ical-2.2.12
-rw-r--r--app-office/ical/ical-2.2.1.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/app-office/ical/ChangeLog b/app-office/ical/ChangeLog
new file mode 100644
index 000000000000..ff60c6e2a267
--- /dev/null
+++ b/app-office/ical/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.1 2002/08/01 03:14:35 chadh Exp $
+
+*ical-2.2.1 (31 Jul 2002)
+
+ 31 Jul 2002; Chad Huneycutt <chadh@gentoo.org> ical-2.2.1.ebuild: Initial
+ import. Most of the patches to get this to compile were taken from the srpm
+ for Redhat 7.3
diff --git a/app-office/ical/files/digest-ical-2.2.1 b/app-office/ical/files/digest-ical-2.2.1
new file mode 100644
index 000000000000..3931fe89e6e3
--- /dev/null
+++ b/app-office/ical/files/digest-ical-2.2.1
@@ -0,0 +1,2 @@
+MD5 246de6b4f477805db9b15239f4f85473 ical-2.2.1a.tar.bz2 221779
+MD5 33be1cf24c5629a8fc893a6f0f2a3ee2 ical-2.2.1a.patch.tar.bz2 3696
diff --git a/app-office/ical/ical-2.2.1.ebuild b/app-office/ical/ical-2.2.1.ebuild
new file mode 100644
index 000000000000..ed3106000e40
--- /dev/null
+++ b/app-office/ical/ical-2.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.2.1.ebuild,v 1.1 2002/08/01 03:14:35 chadh Exp $
+
+DESCRIPTION="Calendar program"
+HOMEPAGE="http://www.fnal.gov/docs/products/tktools/ical.html"
+SRC_URI="http://helios.dii.utk.edu/ftp/pub/tcl/apps/ical/${P}a.tar.bz2
+ http://www.ibiblio.org/gentoo/distfiles/${P}a.patch.tar.bz2"
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-lang/tcl dev-lang/tk sys-devel/autoconf"
+RDEPEND="dev-lang/tcl dev-lang/tk"
+
+S=${WORKDIR}/${P}a
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+
+ patch -p0 < ${P}a-newtcl.patch
+ patch -p0 < ${P}a-hack.patch
+ patch -p0 < ${P}a-glibc22.patch
+ patch -p0 < ${P}a-print.patch
+
+ D=${S}/ dosed "s: \@TCL_LIBS\@::" Makefile.in
+ D=${S}/ dosed "s:mkdir:mkdir -p:" Makefile.in
+
+}
+
+src_compile() {
+ autoconf
+ econf
+ emake || die
+}
+
+src_install () {
+ #make DESTDIR=${D} install || die
+ mkdir -p ${D}/usr
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+}