summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-04-14 12:23:02 +0000
committerMarinus Schraal <foser@gentoo.org>2003-04-14 12:23:02 +0000
commit76949dfcd9a98dd9b05b355de39dcb964b992d1f (patch)
treef174b4d3de6de86d0d5ee2e826d039275c1120c7 /app-office
parentNew version (diff)
downloadhistorical-76949dfcd9a98dd9b05b355de39dcb964b992d1f.tar.gz
historical-76949dfcd9a98dd9b05b355de39dcb964b992d1f.tar.bz2
historical-76949dfcd9a98dd9b05b355de39dcb964b992d1f.zip
New version
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog8
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-1.0.131
-rw-r--r--app-office/gnumeric/gnumeric-1.0.13.ebuild108
3 files changed, 116 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index c629bfb4cd1d..3e22924b7a15 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.28 2003/04/03 17:15:26 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.29 2003/04/14 12:23:02 foser Exp $
+
+*gnumeric-1.0.13 (14 Apr 2003)
+
+ 14 Apr 2003; foser <foser@gentoo.org> gnumeric-1.0.13.ebuild :
+ New stable release
+ Fixed evolution dep, probably doesn't work with the gtk2 version
*gnumeric-1.1.16 (16 Mar 2003)
diff --git a/app-office/gnumeric/files/digest-gnumeric-1.0.13 b/app-office/gnumeric/files/digest-gnumeric-1.0.13
new file mode 100644
index 000000000000..743341303f45
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-1.0.13
@@ -0,0 +1 @@
+MD5 7f0e7b88538719cba9d9f5509ccbb491 gnumeric-1.0.13.tar.bz2 9853785
diff --git a/app-office/gnumeric/gnumeric-1.0.13.ebuild b/app-office/gnumeric/gnumeric-1.0.13.ebuild
new file mode 100644
index 000000000000..e320bcc860a8
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.0.13.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.0.13.ebuild,v 1.1 2003/04/14 12:23:02 foser Exp $
+
+inherit virtualx libtool gnome.org
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
+
+IUSE="libgda gb evo python bonobo guile perl"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+#Eye Of Gnome (media-gfx/eog) is for image support.
+RDEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12-r1
+ =gnome-base/libglade-0*
+ >=gnome-base/gnome-print-0.31
+ >=gnome-extra/gal-0.18
+ >=dev-libs/libole2-0.2.4
+ >=media-gfx/eog-0.6
+ >=dev-libs/libxml-1.8.14
+ =media-libs/freetype-1.3*
+ bonobo? ( >=gnome-base/bonobo-1.0.17 )
+ perl? ( >=dev-lang/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( ~gnome-extra/gb-0.0.17 )
+ libgda? ( <gnome-extra/libgda-0.10.0
+ >=gnome-base/bonobo-1.0.17 )
+ evo? ( <net-mail/evolution-1.3 )"
+
+#will only work once everybody has decided that they should support
+#the latest versions of programs, or if we live in a perfect world,
+#and subsequent versions do not break compatibility.
+# guile? ( >=dev-util/guile-1.5 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ # fix the relink bug, and invalid paths in .la files.
+ elibtoolize
+
+ local myconf=""
+ if [ -n "`use gb`" ]; then
+ myconf="${myconf} --with-gb"
+ else
+ myconf="${myconf} --without-gb"
+ fi
+ #broken as we cannot use guile-1.5 (break gnucash)
+ if [ -n "`use guile`" ]; then
+ myconf="${myconf} --without-guile"
+ else
+ myconf="${myconf} --without-guile"
+ fi
+ if [ -n "`use perl`" ]; then
+ myconf="${myconf} --with-perl"
+ else
+ myconf="${myconf} --without-perl"
+ fi
+ if [ -n "`use python`" ]; then
+ myconf="${myconf} --with-python"
+ else
+ myconf="${myconf} --without-python"
+ fi
+ if [ -n "`use libgda`" ]; then
+ myconf="${myconf} --with-gda --with-bonobo"
+ else
+ myconf="${myconf} --without-gda"
+ fi
+ if [ -n "`use evo`" ]; then
+ myconf="${myconf} --with-evolution"
+ fi
+ if [ -n "`use bonobo`" ]; then
+ myconf="${myconf} --with-bonobo"
+ elif [ -z "`use libgda`" ]; then
+ myconf="${myconf} --without-bonobo"
+ fi
+
+ CFLAGS="${CFLAGS} `gdk-pixbuf-config --cflags`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ #'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
+ #else the build fails.
+ addwrite "${HOME}/.gnome"
+
+ #the build process have to be able to connect to X
+ Xemake || Xmake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+}
+