summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2002-10-27 19:17:40 +0000
committerHanno Boeck <hanno@gentoo.org>2002-10-27 19:17:40 +0000
commitdaa4c479c13739695b8d0262f8722a89b02609e3 (patch)
treec000006d015bec380bd85473867996e6b69f0973 /app-office
parentNew version (diff)
downloadhistorical-daa4c479c13739695b8d0262f8722a89b02609e3.tar.gz
historical-daa4c479c13739695b8d0262f8722a89b02609e3.tar.bz2
historical-daa4c479c13739695b8d0262f8722a89b02609e3.zip
updated version of scribus
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/ChangeLog12
-rw-r--r--app-office/scribus/files/Fonts.diff28
-rw-r--r--app-office/scribus/files/Palette.diff65
-rw-r--r--app-office/scribus/files/digest-scribus-0.81
-rw-r--r--app-office/scribus/scribus-0.8.ebuild56
5 files changed, 159 insertions, 3 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index 3e06210d5b98..b472c0a8f75f 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/scribus
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.4 2002/10/17 14:22:36 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.5 2002/10/27 19:17:40 hanno Exp $
+
+*scribus-0.8 (27 Oct 2002)
+
+ 27 Oct 2002; Hanno Boeck <hanno@gentoo.org> scribus-0.8.ebuild :
+ Version updated.
+ Added two patches by the author and a compile fix for the CXXFLAGS.
+
+*scribus-0.7.4-r1 (09 Jun 2002)
17 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> scribus-0.7.4-r1.ebuild :
Added IUSE.
@@ -10,8 +18,6 @@
Make kde .desktop file installation routine use eclasses to find out kde's
path instead of hardcoding it.
-*scribus-0.7.4-r1 (09 Jun 2002)
-
06 Aug 2002; Mark Guertin <gerk@gentoo.org> :
Added ppc to keywords
diff --git a/app-office/scribus/files/Fonts.diff b/app-office/scribus/files/Fonts.diff
new file mode 100644
index 000000000000..273378a53aba
--- /dev/null
+++ b/app-office/scribus/files/Fonts.diff
@@ -0,0 +1,28 @@
+diff -ur scribus-0.8/scribus/fmitem.cpp scribus-0.8n/scribus/fmitem.cpp
+--- scribus-0.8/scribus/fmitem.cpp Fri Nov 30 21:50:57 2001
++++ scribus-0.8n/scribus/fmitem.cpp Fri Oct 11 11:16:59 2002
+@@ -17,11 +17,13 @@
+
+ #include "fmitem.h"
+ #include <qfontmetrics.h>
++#include <qapplication.h>
+
+ FmItem::FmItem(const QString& s, const QFont& f)
+ {
+ string = s;
+ font = f;
++ font.setPointSize(qApp->font().pointSize());
+ }
+ FmItem::~FmItem()
+ {
+diff -ur scribus-0.8/scribus/scfonts.cpp scribus-0.8n/scribus/scfonts.cpp
+--- scribus-0.8/scribus/scfonts.cpp Sun Sep 22 10:54:38 2002
++++ scribus-0.8n/scribus/scfonts.cpp Sat Oct 12 19:41:57 2002
+@@ -443,6 +443,7 @@
+ {
+ t->Font.setPointSize(12);
+ t->Font.setRawName(tmp);
++ t->Font.setPointSize(12);
+ t->FontEnc = FoEnc;
+ insert(SCName,t);
+ if(t->HasMetrics)
diff --git a/app-office/scribus/files/Palette.diff b/app-office/scribus/files/Palette.diff
new file mode 100644
index 000000000000..d74e1fac393a
--- /dev/null
+++ b/app-office/scribus/files/Palette.diff
@@ -0,0 +1,65 @@
+diff -ur scribus-0.8/scribus/mpalette.cpp scribus-0.8.02/scribus/mpalette.cpp
+--- scribus-0.8/scribus/mpalette.cpp Sat Sep 14 12:26:16 2002
++++ scribus-0.8.02/scribus/mpalette.cpp Sun Oct 27 08:15:56 2002
+@@ -430,8 +430,8 @@
+ connect(FrameScale, SIGNAL(clicked()), this, SLOT(ChangeScaling()));
+ connect(Aspect, SIGNAL(clicked()), this, SLOT(ChangeScaling()));
+ connect(this, SIGNAL(placeChanged(QDockWindow::Place)), this, SLOT(Docken(QDockWindow::Place)));
+- setCloseMode(Always);
+- undock();
++ pa->moveDockWindow(this, DockTornOff);
++ setCloseMode(Always);
+ resize(sizeHint());
+ setResizeEnabled(true);
+ Fram->raiseWidget(4);
+diff -ur scribus-0.8/scribus/scribus.cpp scribus-0.8.02/scribus/scribus.cpp
+--- scribus-0.8/scribus/scribus.cpp Tue Sep 24 22:09:45 2002
++++ scribus-0.8.02/scribus/scribus.cpp Sat Oct 26 16:37:53 2002
+@@ -4686,7 +4686,7 @@
+ pda.Zeiger = 0;
+ pda.Datei = "";
+ pda.Typ = 0;
+- if (DLLName(d[dc], &nam, &ty, pda.Zeiger))
++ if (DLLName(d[dc], &nam, &ty, &pda.Zeiger))
+ {
+ if (ty == 1)
+ extraMenu->insertItem(tr(nam));
+@@ -4698,7 +4698,7 @@
+ helpMenu->insertItem(tr(nam));
+ pda.Datei = d[dc];
+ pda.Typ = ty;
+- PluginMap[tr(nam)] = pda;
++ PluginMap.insert(tr(nam), pda);
+ }
+ }
+ connect(extraMenu, SIGNAL(activated(int)), this, SLOT(RunPlug(int)));
+@@ -4742,7 +4742,7 @@
+ dlclose(mo);
+ }
+
+-bool ScribusApp::DLLName(QString name, QString *PName, int *typ, void *Zeig)
++bool ScribusApp::DLLName(QString name, QString *PName, int *typ, void **Zeig)
+ {
+ void *mo;
+ char *error;
+@@ -4773,7 +4773,7 @@
+ return false;
+ }
+ *typ = (*demo1)();
+- Zeig = mo;
++ *Zeig = mo;
+ if (*typ != 4)
+ dlclose(mo);
+ else
+diff -ur scribus-0.8/scribus/scribus.h scribus-0.8.02/scribus/scribus.h
+--- scribus-0.8/scribus/scribus.h Tue Sep 24 22:09:58 2002
++++ scribus-0.8.02/scribus/scribus.h Sat Oct 26 16:34:00 2002
+@@ -98,7 +98,7 @@
+ void UpdateRecent(QString fn);
+ void InitPlugs();
+ void FinalizePlugs();
+- bool DLLName(QString name, QString *PName, int *typ, void *Zeig);
++ bool DLLName(QString name, QString *PName, int *typ, void **Zeig);
+ void CallDLL(QString name);
+ PSLib* getPSDriver(bool psart, SCFonts &AllFonts, QMap<QString,QFont> DocFonts, CListe DocColors, bool pdf);
+ void closePSDriver();
diff --git a/app-office/scribus/files/digest-scribus-0.8 b/app-office/scribus/files/digest-scribus-0.8
new file mode 100644
index 000000000000..5447dbb4c89e
--- /dev/null
+++ b/app-office/scribus/files/digest-scribus-0.8
@@ -0,0 +1 @@
+MD5 9a5ee8056b27d54ddba64f4c7deecce1 scribus-0.8.tar.gz 3014043
diff --git a/app-office/scribus/scribus-0.8.ebuild b/app-office/scribus/scribus-0.8.ebuild
new file mode 100644
index 000000000000..76c6d6260cf0
--- /dev/null
+++ b/app-office/scribus/scribus-0.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-0.8.ebuild,v 1.1 2002/10/27 19:17:40 hanno Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Scribus is a Layout program"
+HOMEPAGE="http://web2.altmuehlnet.de/fschmid"
+SRC_URI="http://web2.altmuehlnet.de/fschmid/${P}.tar.gz"
+IUSE="kde"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=x11-libs/qt-3*
+ media-libs/freetype
+ media-libs/lcms"
+
+CXXFLAGS="${CXXFLAGS} -I/usr/include/lcms"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ patch -p0 < ${FILESDIR}/Fonts.diff
+ patch -p0 < ${FILESDIR}/Palette.diff
+}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die "make failed"
+ mv debian/scribus-debian.xpm debian/scribus.xpm
+}
+
+src_install () {
+
+ einstall destdir=${D} || die "couldn't be installed"
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Fixing desktop.scribus
+ use kde &&
+ (
+ inherit kde-functions
+ set-kdedir 3
+ sed -e 's/local\///' desktop.scribus > desktop.scribus.2
+ echo "Name=Scribus" >> desktop.scribus.2
+ cp -f desktop.scribus.2 scribus.desktop
+ insinto ${PREFIX}/share/applnk/Graphics
+ doins scribus.desktop
+ )
+ # Copy the pixmaps to the generic place
+ insinto /usr/share/pixmaps/
+ doins debian/scribus.xpm
+
+ dosym /usr/share/scribus/doc /usr/share/doc/${PF}/html
+
+}