summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-09-22 18:08:50 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-09-22 18:08:50 +0000
commit8543e4725534383a5cccd06ac6105021aed0d15d (patch)
tree2f98dc15354ca15ee1ce1ddd0bfa9e7df1c8b31f /app-pda
parentAdded USE flags for g77 and gcj (diff)
downloadhistorical-8543e4725534383a5cccd06ac6105021aed0d15d.tar.gz
historical-8543e4725534383a5cccd06ac6105021aed0d15d.tar.bz2
historical-8543e4725534383a5cccd06ac6105021aed0d15d.zip
New package: iRipDB; allows interaction/updating with database on iRiver-HP1XX devices.
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/iripdb/ChangeLog10
-rw-r--r--app-pda/iripdb/Manifest3
-rw-r--r--app-pda/iripdb/files/digest-iripdb-0.1.11
-rw-r--r--app-pda/iripdb/iripdb-0.1.1.ebuild33
-rw-r--r--app-pda/iripdb/metadata.xml12
5 files changed, 59 insertions, 0 deletions
diff --git a/app-pda/iripdb/ChangeLog b/app-pda/iripdb/ChangeLog
new file mode 100644
index 000000000000..d9a9db812fae
--- /dev/null
+++ b/app-pda/iripdb/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-pda/iripdb
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/ChangeLog,v 1.1 2004/09/22 18:08:50 fafhrd Exp $
+
+*iripdb-0.1.1 (22 Sep 2004)
+
+ 22 Sep 2004; Armando Di Cianno <fafhrd@gentoo.org> +metadata.xml,
+ +iripdb-0.1.1.ebuild:
+ New package added; keyworded for ~x86.
+
diff --git a/app-pda/iripdb/Manifest b/app-pda/iripdb/Manifest
new file mode 100644
index 000000000000..db6a392d7049
--- /dev/null
+++ b/app-pda/iripdb/Manifest
@@ -0,0 +1,3 @@
+MD5 53c11476ac2f2668f4c154c1d0055e44 metadata.xml 789
+MD5 a24d17d21e3f04c7c3bc070f335064b8 iripdb-0.1.1.ebuild 809
+MD5 75a18c7fcd88a614b247cd6fd269ae3f files/digest-iripdb-0.1.1 63
diff --git a/app-pda/iripdb/files/digest-iripdb-0.1.1 b/app-pda/iripdb/files/digest-iripdb-0.1.1
new file mode 100644
index 000000000000..c569030d0a6b
--- /dev/null
+++ b/app-pda/iripdb/files/digest-iripdb-0.1.1
@@ -0,0 +1 @@
+MD5 f00cf7ef20a91d30e900c6b4fab6ec8c iRipDB-0.1.1.tar.gz 17555
diff --git a/app-pda/iripdb/iripdb-0.1.1.ebuild b/app-pda/iripdb/iripdb-0.1.1.ebuild
new file mode 100644
index 000000000000..d52bde068ecc
--- /dev/null
+++ b/app-pda/iripdb/iripdb-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/iripdb-0.1.1.ebuild,v 1.1 2004/09/22 18:08:50 fafhrd Exp $
+
+S=${WORKDIR}/iRipDB-${PV}
+
+inherit eutils
+
+DESCRIPTION="iRipDB allows generating the DB files necessary for the iRiver iHP-1xx series of MP3/Ogg HD Player on Linux and Windows."
+HOMEPAGE="http://www.marevalo.net/iRipDB"
+SRC_URI="http://www.marevalo.net/iRipDB/iRipDB-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="virtual/libc
+ =media-libs/id3lib-3.8.3*
+ =media-libs/libogg-1.1*
+ =media-libs/libvorbis-1.0.1*
+ =sys-libs/zlib-1.2.1*"
+
+src_compile() {
+ gcc -c -o main.o main.c
+ gcc -c -o vcedit.o vcedit.c
+ gcc -o iripdb main.o vcedit.o -L/usr/lib -lz -lm -lid3 -lvorbis -logg -lstdc++
+}
+
+src_install() {
+ dobin iripdb
+ dodoc AUTHORS README doc/iRivDB_structure
+}
+
diff --git a/app-pda/iripdb/metadata.xml b/app-pda/iripdb/metadata.xml
new file mode 100644
index 000000000000..4efda4ceef9f
--- /dev/null
+++ b/app-pda/iripdb/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>fafhrd@gentoo.org</email>
+ <description>Package is not in my main heard, but I have an iRiver-120, and am maintaining this.</description>
+</maintainer>
+<longdescription>
+iRipDB allows generating the DB files necessary for the iRiver iHP-1xx series of MP3/Ogg HD Player on Linux and Windows. That will allow you to navigate your files through the artist/album/genre menus. It supports adding MP3 and Ogg files at this point. It's released under the GNU's General Public License and, at this moment only in source code form.
+</longdescription>
+</pkgmetadata>