summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-23 13:03:59 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-23 13:03:59 +0000
commitb408cc886ab017652beba7adf3082b4912558356 (patch)
tree03dbb643807585b494472d454c30ff273cf9c216 /app-pda
parentadded udev permissions. Added tpm-emulator as optional dependancy. script fil... (diff)
downloadhistorical-b408cc886ab017652beba7adf3082b4912558356.tar.gz
historical-b408cc886ab017652beba7adf3082b4912558356.tar.bz2
historical-b408cc886ab017652beba7adf3082b4912558356.zip
Plucker doesn't build with unicode wxGTK, so make sure we get the ansi
version instead #55716 Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/plucker/ChangeLog6
-rw-r--r--app-pda/plucker/Manifest16
-rw-r--r--app-pda/plucker/plucker-1.8-r1.ebuild16
3 files changed, 31 insertions, 7 deletions
diff --git a/app-pda/plucker/ChangeLog b/app-pda/plucker/ChangeLog
index e328441f37e9..e89abad7334b 100644
--- a/app-pda/plucker/ChangeLog
+++ b/app-pda/plucker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/plucker
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/plucker/ChangeLog,v 1.8 2005/01/02 21:46:32 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/plucker/ChangeLog,v 1.9 2005/06/23 13:03:59 agriffis Exp $
+
+ 23 Jun 2005; Aron Griffis <agriffis@gentoo.org> plucker-1.8-r1.ebuild:
+ Plucker doesn't build with unicode wxGTK, so make sure we get the ansi
+ version instead #55716
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-pda/plucker/Manifest b/app-pda/plucker/Manifest
index e6f6199dd937..1bcca605217b 100644
--- a/app-pda/plucker/Manifest
+++ b/app-pda/plucker/Manifest
@@ -1,7 +1,17 @@
-MD5 48d1833a3db6cf9847e6e6a862930577 ChangeLog 1087
-MD5 53604e38ecb797d12d5d5a86900c5257 plucker-1.8-r1.ebuild 2440
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e78f9b27586178df86f81d4c525d71b4 plucker-1.8-r1.ebuild 2810
+MD5 8dc8f8205042a108fb3ac1fa254c602a ChangeLog 1260
MD5 a4f378385e9e65b9348729f16f6d9a75 plucker-1.8.ebuild 1514
MD5 659d1c5630abf66b0130dcd4d1a62e1f metadata.xml 220
MD5 eceb19a50345feaf7555797e86a0ccff files/plucker-1.8-Makefile.in.patch 471
-MD5 2a325fec96dd6188d796b0fbf85b3bfb files/digest-plucker-1.8-r1 69
MD5 2a325fec96dd6188d796b0fbf85b3bfb files/digest-plucker-1.8 69
+MD5 2a325fec96dd6188d796b0fbf85b3bfb files/digest-plucker-1.8-r1 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCurNSBXaUFmZvwyMRAnpQAKCg6tkxetdjgyUNI2/wthhh2JYMyACeO0hY
+oIHqAjIr1/yTm5Ecw+VH/WU=
+=vFdg
+-----END PGP SIGNATURE-----
diff --git a/app-pda/plucker/plucker-1.8-r1.ebuild b/app-pda/plucker/plucker-1.8-r1.ebuild
index c00d0bfec17d..450b5fa89529 100644
--- a/app-pda/plucker/plucker-1.8-r1.ebuild
+++ b/app-pda/plucker/plucker-1.8-r1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/plucker/plucker-1.8-r1.ebuild,v 1.7 2005/01/01 15:47:17 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/plucker/plucker-1.8-r1.ebuild,v 1.8 2005/06/23 13:03:59 agriffis Exp $
IUSE="gtk"
-inherit python eutils
+inherit python eutils wxwidgets
DESCRIPTION="Distiller for Plucker -- offline ebook reader for Palm devices"
HOMEPAGE="http://www.plkr.org/"
SRC_URI="http://downloads.plkr.org/${PV}/${PN}_src-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~ppc ~x86"
DEPEND=">=dev-lang/python-1.5.2
gtk? ( >=x11-libs/gtk+-2.2 x11-libs/wxGTK )
sys-devel/autoconf"
@@ -40,9 +40,19 @@ src_unpack() {
# Fix deprecation warnings for python-2.3
sed -i "s:0x\w\w\w\w\w\w\w\w:&L:" \
parser/python/PyPlucker/helper/gettext.py || die "sed 3 failed"
+
+ # Get the right version of wxGTK (note call to need-wxwidgets below)
+ find . -name Makefile.in | xargs sed -i 's/wx-config/$(WX_CONFIG)/g' \
+ || die "sed 4 failed"
}
src_compile() {
+ # plucker-desktop doesn't build with the unicode version of wxGTK. Force
+ # the non-unicode version until plucker-desktop is fixed. #55716
+ if useq gtk; then
+ need-wxwidgets gtk2
+ fi
+
# --enable-desktopbuild and --disable-desktopbuild are equivalent for this
# package; either one will *disable* the desktopbuild. It is enabled only
# if the flags are lacking from the cmdline. (21 Jun 2004 agriffis)