summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2004-04-12 01:21:49 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2004-04-12 01:21:49 +0000
commitfdeb15e106ec82ece8c3f12c41acb6830f502357 (patch)
treee900422989ddc5d7b1b07f499f4f047aa4de200b /app-sci/celestia
parentrev bump so the fix to the wrapper goes out (diff)
downloadhistorical-fdeb15e106ec82ece8c3f12c41acb6830f502357.tar.gz
historical-fdeb15e106ec82ece8c3f12c41acb6830f502357.tar.bz2
historical-fdeb15e106ec82ece8c3f12c41acb6830f502357.zip
xorg-x11 compatibility fix.
Diffstat (limited to 'app-sci/celestia')
-rw-r--r--app-sci/celestia/ChangeLog6
-rw-r--r--app-sci/celestia/Manifest14
-rw-r--r--app-sci/celestia/celestia-1.3.0-r1.ebuild9
-rw-r--r--app-sci/celestia/celestia-1.3.0.ebuild9
4 files changed, 26 insertions, 12 deletions
diff --git a/app-sci/celestia/ChangeLog b/app-sci/celestia/ChangeLog
index 7b59a4d5394d..cccd4b9ef851 100644
--- a/app-sci/celestia/ChangeLog
+++ b/app-sci/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/celestia
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/ChangeLog,v 1.3 2004/03/04 20:05:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/ChangeLog,v 1.4 2004/04/12 01:21:49 spyderous Exp $
+
+ 11 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ celestia-1.3.0-r1.ebuild, celestia-1.3.0.ebuild:
+ xorg-x11 compatibility fix.
25 Feb 2004; Patrick Kursawe <phosphan@gentoo.org> celestia-1.3.0-r1.ebuild:
Sandbox violation fixed
diff --git a/app-sci/celestia/Manifest b/app-sci/celestia/Manifest
index efab7eb6dbcf..802fc0578ddb 100644
--- a/app-sci/celestia/Manifest
+++ b/app-sci/celestia/Manifest
@@ -1,13 +1,13 @@
+MD5 f1c0daef87c207d41a216066cbf1c3b8 ChangeLog 2250
+MD5 3fc1b2e7d54b3d27a340cb5b087cfa77 celestia-1.2.2.ebuild 1067
+MD5 89ed818b38b994f8b1d33c116d50b416 celestia-1.2.4.ebuild 1220
+MD5 81ee87e1671c89c7e7b9fdfa17ca7457 celestia-1.2.5.ebuild 1960
+MD5 37f351642d5335a094eee8f1ff9aa4f2 celestia-1.3.0-r1.ebuild 2254
+MD5 ca2d92251c7d227c4e1db0816630a1f1 celestia-1.3.0.ebuild 2120
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 318b4452af1f7b12deb515e84ca6848a files/celestia-gcc3.patch 4576
MD5 f34ba9f68bc1c0e8487c8e27ba984333 files/digest-celestia-1.2.2 68
MD5 5c370faab90b777deeb29bd02fd40b15 files/digest-celestia-1.2.4 68
MD5 96739b584d48f639583eb750463a44ea files/digest-celestia-1.2.5 68
MD5 95f9f0d84c71195fe1f00ba37ea79c0e files/digest-celestia-1.3.0 68
MD5 95f9f0d84c71195fe1f00ba37ea79c0e files/digest-celestia-1.3.0-r1 68
-MD5 3fc1b2e7d54b3d27a340cb5b087cfa77 celestia-1.2.2.ebuild 1067
-MD5 89ed818b38b994f8b1d33c116d50b416 celestia-1.2.4.ebuild 1220
-MD5 81ee87e1671c89c7e7b9fdfa17ca7457 celestia-1.2.5.ebuild 1960
-MD5 850e4cdfa9ad8a2c9a3d4c5b2c5ca144 celestia-1.3.0-r1.ebuild 2080
-MD5 db9f31d5b0e111ee87d065e70912b926 celestia-1.3.0.ebuild 1947
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 01ab025461b262bc63eb9f1a1ba92cc9 ChangeLog 2110
diff --git a/app-sci/celestia/celestia-1.3.0-r1.ebuild b/app-sci/celestia/celestia-1.3.0-r1.ebuild
index 4f3b9379bc10..77b39d59ee03 100644
--- a/app-sci/celestia/celestia-1.3.0-r1.ebuild
+++ b/app-sci/celestia/celestia-1.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0-r1.ebuild,v 1.3 2004/02/28 07:04:55 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0-r1.ebuild,v 1.4 2004/04/12 01:21:49 spyderous Exp $
inherit flag-o-matic kde-functions
@@ -25,10 +25,15 @@ DEPEND=">=media-libs/glut-3.7-r2
kde? ( >=kde-base/kdelibs-3.0.5 )"
pkg_setup() {
+ # Set up X11 implementation
+ X11_IMPLEM_P="$(portageq best_version "${ROOT}" virtual/x11)"
+ X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
+ X11_IMPLEM="${X11_IMPLEM##*\/}"
+
einfo "Please note:"
einfo "if you experience problems building celestia with nvidia drivers,"
einfo "you can try:"
- einfo "opengl-update xfree"
+ einfo "opengl-update ${X11_IMPLEM}"
einfo "emerge celestia"
einfo "opengl-update nvidia"
einfo "------------"
diff --git a/app-sci/celestia/celestia-1.3.0.ebuild b/app-sci/celestia/celestia-1.3.0.ebuild
index 6ee5b957d510..f87b49ae2a8b 100644
--- a/app-sci/celestia/celestia-1.3.0.ebuild
+++ b/app-sci/celestia/celestia-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0.ebuild,v 1.1 2004/02/25 07:59:46 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.0.ebuild,v 1.2 2004/04/12 01:21:49 spyderous Exp $
inherit flag-o-matic kde-functions
@@ -25,10 +25,15 @@ DEPEND=">=media-libs/glut-3.7-r2
!gnome? ( >=kde-base/kdelibs-3.0.5 )"
pkg_setup() {
+ # Set up X11 implementation
+ X11_IMPLEM_P="$(portageq best_version "${ROOT}" virtual/x11)"
+ X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
+ X11_IMPLEM="${X11_IMPLEM##*\/}"
+
einfo "Please note:"
einfo "if you experience problems building celestia with nvidia drivers,"
einfo "you can try:"
- einfo "opengl-update xfree"
+ einfo "opengl-update ${X11_IMPLEM}"
einfo "emerge celestia"
einfo "opengl-update nvidia"
einfo "------------"