summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-01-21 23:06:04 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-01-21 23:06:04 +0000
commit556b1d49829f9d3310a3fed8349dae7e107e235b (patch)
tree0ebb8205e4327295fe77ccecba6d7c2d1a37f256 /app-sci/coq/coq-7.4.ebuild
parentInitial commit. Added norealanalysis use flag to use.local.desc (diff)
downloadhistorical-556b1d49829f9d3310a3fed8349dae7e107e235b.tar.gz
historical-556b1d49829f9d3310a3fed8349dae7e107e235b.tar.bz2
historical-556b1d49829f9d3310a3fed8349dae7e107e235b.zip
Initial commit. Added norealanalysis use flag to use.local.desc
Diffstat (limited to 'app-sci/coq/coq-7.4.ebuild')
-rw-r--r--app-sci/coq/coq-7.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-sci/coq/coq-7.4.ebuild b/app-sci/coq/coq-7.4.ebuild
new file mode 100644
index 000000000000..57fb792f0829
--- /dev/null
+++ b/app-sci/coq/coq-7.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/coq/coq-7.4.ebuild,v 1.1 2004/01/21 23:05:55 mattam Exp $
+
+IUSE="norealanalysis"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-lang/ocaml-3.06"
+
+src_compile() {
+ local myconf="--prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/lib/coq \
+ --mandir /usr/man \
+ --emacslib /usr/share/emacs/site-lisp"
+
+ use norealanalysis && myconf="$myconf --reals"
+ use norealanalysis || myconf="$myconf --reals all"
+
+ has_version ">=dev-lang/ocaml-3.07" && epatch ${FILESDIR}/ocaml-3.07.patch
+
+ echo $myconf
+
+ ./configure $myconf || die
+
+ emake world || die
+}
+
+src_install() {
+ make COQINSTALLPREFIX=${D} install || die
+ dodoc README CREDITS CHANGES LICENSE
+}