summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-03 13:28:54 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-03 13:28:54 +0000
commitf03fc293a029beb520a8a86978530f12a9da8121 (patch)
treeab0a8251851152900bf9852069c4eae0e7363cf9 /app-sci/elem
parentmoving to stable (diff)
downloadhistorical-f03fc293a029beb520a8a86978530f12a9da8121.tar.gz
historical-f03fc293a029beb520a8a86978530f12a9da8121.tar.bz2
historical-f03fc293a029beb520a8a86978530f12a9da8121.zip
sed fix
Diffstat (limited to 'app-sci/elem')
-rw-r--r--app-sci/elem/elem-1.0.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-sci/elem/elem-1.0.1.ebuild b/app-sci/elem/elem-1.0.1.ebuild
index 05a944d66b4e..0226dfae5370 100644
--- a/app-sci/elem/elem-1.0.1.ebuild
+++ b/app-sci/elem/elem-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/elem/elem-1.0.1.ebuild,v 1.3 2003/04/24 13:44:14 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/elem/elem-1.0.1.ebuild,v 1.4 2004/03/03 13:28:54 phosphan Exp $
DESCRIPTION="periodic table of the elements"
HOMEPAGE="http://elem.sourceforge.net/"
@@ -12,15 +12,17 @@ IUSE=""
S=${WORKDIR}/${PN}
-DEPEND="virtual/x11
+RDEPEND="virtual/x11
virtual/glibc
x11-libs/xforms"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_unpack () {
unpack ${A}
cd ${S}
einfo "Modifying Makefile..."
- sed < Makefile -e 's:^LIBS.*:\0 -lXpm:' > Makefile.tmp && mv Makefile.tmp Makefile
+ sed -i -e 's:^LIBS.*:\0 -lXpm:' Makefile
}
src_compile () {