summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2004-03-01 04:16:43 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2004-03-01 04:16:43 +0000
commit69c0ff7d888db7523c4fed61381fa943b00665a1 (patch)
tree50e9251807ef2310a92a96ec6712a0003ca46d4c /app-sci/gromacs
parentAdding metadata.xml (diff)
downloadhistorical-69c0ff7d888db7523c4fed61381fa943b00665a1.tar.gz
historical-69c0ff7d888db7523c4fed61381fa943b00665a1.tar.bz2
historical-69c0ff7d888db7523c4fed61381fa943b00665a1.zip
Version bump. New xml2 USE flag.
Diffstat (limited to 'app-sci/gromacs')
-rw-r--r--app-sci/gromacs/ChangeLog8
-rw-r--r--app-sci/gromacs/Manifest5
-rw-r--r--app-sci/gromacs/files/digest-gromacs-3.21
-rw-r--r--app-sci/gromacs/files/gromacs-3.2-all-static-fix.patch12
-rw-r--r--app-sci/gromacs/gromacs-3.2.ebuild70
5 files changed, 94 insertions, 2 deletions
diff --git a/app-sci/gromacs/ChangeLog b/app-sci/gromacs/ChangeLog
index 1829e97a440b..219512f258ea 100644
--- a/app-sci/gromacs/ChangeLog
+++ b/app-sci/gromacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/gromacs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gromacs/ChangeLog,v 1.8 2004/03/01 04:16:43 spyderous Exp $
+
+*gromacs-3.2 (29 Feb 2004)
+
+ 29 Feb 2004; Donnie Berkholz <spyderous@gentoo.org>; gromacs-3.2.ebuild,
+ files/gromacs-3.2-all-static-fix.patch:
+ Version bump. New xml2 USE flag.
*gromacs-3.1.4-r2 (28 Feb 2004)
diff --git a/app-sci/gromacs/Manifest b/app-sci/gromacs/Manifest
index 14c23dc018ac..afc9fa52263c 100644
--- a/app-sci/gromacs/Manifest
+++ b/app-sci/gromacs/Manifest
@@ -1,6 +1,9 @@
-MD5 bce25cce854a9ed7ab0a403e57ec9fbb ChangeLog 1907
+MD5 ac6521b5860e3c225ffee110392185d5 ChangeLog 2180
MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
MD5 9da7c07e97d7e02a5aece5cb12e8627d gromacs-3.1.4-r1.ebuild 1417
MD5 76479670c978b2f8e8386d6efb46160c gromacs-3.1.4-r2.ebuild 1567
+MD5 5f7482cfcfadbebcce7f201bc8ba2eeb gromacs-3.2.ebuild 1960
MD5 5322e3229934a2776885a05df3606fb0 files/digest-gromacs-3.1.4-r1 66
MD5 5322e3229934a2776885a05df3606fb0 files/digest-gromacs-3.1.4-r2 66
+MD5 b51100cd55b8fa6f7527a6e93c50fa51 files/gromacs-3.2-all-static-fix.patch 596
+MD5 bcf8a5876f341528c9cc49932f63ac10 files/digest-gromacs-3.2 64
diff --git a/app-sci/gromacs/files/digest-gromacs-3.2 b/app-sci/gromacs/files/digest-gromacs-3.2
new file mode 100644
index 000000000000..e328437611aa
--- /dev/null
+++ b/app-sci/gromacs/files/digest-gromacs-3.2
@@ -0,0 +1 @@
+MD5 b7b1ec42f0207794bb3a24fef541f3f5 gromacs-3.2.tar.gz 3303227
diff --git a/app-sci/gromacs/files/gromacs-3.2-all-static-fix.patch b/app-sci/gromacs/files/gromacs-3.2-all-static-fix.patch
new file mode 100644
index 000000000000..79682e6b0593
--- /dev/null
+++ b/app-sci/gromacs/files/gromacs-3.2-all-static-fix.patch
@@ -0,0 +1,12 @@
+diff -urN gromacs-3.2.orig/configure.ac gromacs-3.2/configure.ac
+--- gromacs-3.2.orig/configure.ac 2004-02-29 22:50:34.000000000 -0500
++++ gromacs-3.2/configure.ac 2004-02-29 22:42:19.000000000 -0500
+@@ -178,7 +178,7 @@
+
+
+ AC_ARG_ENABLE(all-static,
+- [ --enable-all-static make completely static binaries],enable_all_static=yes, enable_all_static=no)
++ [ --enable-all-static make completely static binaries],, enable_all_static=no)
+ # Dont add the -all-static flag until after the compiler test.
+
+ ### Compile without FFTW - disabling it means you can't use PME or PPPM!
diff --git a/app-sci/gromacs/gromacs-3.2.ebuild b/app-sci/gromacs/gromacs-3.2.ebuild
new file mode 100644
index 000000000000..e4a7c49c3b58
--- /dev/null
+++ b/app-sci/gromacs/gromacs-3.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gromacs/gromacs-3.2.ebuild,v 1.1 2004/03/01 04:16:43 spyderous Exp $
+
+inherit eutils
+
+IUSE="mpi xml2"
+
+DESCRIPTION="The ultimate molecular dynamics simulation package"
+SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gromacs.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+#mpi is a local USE flag now
+#May become official when situation with mpich is cleared (now the only mpi implementation awailable is lam-mpi)
+DEPEND="=dev-libs/fftw-2.1*
+ mpi? ( >=sys-cluster/lam-mpi-6.5.6 )
+ >=sys-devel/binutils-2.10.91.0.2
+ xml2? ( dev-libs/libxml2 )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-all-static-fix.patch
+}
+
+src_compile() {
+#!!!Please note!!!
+#for troublesome work gromacs should be compiled with the same mpi setting as fftw.
+#Unfortunately portage cannot trace optional dependencies of dependencies at present.
+#Until this (planned) feature is completed, please try to do corresponding check yourself.
+ local myconf
+
+ # Enable asm on Alphas
+ if [ "${ARCH}" = "alpha" ]
+ then
+ myconf="${myconf} --enable-axp-asm"
+ fi
+
+ # static should work but something's broken.
+ # gcc spec file may be screwed up.
+ # Static linking should try -lgcc instead of -lgcc_s.
+ # For more info:
+ # http://lists.debian.org/debian-gcc/2002/debian-gcc-200201/msg00150.html
+ econf \
+ --enable-fortran \
+ --datadir=/usr/share/${P} \
+ --bindir=/usr/bin \
+ --libdir=/usr/lib \
+ `use_with xml2 xml` \
+ `use_enable mpi` \
+ ${myconf} || die "configure failed"
+
+# `use_enable static all-static` \
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ dodoc AUTHORS COPYING INSTALL README
+
+ #move html docs under /usr/share/doc
+ #and leave examples and templates under /usr/gromacs...
+ mv ${D}/usr/share/${P}/html ${D}/usr/share/doc/${PF}
+}