summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-23 14:35:28 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-23 14:35:28 +0000
commit34532eec305edfdc2a596ff751a9c8b47be71a53 (patch)
tree90959f3f91dca9c0b1b196a080a5a3a91e03a492 /app-sci/scigraphica
parenttouchups (diff)
downloadhistorical-34532eec305edfdc2a596ff751a9c8b47be71a53.tar.gz
historical-34532eec305edfdc2a596ff751a9c8b47be71a53.tar.bz2
historical-34532eec305edfdc2a596ff751a9c8b47be71a53.zip
touchups
Diffstat (limited to 'app-sci/scigraphica')
-rw-r--r--app-sci/scigraphica/scigraphica-0.8.0.ebuild33
1 files changed, 12 insertions, 21 deletions
diff --git a/app-sci/scigraphica/scigraphica-0.8.0.ebuild b/app-sci/scigraphica/scigraphica-0.8.0.ebuild
index dfae6744d5d0..d5937b810c05 100644
--- a/app-sci/scigraphica/scigraphica-0.8.0.ebuild
+++ b/app-sci/scigraphica/scigraphica-0.8.0.ebuild
@@ -1,31 +1,26 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/scigraphica-0.8.0.ebuild,v 1.7 2003/02/13 09:25:28 vapier Exp $
-
-IUSE="gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="Scientific application for data analysis and technical graphics."
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/scigraphica-0.8.0.ebuild,v 1.8 2003/04/23 14:35:28 vapier Exp $
+DESCRIPTION="Scientific application for data analysis and technical graphics"
SRC_URI="http://scigraphica.sourceforge.net/src/${P}.tar.gz"
HOMEPAGE="http://scigraphica.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE="gnome"
DEPEND=">=x11-libs/gtk+extra-0.99.17
- >=dev-python/Numeric-20.3
- >=dev-libs/libxml-1.8.16
- gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r3 >=gnome-base/ORBit-0.5.12-r1 >=gnome-base/gnome-print-0.34 )"
- #bonobo? ( >=gnome-base/bonobo-1.0.18 )"
+ >=dev-python/Numeric-20.3
+ >=dev-libs/libxml-1.8.16
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r3 >=gnome-base/ORBit-0.5.12-r1 >=gnome-base/gnome-print-0.34 )"
+ #bonobo? ( >=gnome-base/bonobo-1.0.18 )"
src_compile() {
-
-#bonobo breaks compile when enabled so it is not enabled for now.
-#the result seems to be no printing under gnome.
-#also need to look into --with-lp and --with-lpr config flags
+ #bonobo breaks compile when enabled so it is not enabled for now.
+ #the result seems to be no printing under gnome.
+ #also need to look into --with-lp and --with-lpr config flags
local myconf=""
use gnome || myconf="${myconf} --without-gnome" #default enabled
@@ -47,14 +42,10 @@ src_compile() {
${myconf} || die "Configuration Failed"
emake || die "Parallel Make Failed"
-
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die "Installation Failed"
-
- dodoc ABOUT-NLS AUTHORS COPYING ChangeLog FAQ.compile \
+ dodoc AUTHORS ChangeLog FAQ.compile \
INSTALL NEWS README TODO
-
}