summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-08 08:22:05 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-08 08:22:05 +0000
commit98b4c0515b79c295478727c5bf0720e1d782728e (patch)
treef59ade9dd33ba0064972999b03d6a312297e4aec /app-sci/snns
parentlicense for snns package (diff)
downloadhistorical-98b4c0515b79c295478727c5bf0720e1d782728e.tar.gz
historical-98b4c0515b79c295478727c5bf0720e1d782728e.tar.bz2
historical-98b4c0515b79c295478727c5bf0720e1d782728e.zip
initial ebuild #10390
Diffstat (limited to 'app-sci/snns')
-rw-r--r--app-sci/snns/ChangeLog8
-rw-r--r--app-sci/snns/files/digest-snns-4.22
-rw-r--r--app-sci/snns/files/snns-4.2-gentoo.patch34
-rw-r--r--app-sci/snns/snns-4.2.ebuild49
4 files changed, 93 insertions, 0 deletions
diff --git a/app-sci/snns/ChangeLog b/app-sci/snns/ChangeLog
new file mode 100644
index 000000000000..ad8418cd8cd0
--- /dev/null
+++ b/app-sci/snns/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-sci/snns
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.1 2002/11/08 08:22:05 vapier Exp $
+
+*snns-4.2 (08 Nov 2002)
+
+ 08 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Patrick Kursawe <patrick.kursawe@web.de>.
diff --git a/app-sci/snns/files/digest-snns-4.2 b/app-sci/snns/files/digest-snns-4.2
new file mode 100644
index 000000000000..5777b9a356d0
--- /dev/null
+++ b/app-sci/snns/files/digest-snns-4.2
@@ -0,0 +1,2 @@
+MD5 4609dfd61714bfbb0842d4e8e905e584 SNNSv4.2.tar.gz 2170375
+MD5 e91242fdc43877013ade3b5f2213659a SNNSv4.2.Manual.pdf 2103861
diff --git a/app-sci/snns/files/snns-4.2-gentoo.patch b/app-sci/snns/files/snns-4.2-gentoo.patch
new file mode 100644
index 000000000000..c16385d6675d
--- /dev/null
+++ b/app-sci/snns/files/snns-4.2-gentoo.patch
@@ -0,0 +1,34 @@
+--- symtab.c.orig 2002-11-07 17:32:05.000000000 +0100
++++ tools/sources/symtab.c 2002-11-07 17:33:56.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <math.h> /* for MAXFLOAT */
++#include <values.h>
+
+ #include "symtab.ph"
+ #include "arglist.h"
+--- ui.h.orig 2002-11-07 17:37:06.000000000 +0100
++++ xgui/sources/ui.h 2002-11-07 17:37:44.000000000 +0100
+@@ -21,8 +21,8 @@
+
+ ******************************************************************************/
+
+-#ifndef __ui
+-#define __ui
++#ifndef snns_ui
++#define snns_ui
+
+ /* X11 */
+
+--- ui_config.c.orig 2002-11-07 18:35:43.000000000 +0100
++++ xgui/sources/ui_config.c 2002-11-07 18:37:34.000000000 +0100
+@@ -492,7 +492,7 @@
+ err = fscanf(filePtr,"%*[^:]: %d\n", &noParams);
+ chkretline(1);
+ lines++;
+- for (i=0; (i<UI_NO_LEARN_PARAMS+UI_NO_OF_CASCADE_PARAMS); i++){
++ for (i=0; (i<UI_NO_LEARN_PARAMS+UI_NO_OF_CASCADE_PARAMS) && (i<noParams); i++){
+ err = fscanf(filePtr,"%*[^:]: %f\n", &ui_learnParameters[i]);
+ chkretline(1);
+ lines++;
diff --git a/app-sci/snns/snns-4.2.ebuild b/app-sci/snns/snns-4.2.ebuild
new file mode 100644
index 000000000000..6c57fe9fa603
--- /dev/null
+++ b/app-sci/snns/snns-4.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2.ebuild,v 1.1 2002/11/08 08:22:05 vapier Exp $
+
+MY_P="SNNSv${PV}"
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/glibc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+}
+
+src_compile() {
+ econf "--enable-global"
+ emake || die "emake failed"
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${P}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${P}
+ doins default.cfg help.hdoc
+ use doc && doins ${DISTDIR}/SNNSv4.2.Manual.pdf
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*
+
+ doman man/man*/*
+}