summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Eichert <viz@gentoo.org>2002-12-22 23:22:11 +0000
committerTobias Eichert <viz@gentoo.org>2002-12-22 23:22:11 +0000
commitbcbfd2db2d9548aed2d658603bf33d6ad9dd6b22 (patch)
treed39ae9467c485365a00c83937a850d5beccdb260 /app-sci/spectromatic
parentChanged .tar.gz to .tar.bz2, removed --disable-a52 (diff)
downloadhistorical-bcbfd2db2d9548aed2d658603bf33d6ad9dd6b22.tar.gz
historical-bcbfd2db2d9548aed2d658603bf33d6ad9dd6b22.tar.bz2
historical-bcbfd2db2d9548aed2d658603bf33d6ad9dd6b22.zip
initial import
Diffstat (limited to 'app-sci/spectromatic')
-rw-r--r--app-sci/spectromatic/ChangeLog8
-rw-r--r--app-sci/spectromatic/files/spectromatic-1.0-gentoo.diff23
-rw-r--r--app-sci/spectromatic/spectromatic-1.0.ebuild32
3 files changed, 63 insertions, 0 deletions
diff --git a/app-sci/spectromatic/ChangeLog b/app-sci/spectromatic/ChangeLog
new file mode 100644
index 000000000000..7168bbb5eb07
--- /dev/null
+++ b/app-sci/spectromatic/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-sci/spectromatic
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spectromatic/ChangeLog,v 1.1 2002/12/22 23:22:11 viz Exp $
+
+*spectromatic-1.0 (23 Dec 2002)
+
+ 23 Dec 2002; Tobias Eichert <viz@gentoo.org> spectromatic-1.0.ebuild, files/spectromatic-1.0-gentoo.diff
+ Initial import.
diff --git a/app-sci/spectromatic/files/spectromatic-1.0-gentoo.diff b/app-sci/spectromatic/files/spectromatic-1.0-gentoo.diff
new file mode 100644
index 000000000000..9fef68467dfe
--- /dev/null
+++ b/app-sci/spectromatic/files/spectromatic-1.0-gentoo.diff
@@ -0,0 +1,23 @@
+--- Makefile.orig 2002-12-10 21:25:31.000000000 +0100
++++ Makefile 2002-12-10 21:25:20.000000000 +0100
+@@ -13,15 +13,16 @@
+
+ TARGET = spectromatic
+
+-install: all
++all: $(OBJ)
++ $(CC) -o $(TARGET) $(OBJ) $(LIBS)
++ strip $(TARGET)
++
++install:
+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/bin
+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
+ install -o root -g root -m 0755 spectromatic $(DESTDIR)$(TOPLEVEL_HOME)/bin
+ install -o root -g root -m 0644 man/spectromatic.1 $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
+
+-all: $(OBJ)
+- $(CC) -o $(TARGET) $(OBJ) $(LIBS)
+- strip $(TARGET)
+
+ clean:
+ $(RM) $(TARGET) $(OBJ)
diff --git a/app-sci/spectromatic/spectromatic-1.0.ebuild b/app-sci/spectromatic/spectromatic-1.0.ebuild
new file mode 100644
index 000000000000..dc3796a43254
--- /dev/null
+++ b/app-sci/spectromatic/spectromatic-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spectromatic/spectromatic-1.0.ebuild,v 1.1 2002/12/22 23:22:11 viz Exp $
+
+IUSE=""
+
+MY_P="spectromatic_1.0-1"
+DESCRIPTION="Little program that generates spectrograms (time-frequency analysis images) from mono or stereo wave files."
+HOMEPAGE="http://ieee.uow.edu.au/~daniel/software/spectromatic/"
+SRC_URI="http://ieee.uow.edu.au/~daniel/software/spectromatic/dist/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/gsl-1.2
+ >=media-libs/libpng-1.2.4"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
+}
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dobin spectromatic
+ doman spectromatic.1
+ dodoc COPYING README || die
+}