summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-25 22:57:28 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-25 22:57:28 +0000
commit015ebdf3ac894530c72a1d7c00f1f6329229c05a (patch)
tree00892c3924d26ea25428b310a72a2b3eb76ee873 /app-sci/tbass/tbass-20030725.3.3.ebuild
parentUpdate so gcc-3.4 is respected (#48933). (diff)
downloadhistorical-015ebdf3ac894530c72a1d7c00f1f6329229c05a.tar.gz
historical-015ebdf3ac894530c72a1d7c00f1f6329229c05a.tar.bz2
historical-015ebdf3ac894530c72a1d7c00f1f6329229c05a.zip
Add die following econf for bug 48950
Diffstat (limited to 'app-sci/tbass/tbass-20030725.3.3.ebuild')
-rw-r--r--app-sci/tbass/tbass-20030725.3.3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-sci/tbass/tbass-20030725.3.3.ebuild b/app-sci/tbass/tbass-20030725.3.3.ebuild
index 05cf807434d8..c3d9d6542942 100644
--- a/app-sci/tbass/tbass-20030725.3.3.ebuild
+++ b/app-sci/tbass/tbass-20030725.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/tbass-20030725.3.3.ebuild,v 1.6 2004/04/19 12:33:51 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/tbass-20030725.3.3.ebuild,v 1.7 2004/04/25 22:55:54 agriffis Exp $
inherit eutils
@@ -59,27 +59,27 @@ src_unpack() {
src_compile() {
# compile balsa
- econf
+ econf || die "econf failed"
sed -i -e "s: \$(bindir): \$(DESTDIR)\$(bindir):g" bin/Makefile
emake BALSAHOME=${S} || die
# configure tech paths
if [ $TECH_AMS ]; then
cd ${WORKDIR}/balsa-tech-ams-20030506
- econf
+ econf || die "econf failed"
fi
# config generic verilog backend
cd ${WORKDIR}/balsa-tech-verilog-20030204
- econf
+ econf || die "econf failed"
# config Xilinx FPGA backend
cd ${WORKDIR}/balsa-tech-xilinx-20021029
- econf
+ econf || die "econf failed"
# config example tech
cd ${WORKDIR}/balsa-tech-example-${My_PV}
- econf
+ econf || die "econf failed"
# config balsa-lard (deprecated, but may find some use for it)
#cd ${WORKDIR}/balsa-lard-${PV}