summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-09-22 11:57:28 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-09-22 11:57:28 +0000
commit0a4bf611722bfab358ed9aa46eef4dcd84e30be1 (patch)
tree5ddd171a05b33b07811961c3acf33835c68eab15 /app-sci
parentFixing bug 25429 and some other problems. (diff)
downloadhistorical-0a4bf611722bfab358ed9aa46eef4dcd84e30be1.tar.gz
historical-0a4bf611722bfab358ed9aa46eef4dcd84e30be1.tar.bz2
historical-0a4bf611722bfab358ed9aa46eef4dcd84e30be1.zip
Fixing bug 25429 and some other problems.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/snns/Manifest5
-rw-r--r--app-sci/snns/files/digest-snns-4.2-r32
-rw-r--r--app-sci/snns/snns-4.2-r3.ebuild71
3 files changed, 76 insertions, 2 deletions
diff --git a/app-sci/snns/Manifest b/app-sci/snns/Manifest
index d3519095b91b..894802f9d77a 100644
--- a/app-sci/snns/Manifest
+++ b/app-sci/snns/Manifest
@@ -1,5 +1,6 @@
-MD5 0ce0d72ccfd3fa0723919c35bb44c0ae snns-4.2-r3.ebuild 1606
-MD5 873ee3ec513deccf89eab34b6104970d ChangeLog 720
+MD5 b037c9de25cfce3f2c25e1697cabf132 snns-4.2-r3.ebuild 1836
+MD5 a0bf45d4d43996f0ffb5d68635f98d8d snns-4.2-r2.ebuild 1518
+MD5 e8b84ed98455d03318e1c7d0e8621dcb ChangeLog 951
MD5 c000c0728c9136f1b54cbc3a5fc07644 metadata.xml 220
MD5 1d0f7b62cbc65aedb05a087699dc2968 files/digest-snns-4.2-r2 126
MD5 1d0f7b62cbc65aedb05a087699dc2968 files/digest-snns-4.2-r3 126
diff --git a/app-sci/snns/files/digest-snns-4.2-r3 b/app-sci/snns/files/digest-snns-4.2-r3
new file mode 100644
index 000000000000..5777b9a356d0
--- /dev/null
+++ b/app-sci/snns/files/digest-snns-4.2-r3
@@ -0,0 +1,2 @@
+MD5 4609dfd61714bfbb0842d4e8e905e584 SNNSv4.2.tar.gz 2170375
+MD5 e91242fdc43877013ade3b5f2213659a SNNSv4.2.Manual.pdf 2103861
diff --git a/app-sci/snns/snns-4.2-r3.ebuild b/app-sci/snns/snns-4.2-r3.ebuild
new file mode 100644
index 000000000000..2d1f2c16093f
--- /dev/null
+++ b/app-sci/snns/snns-4.2-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2-r3.ebuild,v 1.1 2003/09/22 11:57:24 phosphan Exp $
+
+MY_P="SNNSv${PV}"
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="X doc"
+
+DEPEND="X? ( virtual/x11
+ x11-libs/Xaw3d )
+ >=sys-apps/sed-4
+ virtual/glibc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+ sed -i -e 's/Xaw/Xaw3d/g' xgui/sources/Makefile
+ sed -i -e 's/\(^#define MAX_NAME_LENGTH\).*/\1 4096/' xgui/sources/ui.h
+ sed -i -e 's/\(^#define MAX_DIR_ENTRIES\).*/\1 4096/' xgui/sources/ui_file.ph
+ sed -i -e 's/\(#define DIR_BUFFER_LENGTH\).*/\1 524288/' xgui/sources/ui_file.ph
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if [ `use X` ] ; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf}
+ emake ${compileopts} || die "emake failed"
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ if [ `use X` ] ; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${PF}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ insinto /usr/share/doc/${PF}
+ use doc && doins ${DISTDIR}/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+
+ doman man/man*/*
+}