summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-08 23:43:26 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-08 23:43:26 +0000
commit3629eff2029e1eab7d35ea177421dc063f0d445b (patch)
tree74fb4116e45f9edc63441d7ec8275327492c4916 /app-sci
parentA newer version :-( (diff)
downloadhistorical-3629eff2029e1eab7d35ea177421dc063f0d445b.tar.gz
historical-3629eff2029e1eab7d35ea177421dc063f0d445b.tar.bz2
historical-3629eff2029e1eab7d35ea177421dc063f0d445b.zip
updates per #10390
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/snns/ChangeLog7
-rw-r--r--app-sci/snns/files/digest-snns-4.2-r12
-rw-r--r--app-sci/snns/snns-4.2-r1.ebuild65
-rw-r--r--app-sci/snns/snns-4.2.ebuild38
4 files changed, 100 insertions, 12 deletions
diff --git a/app-sci/snns/ChangeLog b/app-sci/snns/ChangeLog
index ad8418cd8cd0..4d7b3e9cd3c0 100644
--- a/app-sci/snns/ChangeLog
+++ b/app-sci/snns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/snns
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.1 2002/11/08 08:22:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.2 2002/11/08 23:43:26 vapier Exp $
+
+*snns-4.2-r1 (08 Nov 2002)
+
+ 08 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added ability to use X or not ... #10390
*snns-4.2 (08 Nov 2002)
diff --git a/app-sci/snns/files/digest-snns-4.2-r1 b/app-sci/snns/files/digest-snns-4.2-r1
new file mode 100644
index 000000000000..5777b9a356d0
--- /dev/null
+++ b/app-sci/snns/files/digest-snns-4.2-r1
@@ -0,0 +1,2 @@
+MD5 4609dfd61714bfbb0842d4e8e905e584 SNNSv4.2.tar.gz 2170375
+MD5 e91242fdc43877013ade3b5f2213659a SNNSv4.2.Manual.pdf 2103861
diff --git a/app-sci/snns/snns-4.2-r1.ebuild b/app-sci/snns/snns-4.2-r1.ebuild
new file mode 100644
index 000000000000..fee2d8348d98
--- /dev/null
+++ b/app-sci/snns/snns-4.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2-r1.ebuild,v 1.1 2002/11/08 23:43:26 vapier Exp $
+
+MY_P="SNNSv${PV}"
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="X doc"
+
+DEPEND="X? ( virtual/x11 )
+ virtual/glibc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if [ `use X` ] ; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf}
+ emake ${compileopts} || die "emake failed"
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ if [ `use X` ] ; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${P}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${P}
+ dodoc default.cfg help.hdoc
+ fi
+
+ insinto /usr/share/doc/${P}
+ use doc && dodoc ${DISTDIR}/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*
+
+ doman man/man*/*
+}
diff --git a/app-sci/snns/snns-4.2.ebuild b/app-sci/snns/snns-4.2.ebuild
index 6c57fe9fa603..3b265233fb75 100644
--- a/app-sci/snns/snns-4.2.ebuild
+++ b/app-sci/snns/snns-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2.ebuild,v 1.1 2002/11/08 08:22:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2.ebuild,v 1.2 2002/11/08 23:43:26 vapier Exp $
MY_P="SNNSv${PV}"
DESCRIPTION="Stuttgart Neural Network Simulator"
@@ -11,37 +11,53 @@ SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
LICENSE="SNNS-${PV}"
KEYWORDS="x86"
SLOT="0"
-IUSE=""
+IUSE="X doc"
-DEPEND="virtual/x11
+DEPEND="X? ( virtual/x11 )
virtual/glibc"
S="${WORKDIR}/${MY_P}"
src_unpack() {
- unpack ${A}
+ unpack ${MY_P}.tar.gz
cd ${S}
patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
}
src_compile() {
- econf "--enable-global"
- emake || die "emake failed"
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if [ `use X` ] ; then
+ myconf="${myconf} --without-x"
+ else
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ fi
+
+ econf ${myconf}
+ emake ${compileopts} || die "emake failed"
}
src_install() {
for file in `find tools -type f -perm +100`; do
dobin $file
done
- newbin xgui/sources/xgui snns
- dodir /etc/env.d
- echo XGUILOADPATH=/usr/share/doc/${P}/ > ${D}/etc/env.d/99snns
+ if [ `use X` ] ; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${P}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${P}
+ dodoc default.cfg help.hdoc
+ fi
insinto /usr/share/doc/${P}
- doins default.cfg help.hdoc
- use doc && doins ${DISTDIR}/SNNSv4.2.Manual.pdf
+ use doc && dodoc ${DISTDIR}/${MY_P}.Manual.pdf
+
insinto /usr/share/doc/${P}/examples
doins examples/*