summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-04-26 10:43:34 +0000
committerMichael Imhof <tantive@gentoo.org>2003-04-26 10:43:34 +0000
commitcfa3f9d8b8983b38aa8a33162cf13cabfbb49d09 (patch)
tree1633dd94e45d389e0e5c3937652cc996f430116a /app-sci
parentwhoops forgot some changelog (diff)
downloadhistorical-cfa3f9d8b8983b38aa8a33162cf13cabfbb49d09.tar.gz
historical-cfa3f9d8b8983b38aa8a33162cf13cabfbb49d09.tar.bz2
historical-cfa3f9d8b8983b38aa8a33162cf13cabfbb49d09.zip
Added >=media-libs/imlib-1.9.14 to depend. Should close #19784.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/scigraphica/ChangeLog7
-rw-r--r--app-sci/scigraphica/files/digest-scigraphica-0.8.0-r11
-rw-r--r--app-sci/scigraphica/scigraphica-0.8.0-r1.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/app-sci/scigraphica/ChangeLog b/app-sci/scigraphica/ChangeLog
index 2dca3436e37f..05f8b070dc48 100644
--- a/app-sci/scigraphica/ChangeLog
+++ b/app-sci/scigraphica/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/scigraphica
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/ChangeLog,v 1.3 2003/02/12 05:19:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/ChangeLog,v 1.4 2003/04/26 10:43:34 tantive Exp $
+
+*scigraphica-0.8.0-r1 (26 Apr 2003)
+
+ 26 Apr 2003; Michael Imhof <tantive@gentoo.org> ChangeLog :
+ Added >=media-libs/imlib-1.9.14 to depend. Should close #19784.
*scigraphica-0.8.0 (1 Feb 2002)
diff --git a/app-sci/scigraphica/files/digest-scigraphica-0.8.0-r1 b/app-sci/scigraphica/files/digest-scigraphica-0.8.0-r1
new file mode 100644
index 000000000000..16631c877734
--- /dev/null
+++ b/app-sci/scigraphica/files/digest-scigraphica-0.8.0-r1
@@ -0,0 +1 @@
+MD5 8527c80fe75bc4f72c14548c7a2b0b71 scigraphica-0.8.0.tar.gz 841199
diff --git a/app-sci/scigraphica/scigraphica-0.8.0-r1.ebuild b/app-sci/scigraphica/scigraphica-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..8b73c40e38ab
--- /dev/null
+++ b/app-sci/scigraphica/scigraphica-0.8.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/scigraphica-0.8.0-r1.ebuild,v 1.1 2003/04/26 10:43:34 tantive Exp $
+
+DESCRIPTION="Scientific application for data analysis and technical graphics"
+SRC_URI="http://scigraphica.sourceforge.net/src/${P}.tar.gz"
+HOMEPAGE="http://scigraphica.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gnome"
+
+DEPEND=">=x11-libs/gtk+extra-0.99.17
+ >=dev-python/Numeric-20.3
+ >=dev-libs/libxml-1.8.16
+ >=media-libs/imlib-1.9.14
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r3 >=gnome-base/ORBit-0.5.12-r1 >=gnome-base/gnome-print-0.34 )"
+ #bonobo? ( >=gnome-base/bonobo-1.0.18 )"
+
+src_compile() {
+ #bonobo breaks compile when enabled so it is not enabled for now.
+ #the result seems to be no printing under gnome.
+ #also need to look into --with-lp and --with-lpr config flags
+
+ local myconf=""
+ use gnome || myconf="${myconf} --without-gnome" #default enabled
+# use bonobo && myconf="${myconf} --with-bonobo" #default disabled
+
+ #fix Exec= in sg.desktop
+ cp sg.desktop sg.desktop.orig
+ sed -e 's:\(Exec=\)sga:\1scigraphica:' sg.desktop.orig > sg.desktop
+
+ #fix termcap dependency
+ cp configure configure.orig
+ sed -e 's:-ltermcap:-lncurses:' configure.orig > configure
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation Failed"
+ dodoc AUTHORS ChangeLog FAQ.compile \
+ INSTALL NEWS README TODO
+}