summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-09-12 16:14:38 +0000
committerChristian Birchinger <joker@gentoo.org>2003-09-12 16:14:38 +0000
commit37c4492788be581d7c777eabe619d05d27e9496c (patch)
tree8fda47786447741a95b98a05d49eb99845ec8b6c /app-shells/bash-completion
parentfixing Manifest (diff)
downloadhistorical-37c4492788be581d7c777eabe619d05d27e9496c.tar.gz
historical-37c4492788be581d7c777eabe619d05d27e9496c.tar.bz2
historical-37c4492788be581d7c777eabe619d05d27e9496c.zip
Version bump
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/Manifest4
-rw-r--r--app-shells/bash-completion/bash-completion-20030911.ebuild55
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200309111
4 files changed, 66 insertions, 2 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 56fe7d87fb6b..63631a64676c 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.39 2003/09/12 16:10:13 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.40 2003/09/12 16:14:33 joker Exp $
+
+*bash-completion-20030911 (12 Sep 2003)
+
+ 12 Sep 2003; Christian Birchinger <joker@gentoo.org>
+ bash-completion-20030911.ebuild:
+ Version bump
12 Sep 2003; Christian Birchinger <joker@gentoo.org>
bash-completion-20030821.ebuild:
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 6d402ac81f1b..3a4df8a77a4c 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,8 +1,9 @@
-MD5 c965ef301778cff2c960e7f1547c40a4 ChangeLog 4846
+MD5 7f9d716429b44b78ee5160e0a1b8538d ChangeLog 4993
MD5 822273ec32f2d50fd50a34a3e91fd585 bash-completion-20030505-r1.ebuild 1464
MD5 404e3e265fe61db29a8d6557f018a9c9 bash-completion-20030713.ebuild 1466
MD5 4e281359f4e0adb7356cab7bb57b4c5c bash-completion-20030721.ebuild 1466
MD5 50fcce59b9431ba9f2793307e242816e bash-completion-20030821.ebuild 1458
+MD5 1649be05c198e025a4f55fad21039188 bash-completion-20030911.ebuild 1466
MD5 c85a85bd33aac22ae4872c85733e581f files/README.gentoo 491
MD5 9b22241df7258cb9677cf9a1497e07c5 files/bash-completion 625
MD5 86466a747ec82cd05ba511f06125c947 files/digest-bash-completion-20030505-r1 76
@@ -10,3 +11,4 @@ MD5 3df1918a609a7b2fb8a30f9dd59f552f files/gentoo.completion 15096
MD5 069e386b2f6e85a4b86d4929bfb1f585 files/digest-bash-completion-20030713 76
MD5 60d3ff2b99d75697ce01c2ca72ade293 files/digest-bash-completion-20030721 76
MD5 27ea6237a77a7e7edf98246e855b0a82 files/digest-bash-completion-20030821 76
+MD5 659a0dbd2bc885c9b718cb86d91f6a16 files/digest-bash-completion-20030911 76
diff --git a/app-shells/bash-completion/bash-completion-20030911.ebuild b/app-shells/bash-completion/bash-completion-20030911.ebuild
new file mode 100644
index 000000000000..4856c04fee55
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20030911.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030911.ebuild,v 1.1 2003/09/12 16:14:33 joker Exp $
+
+S=${WORKDIR}/${PN/-/_}
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64"
+
+DEPEND="sys-apps/tar
+ sys-apps/bzip2"
+
+RDEPEND=">=app-shells/bash-2.05a"
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /etc/bash_completion.d
+
+ doins contrib/unrar
+ doins contrib/harbour
+ doins contrib/isql
+ doins contrib/larch
+ doins contrib/lilypond
+ doins contrib/p4
+ doins contrib/ri
+
+ newins ${FILESDIR}/gentoo.completion gentoo
+
+ insinto /etc/profile.d
+ doins ${FILESDIR}/bash-completion
+
+ dodoc COPYING Changelog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ echo
+
+ if [ -f /etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ echo
+ fi
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20030911 b/app-shells/bash-completion/files/digest-bash-completion-20030911
new file mode 100644
index 000000000000..1bda8a1127f4
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20030911
@@ -0,0 +1 @@
+MD5 594efc56cc2b2d10a6118a6c01bee328 bash-completion-20030911.tar.bz2 71443