summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-06 14:58:26 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-06 14:58:26 +0000
commita6f73b52b712961f05d2a78d991f6144c1c76968 (patch)
tree33139699880024dc7d5ad8e9d1f1510182c83a62 /app-shells/sash
parentVersion bump and libpcap includes fixed (diff)
downloadhistorical-a6f73b52b712961f05d2a78d991f6144c1c76968.tar.gz
historical-a6f73b52b712961f05d2a78d991f6144c1c76968.tar.bz2
historical-a6f73b52b712961f05d2a78d991f6144c1c76968.zip
touchups
Diffstat (limited to 'app-shells/sash')
-rw-r--r--app-shells/sash/sash-3.6.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/app-shells/sash/sash-3.6.ebuild b/app-shells/sash/sash-3.6.ebuild
index e96f7e77e33a..69777928cadb 100644
--- a/app-shells/sash/sash-3.6.ebuild
+++ b/app-shells/sash/sash-3.6.ebuild
@@ -1,37 +1,30 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.6.ebuild,v 1.5 2003/12/17 03:43:39 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.6.ebuild,v 1.6 2004/02/06 14:58:26 vapier Exp $
-IUSE="readline"
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="A small static UNIX Shell with readline support"
-SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
-SLOT="0"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+
LICENSE="freedist"
+SLOT="0"
+IUSE="readline"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64 ppc64"
DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.4
readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
-
RDEPEND=""
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64 ppc64"
src_unpack() {
-
unpack ${P}.tar.gz
cd ${S}
epatch ${FILESDIR}/sash-3.6-fix-includes.patch
-
- if [ "`use readline`" ]
- then
- epatch ${FILESDIR}/sash-3.6-readline.patch
- fi
-
+ [ `use readline` ] && epatch ${FILESDIR}/sash-3.6-readline.patch
sed -e "s:-O3:${CFLAGS}:" -i Makefile
-
}
src_compile() {
@@ -41,7 +34,6 @@ src_compile() {
src_install() {
into /
dobin sash
- into /usr
doman sash.1
dodoc README
}