summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-01-18 17:51:13 +0000
committerMamoru Komachi <usata@gentoo.org>2004-01-18 17:51:13 +0000
commit7581007d5f3a10065855ea15c3be5d89f1114364 (patch)
tree18fcc09f030d6892dd3c67dc7ffcdc0769f65737 /app-shells
parentFixed bug #38356 and #33130 (diff)
downloadhistorical-7581007d5f3a10065855ea15c3be5d89f1114364.tar.gz
historical-7581007d5f3a10065855ea15c3be5d89f1114364.tar.bz2
historical-7581007d5f3a10065855ea15c3be5d89f1114364.zip
Fixed bug #38356 and #33130
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/Manifest8
-rw-r--r--app-shells/zsh/files/_portage22
-rw-r--r--app-shells/zsh/files/digest-zsh-4.0.9-r23
-rw-r--r--app-shells/zsh/files/digest-zsh-4.1.1-r43
-rw-r--r--app-shells/zsh/files/zsh-strncmp.diff11
-rw-r--r--app-shells/zsh/zsh-4.0.9-r2.ebuild97
-rw-r--r--app-shells/zsh/zsh-4.1.1-r4.ebuild125
7 files changed, 261 insertions, 8 deletions
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
index 2d34e7803891..a3e4d60cc4ff 100644
--- a/app-shells/zsh/Manifest
+++ b/app-shells/zsh/Manifest
@@ -1,13 +1,13 @@
MD5 226ad84ab10a74bbc8cf0dea1329941c zsh-4.0.7-r1.ebuild 2291
MD5 23e900b112727caac5567ac36ddd60ea zsh-4.0.9.ebuild 2469
MD5 a0a4947a1238749d1f49b03c4697055a zsh-4.1.1-r2.ebuild 3057
-MD5 be74f3e2307b9eaf4400972d997b2b6b ChangeLog 6651
+MD5 dc79d2b364b80df4eb879e1531976950 ChangeLog 6844
MD5 28ed8ea6cdccb353e2e8ad783eb51f5b metadata.xml 506
MD5 0d12007c5eebbe15ac6052e8d7489f69 zsh-4.0.9-r1.ebuild 2591
MD5 39d0fa380eb9e44e5d8771b357472017 zsh-4.1.1-r3.ebuild 3307
-MD5 4bb4ad7885420ba89c7ae3bacad7bc0b zsh-4.0.9-r2.ebuild 2630
-MD5 bb68223a15a9cbfe419015eda5485584 zsh-4.1.1-r4.ebuild 3346
-MD5 0ecfdd86dc02a38143de6d6578e15f6d files/_portage 7539
+MD5 a9a9386cc7a58ea21807a4edaacb9534 zsh-4.0.9-r2.ebuild 2630
+MD5 a36d8a2cb269b634a7e01a35d364371f zsh-4.1.1-r4.ebuild 3346
+MD5 2aa47fce01c92a0cc7e070f04018ac93 files/_portage 7539
MD5 69b64f833140e51ce26127a2336e7766 files/digest-zsh-4.0.7-r1 127
MD5 de58f149f41740c394800ba8d2cdf361 files/digest-zsh-4.0.9-r1 199
MD5 4823f16213517c590b1e624afe52271d files/digest-zsh-4.1.1-r2 132
diff --git a/app-shells/zsh/files/_portage b/app-shells/zsh/files/_portage
index 688abda0ca12..d61e7cf71c00 100644
--- a/app-shells/zsh/files/_portage
+++ b/app-shells/zsh/files/_portage
@@ -1,6 +1,6 @@
#compdef emerge
-# $Id: _portage,v 1.1 2003/12/28 19:51:46 usata Exp $
+# $Id: _portage,v 1.2 2004/01/18 17:51:04 usata Exp $
# ZSH completion function for emerge
# Author: baptux <bapt@ifrance.com>
@@ -16,13 +16,17 @@ _emerge () {
case "$words[2]" in
unmerge|-C)
_arguments -s \
- '*:installed pkg:_portage_unmerge' "$common_args[@]" && return 0
+ '*:installed pkgname with versions:_portage_unmerge' "$common_args[@]" && return 0
+ ;;
+ clean|-c)
+ _arguments -s \
+ '*:installed pkgname:_portage_clean' "$common_args[@]" && return 0
;;
--usepkgonly|-K)
_arguments -s \
'*:use package only:_portage_tbz2list' "$common_args[@]" && return 0
;;
- clean|depclean|-c|help|-h|info|regen|sync|rsync|--searchdesc|-S|search|-s|inject|-j|prune|-P)
+ depclean|help|-h|info|regen|sync|rsync|--searchdesc|-S|search|-s|inject|-j|prune|-P)
;;
*)
_arguments -s \
@@ -49,7 +53,7 @@ _emerge () {
done
}
-#Function to show only installed packages "cat/name"
+#Function to show only installed packages "cat/name-ver"
_portage_unmerge(){
installed_portage=(/var/db/pkg/*-*/*)
installed_dir=/var/db/pkg/
@@ -57,6 +61,16 @@ _portage_unmerge(){
_tags -s installed_pkg && { compadd "$@" -k installed_pkg || compadd "$@" ${(kv)=installed_pkg} }
}
+#Functions to show "cat/name", classes and dependencies
+_portage_clean() {
+ installed_portage=(/var/db/pkg/*-*/*)
+ installed_dir=/var/db/pkg/
+ installed_pkg=${installed_portage//$installed_dir/}
+ installed_pkgname=${(M)${${installed_portage##*/}%%-[0-9]*}}
+ _tags -s installed_pkg && { compadd "$@" -k installed_pkg || compadd "$@" ${(kv)=installed_pkg} }
+ _tags -s installed_pkgname && { compadd "$@" -k installed_pkgname || compadd "$@" ${(kv)=installed_pkgname} }
+}
+
#Function to show tbz2 files available
_portage_tbz2list() {
# this doesn't take care of ${PORTAGE_BINHOST}. If Gentoo official
diff --git a/app-shells/zsh/files/digest-zsh-4.0.9-r2 b/app-shells/zsh/files/digest-zsh-4.0.9-r2
new file mode 100644
index 000000000000..19f27e152f5f
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.0.9-r2
@@ -0,0 +1,3 @@
+MD5 26cc0f9051ba41063e950723246dfaa8 zsh-4.0.9.tar.bz2 1749802
+MD5 f7032dd0a992cba7bb903ab90a9ca667 zsh-4.0.9-doc.tar.bz2 1411985
+MD5 1e755a2ffa0bad11b0ebc7d5d7622674 zsh-4.0.9-euc-0.2.patch.gz 2869
diff --git a/app-shells/zsh/files/digest-zsh-4.1.1-r4 b/app-shells/zsh/files/digest-zsh-4.1.1-r4
new file mode 100644
index 000000000000..f9bbd87c4098
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.1.1-r4
@@ -0,0 +1,3 @@
+MD5 48958b1a3fc86261a26eea40a4f7d4af zsh-4.1.1.tar.bz2 1924514
+MD5 a4fb455591ee95e5264bf985af3473ea zsh-4.1.1-euc-0.2.patch.gz 2788
+MD5 3ec54fa702b9a5c5209b56c2c8ed6a88 zsh-4.1.1-doc.tar.bz2 1572953
diff --git a/app-shells/zsh/files/zsh-strncmp.diff b/app-shells/zsh/files/zsh-strncmp.diff
new file mode 100644
index 000000000000..c75b28048542
--- /dev/null
+++ b/app-shells/zsh/files/zsh-strncmp.diff
@@ -0,0 +1,11 @@
+--- Src/Zle/compmatch.c.orig 2004-01-15 18:37:39.000000000 -0600
++++ Src/Zle/compmatch.c 2004-01-15 18:38:45.000000000 -0600
+@@ -341,7 +341,7 @@
+
+ /* If the anchors are equal, we keep only one. */
+
+- if (!strncmp(l, w, wl))
++ if (wl == 0 || !strncmp(l, w, wl))
+ l = NULL;
+
+ /* Split the new part into parts and turn the last one into a
diff --git a/app-shells/zsh/zsh-4.0.9-r2.ebuild b/app-shells/zsh/zsh-4.0.9-r2.ebuild
new file mode 100644
index 000000000000..095fecddec4c
--- /dev/null
+++ b/app-shells/zsh/zsh-4.0.9-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.9-r2.ebuild,v 1.1 2004/01/18 17:51:04 usata Exp $
+
+IUSE="maildir ncurses static doc cjk"
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
+ doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )
+ cjk? ( http://www.ono.org/software/dist/${P}-euc-0.2.patch.gz )"
+
+SLOT="0"
+LICENSE="ZSH"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+
+DEPEND="virtual/glibc
+ sys-apps/groff
+ ${RDEPEND}"
+RDEPEND="ncurses? ( >=sys-libs/ncurses-5.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use cjk && epatch ../${P}-euc-0.2.patch
+ epatch ${FILESDIR}/${PN}-strncmp.diff
+ cd ${S}/Doc
+ ln -sf . man1
+ # fix zshall problem with soelim
+ soelim zshall.1 > zshall.1.soelim
+ mv zshall.1.soelim zshall.1
+}
+
+src_compile() {
+ local myconf
+
+ use ncurses && myconf="--with-curses-terminfo"
+ use maildir && myconf="${myconf} --enable-maildir-support"
+ use static && myconf="${myconf} --disable-dynamic" \
+ && LDFLAGS="${LDFLAGS} -static"
+
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/lib \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/zsh/zprofile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --enable-ldflags="${LDFLAGS}" \
+ ${myconf} || die "configure failed"
+ # emake still b0rks
+ make || die "make failed"
+ #make check || die "make check failed"
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin \
+ libdir=${D}/usr/lib \
+ fndir=${D}/usr/share/zsh/${PV}/functions \
+ sitefndir=${D}/usr/share/zsh/site-functions \
+ install.bin install.man install.modules \
+ install.info install.fns || die "make install failed"
+
+ insinto /etc/zsh
+ doins ${FILESDIR}/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/site-functions
+ doins ${FILESDIR}/_portage
+
+ dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
+
+ if [ "`use doc`" ] ; then
+ dohtml Doc/*
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh{.dvi,_us.ps,_a4.ps}
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_preinst() {
+ # Our zprofile file does the job of the old zshenv file
+ # Move the old version into a zprofile script so the normal
+ # etc-update process will handle any changes.
+ if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
+ mv /etc/zsh/zshenv /etc/zsh/zprofile
+ fi
+}
diff --git a/app-shells/zsh/zsh-4.1.1-r4.ebuild b/app-shells/zsh/zsh-4.1.1-r4.ebuild
new file mode 100644
index 000000000000..54064eb8c014
--- /dev/null
+++ b/app-shells/zsh/zsh-4.1.1-r4.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.1.1-r4.ebuild,v 1.1 2004/01/18 17:51:04 usata Exp $
+
+inherit eutils
+
+IUSE="cjk maildir ncurses static doc"
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
+ cjk? ( http://www.ono.org/software/dist/${P}-euc-0.2.patch.gz )
+ doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
+
+SLOT="0"
+LICENSE="ZSH"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64 ~hppa"
+
+DEPEND="sys-apps/groff
+ >=sys-apps/sed-4
+ ${RDEPEND}"
+RDEPEND=">=dev-libs/libpcre-3.9
+ sys-libs/libcap
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use doc && unpack ${P}-doc.tar.bz2
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ use cjk && epatch ${DISTDIR}/${P}-euc-0.2.patch.gz
+ epatch ${FILESDIR}/${PN}-strncmp.diff
+ cd ${S}/Doc
+ ln -sf . man1
+ # fix zshall problem with soelim
+ soelim zshall.1 > zshall.1.soelim
+ mv zshall.1.soelim zshall.1
+}
+
+src_compile() {
+ local myconf
+
+ use ncurses && myconf="--with-curses-terminfo"
+ use maildir && myconf="${myconf} --enable-maildir-support"
+ use static && myconf="${myconf} --disable-dynamic" \
+ && LDFLAGS="${LDFLAGS} -static"
+
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/lib \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/zsh/zprofile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --enable-ldflags="${LDFLAGS}" \
+ ${myconf} || die "configure failed"
+
+ if [ -n "`use static`" ] ; then
+ # compile all modules statically, see Bug #27392
+ sed -i -e "s/link=no/link=static/g" \
+ -e "s/load=no/load=yes/g" \
+ config.modules || die
+ else
+ # avoid linking to libs in /usr/lib, see Bug #27064
+ sed -i -e "/LIBS/s%-lpcre%/usr/lib/libpcre.a%" \
+ Makefile || die
+ fi
+
+ # emake still b0rks
+ make || die "make failed"
+ #make check || die "make check failed"
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin \
+ libdir=${D}/usr/lib \
+ fndir=${D}/usr/share/zsh/${PV}/functions \
+ sitefndir=${D}/usr/share/zsh/site-functions \
+ install.bin install.man install.modules \
+ install.info install.fns || die "make install failed"
+
+ insinto /etc/zsh
+ doins ${FILESDIR}/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/site-functions
+ doins ${FILESDIR}/_portage
+
+ dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
+
+ if [ "`use doc`" ] ; then
+ dohtml Doc/*
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh{.dvi,_us.ps,_a4.ps}
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_preinst() {
+ # Our zprofile file does the job of the old zshenv file
+ # Move the old version into a zprofile script so the normal
+ # etc-update process will handle any changes.
+ if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
+ mv /etc/zsh/zshenv /etc/zsh/zprofile
+ fi
+}
+
+pkg_postinst() {
+
+ # see Bug 26776
+ ewarn
+ ewarn "If you are upgrading from zsh-4.0.x you may need to"
+ ewarn "remove all your old ~/.zcompdump files in order to use"
+ ewarn "completion. For more info see zcompsys manpage."
+ ewarn
+}