summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-03-27 09:45:16 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-03-27 09:45:16 +0000
commite735fd0aec1f3af706e89f663ce6acfa24c2b3c3 (patch)
tree216bd6542d12e18368f2a707f320413f3067122c /app-shells
parentremoved w3m-m17n (diff)
downloadhistorical-e735fd0aec1f3af706e89f663ce6acfa24c2b3c3.tar.gz
historical-e735fd0aec1f3af706e89f663ce6acfa24c2b3c3.tar.bz2
historical-e735fd0aec1f3af706e89f663ce6acfa24c2b3c3.zip
bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/ChangeLog7
-rw-r--r--app-shells/ksh/Manifest6
-rw-r--r--app-shells/ksh/files/digest-ksh-93.200502023
-rw-r--r--app-shells/ksh/ksh-93.20050202.ebuild69
4 files changed, 82 insertions, 3 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index e87f97dbffd0..eb94938f715c 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/ksh
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.20 2005/01/02 21:47:49 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.21 2005/03/27 09:45:16 taviso Exp $
+
+*ksh-93.20050202 (27 Mar 2005)
+
+ 27 Mar 2005; Tavis Ormandy <taviso@gentoo.org> +ksh-93.20050202.ebuild:
+ bump
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index 9566292a12d1..1591bb385919 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,8 +1,10 @@
+MD5 c76bed5dac630d03d14254b4709f6ba6 ksh-93.20050202.ebuild 1884
MD5 6468ba68114d77416bebf8d6714e51ab ksh-93.20040229.ebuild 2288
-MD5 7e23fc6795e3181c3c459770c2a65a6a ChangeLog 2426
MD5 6d76d9854c5218e7fe05ecdb64486545 ksh-93.20030724.ebuild 2378
+MD5 bae6bc6856dd45838b15b17a58769c33 ChangeLog 2539
MD5 e283b9362f2885bedf238e7c08f51e26 metadata.xml 1272
MD5 c2103b0157f069fd50dacdf50670d848 files/ksh-build-problems.diff 303
-MD5 9d9dc80da41b462852a6632153563619 files/digest-ksh-93.20040229 206
MD5 fc05a830ab720e8d3462bb10f0474258 files/ksh-93.20030724-libs.diff 12867
MD5 75a91bdad38d09a163894fd8ebc8adff files/digest-ksh-93.20030724 206
+MD5 9d9dc80da41b462852a6632153563619 files/digest-ksh-93.20040229 206
+MD5 da9b0b1c8ec37e2f3c71214296964484 files/digest-ksh-93.20050202 206
diff --git a/app-shells/ksh/files/digest-ksh-93.20050202 b/app-shells/ksh/files/digest-ksh-93.20050202
new file mode 100644
index 000000000000..be40e569ca6e
--- /dev/null
+++ b/app-shells/ksh/files/digest-ksh-93.20050202
@@ -0,0 +1,3 @@
+MD5 50339ec5c16f102e865f8f766da9016d INIT.2005-02-02.tgz 298407
+MD5 fecce7e67b55fe986c7c2163346e0977 ast-ksh.2005-02-02.tgz 1529366
+MD5 5a5e306db1323a7b0d17a58a2da43f48 ast-ksh-locale.2005-02-02.tgz 571632
diff --git a/app-shells/ksh/ksh-93.20050202.ebuild b/app-shells/ksh/ksh-93.20050202.ebuild
new file mode 100644
index 000000000000..7def13863d24
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20050202.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20050202.ebuild,v 1.1 2005/03/27 09:45:16 taviso Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+RELEASE="2005-02-02"
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+SRC_URI="http://www.research.att.com/~gsf/download/tgz/INIT.${RELEASE}.tgz
+ http://www.research.att.com/~gsf/download/tgz/ast-ksh.${RELEASE}.tgz
+ nls? ( http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.${RELEASE}.tgz )"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~arm ~s390 ~ia64 ~ppc"
+IUSE="static nls"
+
+DEPEND="virtual/libc !app-shells/pdksh"
+
+S=${WORKDIR}
+
+src_unpack() {
+ # the AT&T build tools look in here for packages.
+ mkdir -p ${S}/lib/package/tgz
+
+ # move the packages into place.
+ cp ${DISTDIR}/ast-ksh.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
+
+ if use nls; then
+ cp ${DISTDIR}/ast-ksh-locale.2003-04-22.tgz ${S}/lib/package/tgz/ || die
+ fi
+
+ # INIT provides the basic tools to start building.
+ unpack INIT.${RELEASE}.tgz
+
+ # `package read` will unpack any tarballs put in place.
+ ${S}/bin/package read || die
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ export CCFLAGS="${CFLAGS}"
+ cd ${S}; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
+
+ # install the optional locale data.
+ if use nls; then
+ cd ${S}; ./bin/package only make ast-ksh-locale CC=${CC:-gcc}
+ fi
+}
+
+src_install() {
+ # check where the build scripts put them
+ local my_arch="${S}/arch/$(${S}/bin/package)"
+
+ exeinto /bin
+ doexe ${my_arch}/bin/ok/ksh || die
+
+ dosym /bin/ksh /bin/ksh93
+
+ newman ${my_arch}/man/man1/sh.1 ksh.1
+ dodoc lib/package/LICENSES/ast lib/package/gen/ast-ksh.txt
+
+ if use nls; then
+ dodir /usr/share
+ mv ${S}/share/lib/locale ${D}/usr/share
+ fi
+}