summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2004-07-30 21:09:05 +0000
committerAnders Rune Jensen <arj@gentoo.org>2004-07-30 21:09:05 +0000
commite73873d2f2f8648ab457668474a2c7f743795ef8 (patch)
tree2a4258583cfb03ef4ee6f1376b15caa14def026c /app-text/aspell
parentRemoving another obsolete one now (diff)
downloadhistorical-e73873d2f2f8648ab457668474a2c7f743795ef8.tar.gz
historical-e73873d2f2f8648ab457668474a2c7f743795ef8.tar.bz2
historical-e73873d2f2f8648ab457668474a2c7f743795ef8.zip
fix bug 48865
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog5
-rw-r--r--app-text/aspell/Manifest9
-rw-r--r--app-text/aspell/aspell-0.50.5-r2.ebuild3
-rw-r--r--app-text/aspell/files/aspell-quotechar-fix.patch13
4 files changed, 24 insertions, 6 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index e5ce44b3460d..88ea57f494a0 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.49 2004/07/24 19:33:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.50 2004/07/30 21:09:05 arj Exp $
+
+ 30 Jul 2004; Anders Rune Jensen <arj@gentoo.org> aspell-0.50.5-r2.ebuild:
+ Bugfix for aspell --mode=email by Alex Efros. Very good work! (#48865).
24 Jul 2004; Alastair Tse <liquidx@gentoo.org> aspell-0.50.5-r2.ebuild:
fixed SRC_URI to use mirror://gnu (#55523)
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index b743bce62ffa..c3cc3d6e6d5b 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,7 +1,8 @@
-MD5 99f84a8acb8e2e1b8bffde8711b06d57 aspell-0.50.5-r2.ebuild 1953
-MD5 e80e4631ad2a8a2c420b7a5df5dd147e ChangeLog 8654
+MD5 c6c7bb2b4950bf7e9af89ce5ba8b1886 ChangeLog 8801
+MD5 aa27f7dd2cccb4862944b51f8884d07c aspell-0.50.5-r2.ebuild 1995
MD5 eb03775ece62e57725480e782cd84ee8 metadata.xml 162
MD5 4fa550930c5e5fb38177ac9f77619891 files/01-gcc3.3-assert.patch 309
-MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5-r2 66
-MD5 02560c627d075d243720f1067bf45bcf files/aspell-buffer-fix.patch 1556
MD5 f956a4b48687a0823d0d5d7608b567e9 files/02-gcc3.3-constcast.patch 453
+MD5 02560c627d075d243720f1067bf45bcf files/aspell-buffer-fix.patch 1556
+MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5-r2 66
+MD5 ec7c300a1661ae94b55736f74a045bab files/aspell-quotechar-fix.patch 473
diff --git a/app-text/aspell/aspell-0.50.5-r2.ebuild b/app-text/aspell/aspell-0.50.5-r2.ebuild
index 96bb3650ebae..0c8002669a62 100644
--- a/app-text/aspell/aspell-0.50.5-r2.ebuild
+++ b/app-text/aspell/aspell-0.50.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5-r2.ebuild,v 1.6 2004/07/24 19:33:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5-r2.ebuild,v 1.7 2004/07/30 21:09:05 arj Exp $
inherit libtool eutils flag-o-matic
@@ -28,6 +28,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PN}-buffer-fix.patch
+ epatch ${FILESDIR}/${PN}-quotechar-fix.patch
}
src_compile() {
diff --git a/app-text/aspell/files/aspell-quotechar-fix.patch b/app-text/aspell/files/aspell-quotechar-fix.patch
new file mode 100644
index 000000000000..2c600547d1fa
--- /dev/null
+++ b/app-text/aspell/files/aspell-quotechar-fix.patch
@@ -0,0 +1,13 @@
+diff -uNr ./modules/filter/email.cpp ./modules/filter/email.cpp
+--- ./modules/filter/email.cpp 2004-04-24 12:39:56.371216800 +0300
++++ ./modules/filter/email.cpp 2004-04-24 12:40:05.521825696 +0300
+@@ -33,7 +33,8 @@
+ memset(data, 0, sizeof(bool)*256);
+ return no_err;
+ }
+- bool have(char c) {
++ bool have(FilterChar::Chr c) {
++ if (c > 255) return false;
+ return data[static_cast<unsigned char>(c)];
+ }
+ QuoteChars() {clear();}