summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-01-19 15:08:07 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-01-19 15:08:07 +0000
commit87be27862264581ae2bba7a7a381522d82340715 (patch)
tree713748212cface125c334e751fef3d94743ac65f /app-text/ggv/ggv-2.12.0.ebuild
parentKeyworded ~sparc (diff)
downloadhistorical-87be27862264581ae2bba7a7a381522d82340715.tar.gz
historical-87be27862264581ae2bba7a7a381522d82340715.tar.bz2
historical-87be27862264581ae2bba7a7a381522d82340715.zip
version bump, fixes #119413
Package-Manager: portage-2.0.53
Diffstat (limited to 'app-text/ggv/ggv-2.12.0.ebuild')
-rw-r--r--app-text/ggv/ggv-2.12.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/ggv/ggv-2.12.0.ebuild b/app-text/ggv/ggv-2.12.0.ebuild
new file mode 100644
index 000000000000..cbc1a634481c
--- /dev/null
+++ b/app-text/ggv/ggv-2.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-2.12.0.ebuild,v 1.1 2006/01/19 15:08:07 allanonjl Exp $
+
+inherit gnome2
+
+DESCRIPTION="The GNOME PostScript document viewer"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/gconf-2
+ virtual/ghostscript
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.30"
+
+PROVIDE="virtual/psviewer"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-pdf-options $(use_enable debug bonobo-debug)"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ gnome2_omf_fix
+}