summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-09-22 12:44:00 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-09-22 12:44:00 +0000
commit022838f1800801249b23dc905a26027e24fed063 (patch)
treef4169a2d44a7898bf49440ab055be81589680389 /app-text/gsview/gsview-4.6.ebuild
parentstable on amd64 (diff)
downloadhistorical-022838f1800801249b23dc905a26027e24fed063.tar.gz
historical-022838f1800801249b23dc905a26027e24fed063.tar.bz2
historical-022838f1800801249b23dc905a26027e24fed063.zip
version bump, bug #62062
Diffstat (limited to 'app-text/gsview/gsview-4.6.ebuild')
-rw-r--r--app-text/gsview/gsview-4.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/gsview/gsview-4.6.ebuild b/app-text/gsview/gsview-4.6.ebuild
new file mode 100644
index 000000000000..f4eafe3a6aa8
--- /dev/null
+++ b/app-text/gsview/gsview-4.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/gsview-4.6.ebuild,v 1.1 2004/09/22 12:44:00 lanius Exp $
+
+MY_PV="${PV/.}"
+DESCRIPTION="gsView PostScript and PDF viewer"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/gsv${MY_PV}src.zip"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/"
+
+IUSE="doc"
+SLOT="0"
+LICENSE="Aladdin"
+KEYWORDS="~x86"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ app-text/ghostscript-afpl"
+
+src_compile() {
+ ## copy Unix makefile
+ ln -s srcunx/unx.mak Makefile
+
+ ## respect CFLAGS
+ sed -i -e "s:^CFLAGS=-O :CFLAGS=${CFLAGS} :g" Makefile
+
+ ## run Makefile
+ make || die "Error compiling files."
+}
+
+src_install() {
+ dobin bin/gsview bin/epstool
+
+ insinto /usr/share/applications
+ newins srcunx/gvxhelp.txt gview
+
+ doman srcunx/gsview.1
+
+ dodoc gsview.css cdorder.txt regorder.txt LICENCE
+
+ if use doc
+ then
+ dohtml *.htm bin/*.htm
+ fi
+
+ insinto /etc/gsview
+ doins src/printer.ini
+}