summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-29 22:52:08 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-29 22:52:08 +0000
commitcce6de7f08001305df9ae2d8b11271feec29c714 (patch)
tree8428424d3c151ba1a3e912f950b12c7df965590f /app-text/mgv
parentnew version (diff)
downloadhistorical-cce6de7f08001305df9ae2d8b11271feec29c714.tar.gz
historical-cce6de7f08001305df9ae2d8b11271feec29c714.tar.bz2
historical-cce6de7f08001305df9ae2d8b11271feec29c714.zip
virtual/motif fix and compile fix
Diffstat (limited to 'app-text/mgv')
-rw-r--r--app-text/mgv/ChangeLog6
-rw-r--r--app-text/mgv/files/mgv-3.1.5-stderr.patch10
-rw-r--r--app-text/mgv/mgv-3.1.5.ebuild13
3 files changed, 26 insertions, 3 deletions
diff --git a/app-text/mgv/ChangeLog b/app-text/mgv/ChangeLog
index 27743e1ecc99..e8fa943f5953 100644
--- a/app-text/mgv/ChangeLog
+++ b/app-text/mgv/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for app-text/mgv
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mgv/ChangeLog,v 1.5 2003/02/12 05:32:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mgv/ChangeLog,v 1.6 2003/03/29 22:52:08 liquidx Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*mgv-3.1.5 (1 Feb 2002)
+ 29 Mar 2003; Alastair Tse <liquidx@gentoo.org> mgv-3.1.5.ebuild:
+ replacing openmotif with virtual/motif.
+ fix compile errors that no one came across because no one uses this :)
+
2 Aug 2002; phoen][x <phoenix@gentoo.org> mgv-3.1.5.ebuild :
Added LICENSE, KEYWORDS.
diff --git a/app-text/mgv/files/mgv-3.1.5-stderr.patch b/app-text/mgv/files/mgv-3.1.5-stderr.patch
new file mode 100644
index 000000000000..ba4595d423c0
--- /dev/null
+++ b/app-text/mgv/files/mgv-3.1.5-stderr.patch
@@ -0,0 +1,10 @@
+--- mgv-3.1.5/wlib/wlib/sanity.h 1998-08-27 04:22:41.000000000 +0100
++++ mgv-3.1.5-new/wlib/wlib/sanity.h 2003-03-29 22:13:37.000000000 +0000
+@@ -25,6 +25,7 @@
+ #define WLIB_SANITY_H
+ MU_HID(wlib_sanity_h, "$Mu: wlib/wlib/sanity.h 1.6 1998/08/27 03:22:41 $")
+
++#include <stdio.h>
+ #include <assert.h>
+
+ #define ARGSANITY(a,n) assert((size_t)(n) <= sizeof(a)/sizeof((a)[0]))
diff --git a/app-text/mgv/mgv-3.1.5.ebuild b/app-text/mgv/mgv-3.1.5.ebuild
index c8c6506569aa..c5f740f26d83 100644
--- a/app-text/mgv/mgv-3.1.5.ebuild
+++ b/app-text/mgv/mgv-3.1.5.ebuild
@@ -1,7 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# /home/cvsroot/gentoo-x86/skel.build,v 1.2 2001/02/15 18:17:31 achim Exp
-# $Header: /var/cvsroot/gentoo-x86/app-text/mgv/mgv-3.1.5.ebuild,v 1.14 2003/03/01 04:31:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mgv/mgv-3.1.5.ebuild,v 1.15 2003/03/29 22:52:08 liquidx Exp $
+
+inherit eutils
+
+IUSE=""
DESCRIPTION="Motif PostScript viewer loosely based on Ghostview"
SRC_URI="http://www.trends.net/~mu/srcs/${P}.tar.gz"
@@ -12,7 +16,12 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND=">=app-text/ghostscript-3.33
- x11-libs/openmotif"
+ virtual/motif"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-stderr.patch || die
+}
src_compile() {
econf || die