summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-03-05 22:28:37 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-03-05 22:28:37 +0000
commitfdd69ceaf4e91e0e994197167468175464d61fc8 (patch)
tree790abbd911631ed72f353b0be8c15324a394ba35 /app-text/rpl
parentBug 19303, ebuild provided by satya, cleaned up for proper license, src mirror (diff)
downloadhistorical-fdd69ceaf4e91e0e994197167468175464d61fc8.tar.gz
historical-fdd69ceaf4e91e0e994197167468175464d61fc8.tar.bz2
historical-fdd69ceaf4e91e0e994197167468175464d61fc8.zip
Patch to fix GCC4 compilation by node <nullcore@gmail.com> closes bug #121989.
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'app-text/rpl')
-rw-r--r--app-text/rpl/Manifest25
-rw-r--r--app-text/rpl/files/digest-rpl-1.4.02
-rw-r--r--app-text/rpl/files/rpl-1.4.0-gcc4.patch19
-rw-r--r--app-text/rpl/rpl-1.4.0.ebuild12
4 files changed, 54 insertions, 4 deletions
diff --git a/app-text/rpl/Manifest b/app-text/rpl/Manifest
index 4e4b1751e31d..2d855775ffa5 100644
--- a/app-text/rpl/Manifest
+++ b/app-text/rpl/Manifest
@@ -1,4 +1,25 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 cc5f71e56f0a54a7a5db7c53912a276a ChangeLog 1244
-MD5 f25f48d8febebe40b51c3b3b93458b89 rpl-1.4.0.ebuild 683
+RMD160 8d83d6f0f8d36c02283c01c237b13ef74ec5b1f5 ChangeLog 1244
+SHA256 8989f05df95132e8cf4bd68165dddeb2bc1ee02860ba8a575eb39affe16c8888 ChangeLog 1244
+MD5 108e66c8cc1d9feb5627065193a1eba1 files/digest-rpl-1.4.0 226
+RMD160 7c4358d4db2ff6baace0d35d6cd9ad48c22bb89a files/digest-rpl-1.4.0 226
+SHA256 9edfcb8c84a26d8a230995f01f3818acac1c4024b975707da40370bd99a7ec4d files/digest-rpl-1.4.0 226
+MD5 f4b75991fabd682583b911e4e36801ae files/rpl-1.4.0-gcc4.patch 949
+RMD160 72ffc12c037a3cbed95b155f3ad0f71850fd0d5b files/rpl-1.4.0-gcc4.patch 949
+SHA256 a1db2eae185ec82fa28a54312ba53154582304588f696985777fc1c57649f39c files/rpl-1.4.0-gcc4.patch 949
MD5 0c131a7201c4670302767f93643876fa metadata.xml 165
-MD5 54e293c83403000aebce56e26db932ad files/digest-rpl-1.4.0 60
+RMD160 c4557a3518a065b077539be5a0f20e4735fc2141 metadata.xml 165
+SHA256 75ca85c472d4181ae0de529c83826baaebe75d9e750ee6621758b5096bceffcd metadata.xml 165
+MD5 4ecbeb3a38e9199b20358d03e8e59b69 rpl-1.4.0.ebuild 776
+RMD160 0fe05707fa82ee1ea4a0a27ed97b6a70074c3b22 rpl-1.4.0.ebuild 776
+SHA256 8abc430bf589e4c44be8797560d239a96cada5588f5e365893da72d73cbdc614 rpl-1.4.0.ebuild 776
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.1 (GNU/Linux)
+
+iD8DBQFEC2Z6p5vW4rUFj5oRApaNAKDAZYpqSZWGJcadI1ioPbDQEeSAwgCfXo1V
+c3d50j4GYZtTAkEh1jKiEHo=
+=NC4H
+-----END PGP SIGNATURE-----
diff --git a/app-text/rpl/files/digest-rpl-1.4.0 b/app-text/rpl/files/digest-rpl-1.4.0
index 64ce7507ab64..d01c7d4b1f13 100644
--- a/app-text/rpl/files/digest-rpl-1.4.0
+++ b/app-text/rpl/files/digest-rpl-1.4.0
@@ -1 +1,3 @@
MD5 35af9ac5425f5a6278e5890c3272684e rpl-1.4.0.tar.gz 59602
+RMD160 e631f85d95c2c1bbb1f25f66cc7c08f55da07ab9 rpl-1.4.0.tar.gz 59602
+SHA256 f9ddb40ab3cf550d4ad1977f448f3b083035645a89ecba581bb57577a6c04caa rpl-1.4.0.tar.gz 59602
diff --git a/app-text/rpl/files/rpl-1.4.0-gcc4.patch b/app-text/rpl/files/rpl-1.4.0-gcc4.patch
new file mode 100644
index 000000000000..6cfb8c62627d
--- /dev/null
+++ b/app-text/rpl/files/rpl-1.4.0-gcc4.patch
@@ -0,0 +1,19 @@
+diff -Naur rpl-1.4.0-clean/src/replace.h rpl-1.4.0/src/replace.h
+--- rpl-1.4.0-clean/src/replace.h 2002-07-24 10:41:45.000000000 -0500
++++ rpl-1.4.0/src/replace.h 2006-02-19 16:38:32.000000000 -0500
+@@ -77,7 +77,7 @@
+
+ /* This is a simple macro to call malloc() and die if it returns null */
+ #define MALLOC_FAIL_STRING ("\n" PACKAGE " Unable to allocate memory!")
+-#define MALLOC_AND_CHECK( x, y ) (void*)(x)=malloc((y));if(x==NULL){fprintf(stderr,"\n%s --> %s:%d\n", MALLOC_FAIL_STRING, __FILE__, __LINE__ );exit(EX_OSERR);}
++#define MALLOC_AND_CHECK( x, y ) (x)=malloc((y));if(x==NULL){fprintf(stderr,"\n%s --> %s:%d\n", MALLOC_FAIL_STRING, __FILE__, __LINE__ );exit(EX_OSERR);}
+
+
+ /* Function Prototypes */
+@@ -90,4 +90,4 @@
+
+ static void EchoFeedback(int, int, int, char*);
+
+-static void SetPerms(struct stat, int, int, char*, int* );
+\ No newline at end of file
++static void SetPerms(struct stat, int, int, char*, int* );
diff --git a/app-text/rpl/rpl-1.4.0.ebuild b/app-text/rpl/rpl-1.4.0.ebuild
index 4e8420e6ffe1..c8c91dc98086 100644
--- a/app-text/rpl/rpl-1.4.0.ebuild
+++ b/app-text/rpl/rpl-1.4.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rpl/rpl-1.4.0.ebuild,v 1.18 2005/10/29 14:26:53 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rpl/rpl-1.4.0.ebuild,v 1.19 2006/03/05 22:28:37 chainsaw Exp $
+
+inherit eutils
DESCRIPTION="rpl is a UN*X text replacement utility. It will replace strings with new strings in multiple text files. It can work recursively"
HOMEPAGE="http://www.laffeycomputer.com/rpl.html"
@@ -13,6 +15,12 @@ IUSE=""
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc4.patch
+}
+
src_install () {
dobin src/rpl
doman man/rpl.1