summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 05:27:27 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 05:27:27 +0000
commit2fbf9a3d5d030ddd1d29b1d609c55f34dd50233b (patch)
treea47446a6710db501309f3047312dc9cb8606d806 /app-text/sablotron
parentNew packages for gnome-1.4_beta2 used in rc4 (diff)
downloadhistorical-2fbf9a3d5d030ddd1d29b1d609c55f34dd50233b.tar.gz
historical-2fbf9a3d5d030ddd1d29b1d609c55f34dd50233b.tar.bz2
historical-2fbf9a3d5d030ddd1d29b1d609c55f34dd50233b.zip
*** empty log message ***
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/files/digest-sablotron-0.511
-rw-r--r--app-text/sablotron/sablotron-0.51.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/sablotron/files/digest-sablotron-0.51 b/app-text/sablotron/files/digest-sablotron-0.51
new file mode 100644
index 000000000000..70ed002b83eb
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-0.51
@@ -0,0 +1 @@
+MD5 86e30805258a3f61e16796b5ef84b64a Sablot-0.51.tar.gz
diff --git a/app-text/sablotron/sablotron-0.51.ebuild b/app-text/sablotron/sablotron-0.51.ebuild
new file mode 100644
index 000000000000..82dd1cba011b
--- /dev/null
+++ b/app-text/sablotron/sablotron-0.51.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.51.ebuild,v 1.1 2001/03/06 05:27:27 achim Exp $
+
+A="Sablot-${PV}.tar.gz"
+S=${WORKDIR}/Sablot-${PV}
+DESCRIPTION="An XSLT Parser in C++"
+SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${A}"
+HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
+
+DEPEND=">=sys-devel/gcc-2.95.2 >=dev-libs/expat-1.95.1 virtual/glibc"
+
+src_unpack() {
+ unpack Sablot-${PV}.tar.gz
+ if [ "`use glibc22`" ]
+ then
+ cd ${S}/Sablot/engine
+ cp utf8.cpp utf8.cpp.orig
+ sed -e '44d;46d' utf8.cpp.orig > utf8.cpp
+ fi
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+ try pmake
+
+}
+
+src_install () {
+ cd ${S}
+ dodir /usr/lib
+ dodir /usr/include
+ dodir /usr/bin
+ try make prefix=${D}/usr install
+ dodoc README
+ dodoc Sablot/RELEASE Sablot/TODO
+}
+
+
+