summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-28 03:59:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-28 03:59:30 +0000
commit21917ca4bf0ba5a62865a75fd3c3113a5aa03a64 (patch)
tree1bf9fa56ae77a674e1cc217886a64b3237a3d019 /app-text/ttf2pt1
parentversion bump, and cleanup of old ebuilds (diff)
downloadhistorical-21917ca4bf0ba5a62865a75fd3c3113a5aa03a64.tar.gz
historical-21917ca4bf0ba5a62865a75fd3c3113a5aa03a64.tar.bz2
historical-21917ca4bf0ba5a62865a75fd3c3113a5aa03a64.zip
cleanup
Diffstat (limited to 'app-text/ttf2pt1')
-rw-r--r--app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild b/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild
index f3987159b57f..284801fdfc50 100644
--- a/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild
+++ b/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild
@@ -1,37 +1,35 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild,v 1.4 2001/08/11 04:42:31 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild,v 1.5 2002/04/28 03:59:30 seemant Exp $
-A=${P}.tgz
S=${WORKDIR}/${P}
DESCRIPTION="Converts True Type to Type 1 fonts"
-SRC_URI="http://download.sourceforge.net/ttf2pt1/${A}"
+SRC_URI="http://download.sourceforge.net/ttf2pt1/${P}.tgz"
HOMEPAGE="http://ttf2pt1.sourceforge.net"
RDEPEND="virtual/glibc
- >=media-libs/freetype-2.0"
+ >=media-libs/freetype-2.0"
DEPEND="$RDEPEND sys-devel/perl"
src_unpack() {
- unpack ${A}
- patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff
}
src_compile() {
- try make CFLAGS="${CFLAGS}" all
+ make CFLAGS="${CFLAGS}" all || die
}
src_install () {
- try make INSTDIR=${D}/usr install
- dodir /usr/share/doc/${PF}/html
- cd ${D}/usr/share/ttf2pt1
- rm -r app other
- mv *.html ../doc/${PF}/html
- mv [A-Z]* ../doc/${PF}
- prepalldocs
+ make INSTDIR=${D}/usr install || die
+ dodir /usr/share/doc/${PF}/html
+ cd ${D}/usr/share/ttf2pt1
+ rm -r app other
+ mv *.html ../doc/${PF}/html
+ mv [A-Z]* ../doc/${PF}
+ prepalldocs
}
-