summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2009-05-16 22:10:38 +0000
committerRyan Hill <rhill@gentoo.org>2009-05-16 22:10:38 +0000
commit83fdf26643e750c59db7486e6989a8ec4864d8d3 (patch)
tree2c73bf8b87b58b0bc83f437439bc9ae6e5967fd2 /app-text/xchm/xchm-1.16.ebuild
parentRestrict tests for gstreamer external plugins, they don't work with the split... (diff)
downloadhistorical-83fdf26643e750c59db7486e6989a8ec4864d8d3.tar.gz
historical-83fdf26643e750c59db7486e6989a8ec4864d8d3.tar.bz2
historical-83fdf26643e750c59db7486e6989a8ec4864d8d3.zip
Version bump.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'app-text/xchm/xchm-1.16.ebuild')
-rw-r--r--app-text/xchm/xchm-1.16.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-text/xchm/xchm-1.16.ebuild b/app-text/xchm/xchm-1.16.ebuild
new file mode 100644
index 000000000000..5e98701e4f60
--- /dev/null
+++ b/app-text/xchm/xchm-1.16.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/xchm-1.16.ebuild,v 1.1 2009/05/16 22:10:38 dirtyepic Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets flag-o-matic fdo-mime gnome2-utils
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="nls"
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:2.8"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ append-flags -fno-strict-aliasing
+}
+
+src_configure() {
+ econf ${myconf} \
+ $(use_enable nls) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}