summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-07-23 18:40:38 +0000
committerDan Armak <danarmak@gentoo.org>2001-07-23 18:40:38 +0000
commitee234b2a7fb323ce4b3a0408b8b536da03403a4f (patch)
treebf3f5d6cead1fbac97c998f6d0a27a6721ea8e7a /app-text
parent- looks like they updated the beta, without changing the tarball name. (diff)
downloadhistorical-ee234b2a7fb323ce4b3a0408b8b536da03403a4f.tar.gz
historical-ee234b2a7fb323ce4b3a0408b8b536da03403a4f.tar.bz2
historical-ee234b2a7fb323ce4b3a0408b8b536da03403a4f.zip
Added GNU enscript. In some situations a2ps is difficult to use.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enscript/enscript-1.6.1.ebuild41
-rw-r--r--app-text/enscript/files/digest-enscript-1.6.11
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/enscript/enscript-1.6.1.ebuild b/app-text/enscript/enscript-1.6.1.ebuild
new file mode 100644
index 000000000000..3eb2587ca641
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/enscript-1.6.1.ebuild,v 1.1 2001/07/23 18:40:38 danarmak Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.gnu.org/gnu/enscript/${P}.tar.gz"
+
+HOMEPAGE="http:/www.gnu.org/software/enscript/enscript.html"
+DESCRIPTION="GNU's enscript is a powerful text-to-postsript converter"
+
+DEPEND="sys-devel/flex sys-devel/bison"
+
+src_compile() {
+
+ confopts="--infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}"
+
+ try ./configure ${confopts}
+
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+ # I have no idea why, but the default config file isn't getting
+ # installed. Sometime I'll research that.
+ insinto /etc
+ doins ${S}/lib/enscript.cfg
+
+}
+
+pkg_postinst() {
+
+ echo "
+ Now, customize /etc/enscript.cfg.
+ "
+
+} \ No newline at end of file
diff --git a/app-text/enscript/files/digest-enscript-1.6.1 b/app-text/enscript/files/digest-enscript-1.6.1
new file mode 100644
index 000000000000..43b3d391d893
--- /dev/null
+++ b/app-text/enscript/files/digest-enscript-1.6.1
@@ -0,0 +1 @@
+MD5 5ebcd29011806fb038b088a6adbda8b2 enscript-1.6.1.tar.gz