summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-04-29 03:46:31 +0000
committerTim Harder <radhermit@gentoo.org>2011-04-29 03:46:31 +0000
commit4afced7e08d302d3ea527a3d638435f16bfa1c34 (patch)
tree2a03805234d0af6407140f2c76fc61614d39f08a /app-vim
parentVersion bump. Update to EAPI 4. (diff)
downloadhistorical-4afced7e08d302d3ea527a3d638435f16bfa1c34.tar.gz
historical-4afced7e08d302d3ea527a3d638435f16bfa1c34.tar.bz2
historical-4afced7e08d302d3ea527a3d638435f16bfa1c34.zip
Initial import.
Package-Manager: portage-2.2.0_alpha30/cvs/Linux x86_64
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/automatictexplugin/ChangeLog10
-rw-r--r--app-vim/automatictexplugin/Manifest18
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-9.3.5.ebuild24
-rw-r--r--app-vim/automatictexplugin/metadata.xml5
4 files changed, 57 insertions, 0 deletions
diff --git a/app-vim/automatictexplugin/ChangeLog b/app-vim/automatictexplugin/ChangeLog
new file mode 100644
index 000000000000..8a94d3a6c975
--- /dev/null
+++ b/app-vim/automatictexplugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/automatictexplugin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.1 2011/04/29 03:46:31 radhermit Exp $
+
+*automatictexplugin-9.3.5 (29 Apr 2011)
+
+ 29 Apr 2011; Tim Harder <radhermit@gentoo.org>
+ +automatictexplugin-9.3.5.ebuild, +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/automatictexplugin/Manifest b/app-vim/automatictexplugin/Manifest
new file mode 100644
index 000000000000..a182f52ca1ad
--- /dev/null
+++ b/app-vim/automatictexplugin/Manifest
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST AutomaticTexPlugin_9.3.5.tar.gz 287965 RMD160 c0b9cecfcd34b8a15e03fd0bbe657e5a1b12314d SHA1 561ddcd4103710b4c0604ff55e105161d77932a8 SHA256 8642ad46b835b1705e693c60dbb83f7d961912ab6f2e38b111fc473346f49e23
+EBUILD automatictexplugin-9.3.5.ebuild 699 RMD160 a1c3fd6fe87ce7d755cac1665186afa22c42bd88 SHA1 28d91f9d86b5471d311e56cc33d2602302f9ca9e SHA256 4561daf8eefc53e3099bbd68407b500c8480a2a2e5e5b08ce0804b0ec0053452
+MISC ChangeLog 388 RMD160 18644aa41cb50ff7f8da7e2a6209c3359c6b1bd1 SHA1 a37bcdc6819c293b8d3d1e5f9bb2f157d9b283b4 SHA256 18ad700022cc6757e2c75564174d6b799e60c6727b1b152e88496ebd884f9569
+MISC metadata.xml 157 RMD160 adcd6494e1e562ab5e0bd090e114622782ac753a SHA1 22983b8e9ba3045d8ccbc2b14393423f7f05d2ee SHA256 106c8618581360c66c2b535fcb7a6cb9ff318f1bd8e6c8f40f2f2f2d54e6787a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iQEcBAEBAgAGBQJNujSdAAoJEEqz6FtPBkyjrZMIAKUn1/yx3Kem4JhfIJg09LHN
+8voJTl/Y3Af8ObFDsyOSu1SqORIFTVSAT7NXBLNb4X8IjyAwWwcamxDWbe8gXlOv
+oc0+YtJBsM3mte+Bir+MV0bfmVaySDtgB1X4/4v8eJc6VpQjrHHNiTt7FbLCuwJm
+RG1YlpTaKJJFhqPYOxfnjR+ZIaDYZU4q5yQncNLDMKvMsK06gBXucCUyeLinawXf
+yEOd8FMc6pLckAq7ClxwmweoBxRqmCK5RsHKQ5jjkULIGmBRGPrv54dhGjuwIolU
+xkPwsytTlIEvQU35P/expO8sV0IFJKgGrDEgESjkQhewwj/0aOptplXpOxaUIxk=
+=ccMN
+-----END PGP SIGNATURE-----
diff --git a/app-vim/automatictexplugin/automatictexplugin-9.3.5.ebuild b/app-vim/automatictexplugin/automatictexplugin-9.3.5.ebuild
new file mode 100644
index 000000000000..61199c1f4f26
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-9.3.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-9.3.5.ebuild,v 1.1 2011/04/29 03:46:31 radhermit Exp $
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2945"
+SRC_URI="mirror://sourceforge/atp-vim/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="!app-vim/vim-latex
+ dev-tex/latexmk
+ app-text/wdiff"
diff --git a/app-vim/automatictexplugin/metadata.xml b/app-vim/automatictexplugin/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/automatictexplugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>