summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-06-05 18:59:32 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-06-05 18:59:32 +0000
commit62e9abe04c0c5588fee9141cdb5ee216e78ba8a9 (patch)
tree5ca6d5f9ee1a63bb06f4a2048c95d0efb5cda21a /dev-ada/booch_components/booch_components-20051222-r1.ebuild
parentpulled -r1 as it was decided not to do the LD_RUN_PATH after all (#111340) (diff)
downloadhistorical-62e9abe04c0c5588fee9141cdb5ee216e78ba8a9.tar.gz
historical-62e9abe04c0c5588fee9141cdb5ee216e78ba8a9.tar.bz2
historical-62e9abe04c0c5588fee9141cdb5ee216e78ba8a9.zip
pulled -r1 as it was decided not to do the LD_RUN_PATH after all (#111340)
Package-Manager: portage-2.1_rc4-r1
Diffstat (limited to 'dev-ada/booch_components/booch_components-20051222-r1.ebuild')
-rw-r--r--dev-ada/booch_components/booch_components-20051222-r1.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/dev-ada/booch_components/booch_components-20051222-r1.ebuild b/dev-ada/booch_components/booch_components-20051222-r1.ebuild
deleted file mode 100644
index 02b2a3c419ad..000000000000
--- a/dev-ada/booch_components/booch_components-20051222-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/booch_components/booch_components-20051222-r1.ebuild,v 1.1 2006/06/05 10:06:53 george Exp $
-
-IUSE="doc"
-
-inherit gnat
-
-My_PN="bc"
-S="${WORKDIR}/${My_PN}-${PV}"
-DESCRIPTION="Booch Components for Ada"
-SRC_URI="mirror://sourceforge/booch95/${My_PN}-${PV}.tgz
- mirror://sourceforge/booch95/${My_PN}-html-${PV}.zip"
-
-HOMEPAGE="http://booch95.sourceforge.net/"
-
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
-SLOT="0"
-
-RDEPEND="virtual/gnat
- >=app-admin/eselect-gnat-0.7"
-
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )"
-
-lib_compile() {
- cd ${SL}/GNAT
- make
-}
-
-lib_install() {
- # new style booch components install Debug and Release versions, we only
- # need the lib subdir of either
- mkdir -p ${DL}/Debug
- # both $SL and $DL are under ${WORKDIR}, so no dodir, doins...
- # (as lib_install is called from src_compile it is not safe to have $DL
- # under $D)
- mv ${SL}/GNAT/*-Release/lib/* ${DL}
- mv ${SL}/GNAT/*-Debug/lib/* ${DL}/Debug
-}
-
-src_install () {
- dodir "${AdalibSpecsDir}/${PN}"
- cd ${S}
- insinto "${AdalibSpecsDir}/${PN}"
- doins *.ad?
-
- #set up environment
- echo "ADA_OBJECTS_PATH=%DL%" > ${LibEnv}
- echo "ADA_INCLUDE_PATH=${AdalibSpecsDir}/${PN}" >> ${LibEnv}
- echo "LD_RUN_PATH=%DL%" >> ${LibEnv}
-
- gnat_src_install
-
- # Install documentation.
- dodoc COPYING README
- if use doc ; then
- einfo "installing docs"
- cd ${WORKDIR}
- dohtml *.html *.gif *.jpg
- cp coldframe-hash.* x.ada ${D}/usr/share/doc/${PF}/html
-
- cd ${S}
- dodir /usr/share/doc/${PF}/demo
- insinto /usr/share/doc/${PF}/demo
- doins demo/*
-
- dodir /usr/share/doc/${PF}/test
- insinto /usr/share/doc/${PF}/test
- doins test/*
- fi
-}
-
-pkg_postinst(){
- einfo "Updating gnat configuration to pick up ${PN} library..."
- eselect gnat update
- einfo "The envaironment has been set up to make gnat automatically find files in"
- einfo "Booch components. In order to immediately activate these settings please do"
- einfo "env-update"
- einfo "source /etc/profile"
- einfo "Otherwise the settings will become active next time you login"
-}